Thermostat Set Temp Issues

I’m not sure when this started happening, but I’m having an interesting issue with my Zwave thermostat (Trane) and my Gen 1 Smartthings Hub. Here is a description of what happens:

Anytime a command is given to change the temperature of the thermostat’s heating set point, the command goes through properly is set on the actual thermostat. The only problem is that in the smart things app, their is never a notification like “Thermostat setpoint is 55F.” So any smart app that checks the setpoint of the thermostat will not see the new setpoint. For example, if I remotely set the heat to 55F, hours later when I view the thermostat in the Smartthings app, it’ll show the actual temperature has been going towards 55F while the setpoint is at 70F for example. This would potentially indicate the heat is not working. That is not the case though, as soon as you refresh the thermostat device from within the app, a notification will finally say the thermostat setpoint was changed to what it was changed potentially hours ago.

TLDR; Thermostat heating setpoint isn’t seen in the “recently” tab or as a notification so all other apps think the setpoint is different than it actually is. Changing the thermostat remotely successfully changes the heating setpoint on the thermostat, but the new setpoint isn’t announced or made known anywhere else.

Any help would be greatly appreciated!

did it ever?

That does seem unlike my wifi-Tstat, Radio Thermostat device like that integrated by geko, Filtrete CT-30 . Which does log setpoint changes. So it is probably due to the device handler - maybe you could compare and tweak it.

The question that’s already been asked is a good one. Did it ever? (i.e., did the thermostat ever properly report the changed setpoints back to ST?) If not, then it’s possibly the thermostat because any properly-written DTH would have the response capability included.

Also, I have a CT-100 (Z-Wave) thermostat that writes the updated setpoint fairly quickly but still takes 25 seconds or so to acknowledge the change. I have webCoRE ensure that the setpoint changes have actually been made by comparing what I sent, versus the thermostat’s current setpoint. It tries to change and check the thermostat setpoints up to five times before giving up. In each cycle, I have webCoRE do a thermostat ‘refresh’ and a 25-second wait before checking the result.

Possible choices are:

  • The thermostat never reported the setpoint changes back to ST so it might be the thermostat or it’s z-wave module
  • The thermostat used to report back but now it doesn’t. That could mean:
    • The thermostat or it’s z-Wave module have gone bad
    • there is a communication issue within your Z-Wave mesh that’s only affecting transmissions from the thermostat (I think it might be this one)
1 Like

I’ve noticed the same thing with mine. I know it used to work because I wrote my own device handler for mine. It will refresh correctly if you manually tap the refresh button, There is supposed to be a scheduled 5 minute refresh for all of them except honeywell, but it appears that isn’t working.

This would indicate the the commands aren’t reaching the hub. Most thermostats will send this information but due to mesh or thermostat issues it doesn’t sometimes.

Things to try:

  1. Reboot hub and repair the Z-Wave mesh
  2. Reset the thermostat (this happens to CT-xx thermostats where they lose directional communication, ie. they only have one sided communications, a reset helps fix this)
  3. Run the thermostat on a C-Wire as now it’s in active listening mode rather than beaming mode as it can lose commands in beaming mode
    4.If you’re running in beaming mode try adding an active buffering repeater within 30ft of the thermostat

Thank you everyone for your replies. In the past the thermostat worked fine and always reported the change in set temp back to the hub. I’m not sure when it stopped doing that. I am unfortunately not at the home and won’t be for awhile as it’s an currently in use as an Airbnb. I used Webcore to make a piston that refreshes the thermostat every time the thermostat temperature changes but that’s not working. Maybe I’ll mess more with that. When I get access to the home again I think I’ll try to reset the thermostat or something.

I did a Zwave network repair but that didn’t help. The hub and thermostat are very close together and there are plenty of other devices that can act as repeaters. The only thing I should note is I have several devices that are unplugged but haven’t been removed from the Smartthings app. I’m not sure if that’d create any issues.

in the IDE, which device Type is you thermostat set to? Also, in the Classic app, try going into the settings for the thermostat and saving. That sometimes restarts the polling for changes.

The IDE lists the Thermostat as “Z-wave Thermostat.”

I tried your idea of doing into the settings for the thermostat and saving but so far no luck. It seems the only way to get the thermostat to report it’s settemp is to refresh it.

I only use the classic Smart things app with my V1 hub.

I just went through and deleted any device that wasn’t in use and did a Z-wave network repair. It finished in less than a minute with zero errors. But it doesn’t seem to have alleviated the problem.

At this point it may be worth getting in contact with support.

Thank you for your time. I’ve reached out to support.