Thermostat CT-22 Z Wave?


(esung) #1

Hello
Has anybody tried CT-22 (ebay link) with smart things? It says it’s a z-wave thermostat. If it works it would be a good deal.

Thanks


(Dave) #2

It’s not on the list of tested things (https://docs.google.com/spreadsheet/pub?key=0AugOGkst4zsvdDRSaU90WWpsMWIya2ZDaVBYbURYSWc&output=html), but if it’s zwave I’d think it’d work.


(esung) #3

I’d think so too Dave.
On the list there is CT-30 which says ‘Has U-Snap module which as long as its Z-Wave will work.’ on the comment section, and CT-22 on ebay page says it comes with a USnap as well.

"INCLUDES Z-WAVE FW 7.4 USNAP MODULE

The CT22 works with nearly any HVAC system- including traditional furnaces and heat pumps. Z-WAVE Router/Controller REQUIRED
The CT22 has an informative display showing room temperature and target temperature simultaneously.
The CT-22 can control up to 2 stages of heat and 2 stages of cool.
The CT-22 can be programmed up to 4 independent periods per day."

I guess I find it too good to be true price-wise.


(Different Computers) #4

Maybe this isn’t quite on topic, but if anyone has experience with a Z-wave/zigbee ST compatible thermostat that is known to work with Carrier Infinity heat pumps, I would be thrilled to hear about it.

Seems like 5 years ago when we updated our system, I unknowingly picked a real bastard of a proprietary HVAC control!


(Andrew Urman) #5

I remember someone using the Z-Wave USNAP module in the past but never had the chance to test it which its not on the list.


(esung) #6

CT-22 works with ST (as far as I can tell)

I took the plunge and ordered one. ST sees the device and now connected. I haven’t tried any other z-wave thermostats so I don’t know if it’s working to the full extent, but it seems to do as much as it can. Changing the heat setpoint changes target temperature on the thermostat, and that is all I need for now. (I only have heating and no fan or a/c)

The drawback I can see now is that the unit is rather ugly. It’s quite thick because of the usnap module housing and unless you make a hole and “plant” the unit into the wall it’ll look like it’s just slapped to the wall. But for $40 it’s a steal and now I have ability to control my home’s temperature from opposite side of the world. I’ll just have to try to look at ST app and not the unit itself.


(Matt) #7

CT-22 is working for me. Needs to have power to it, can’t run on batteries, like, I believe most smart thermostats.