The SmartThings routine for changing the desired air conditioning temperature does not work

Greetings to more experienced users.
I am asking you for advice.
To change the day and night temperature when heating the air conditioners, I wanted to use a routine with a temperature change of 19 ° C at night and 21 ° C during the day.
I see the routine in the SmartThings app history or report, but when I look at the air conditioning settings in the devices, the original temperature is still set. Routine-free direct temperature control works. It’s not just routine to change the temperature.
Even just setting up automation (routines):
if - time - 22:00
then - control the device - air conditioning - temperature - 19 ° C
Through the routine, I can only turn the air conditioning on and off depending on the temperature of the external sensor.
my device:
cassette air conditioning Wind Free Samsung AC052RN4DKG
Wifi kit MIM-H04EN
Aeotec Smart Home Hub - IM6001 V3P
Aeotec temperature sensor
mobile phone Samsung S21 ultra

Thank you very much for the advice.

can you post a screenshot of your routine/automation?

But I have it in Czech

Automation settings (routines):
9:00 climate on, mode - heat, fan - automatic, temperature - 21 ° C TEMPERATURE REMAINS 19 ° C

Does the push notification part of the routine work?

Yes, it works. I can even see it in the news and history of the application. But when I click on the AC device, the temperature is still set to the original value.

This may be similar to:

I know this doesn’t help with a solution right away. However, maybe having two instead of one will help get attention.

So you are looking at what SmartThings is reporting, right? Does the setting on the thermostat/AC device itself change?

It’s possible ST is sending the setting to the AC and it’s being applied, but ST isn’t polling the device to pick up the change. Not sure about your AC, but on a Honeywell thermostat, for example, I have to use the “Refresh” command to get ST to pick up the setting change, even though ST sent the change to start with.

But when I control the AC with an infrared controller, the temperature change of the ST application shows right away. And when I open the AC device, a sync ring appears, so it’s probably updating.
It seems to me like an application and air conditioning communication error.

So after a long time mysteriously solved.
I asked for advice at
1st advice to clear the SmartThings memory app, I did before, but for sure again and without change
So the 2nd question
2. Advice on your mobile phone to create error messages according to the instructions and send them to support
The answer is handed over to a professional service.
In the meantime, the S21 Ultra update and UI 4.0 have been released.
The next day, while testing how to tune the climate, I noticed that my climate had changed temperature from 19 ° C to 18 ° C, so I tried to change only the temperature through a routine and everything worked at once.
3. The next day, a support response came to update the application, so I’d rather not even comment.
So if it was an update or they changed something remotely according to the error message, I don’t know, but this works, but the advice didn’t help at all :slight_smile:
Thanks for your willingness and support.

1 Like