Temperature Routines running as Celsius vice Fahrenheit

This morning it was really cold in my place since the Thermostat was not in Heat Mode. Troubleshooting the situation, I saw on the log page that my Routine for It’s To Hot that sets the Thermostat to Cool Mode when the temperature is over 79 degrees fahrenheit had been constantly activating since yesterday so my Thermostat was in Cool Mode instead of Heat Mode even though the temperature was actually 66 degrees fahrenheit.

Troubleshooting this, I tried to create a new Routine using the same fahrenheit settings, but SmartThings would only let me pick up to a number up to just 50 for the temperature setting as the Trigger. So obviously it was thinking Celsius vice Fahrenheit!

I didn’t find anywhere in the SmartThings app to see the Fahrenheit or Celsius setting, so off to the IDE I went. I opened the IDE page for Location and selected my Home. I saw that the Temperature Scale was set to ‘F’ for Fahrenheit as it should be. Anyway, I selected ‘Edit’, toggled the Temperature Scale setting to ‘C’ and then toggled it back to ‘F’ again, then ‘Saved’ it. Now the SmartThings Routing Trigger setting is now allowing me to set the temperature setting above 50.

So, for whatever reason SmartThings all of a sudden was using Celsius numbers even though it was set to Fahrenheit which it has been set to for years! WOW!!!

Update: I’m not sure what’s going on, but at least the It’s Too Hot isn’t running, but the Thermostat temperature Trigger setting is not allowing me to select anything above 50 in Routines again.

Update: I didn’t do anything and now I can select temperature Trigger numbers above 50 again. Seems to be going back and forth between Fahrenheit and Celsius.

I noticed the same thing. I do not use ST to control my thermostat as it cannot set a permanent hold, but I was testing an automation in response to a community question last week and noticed that the setting was Celsius. Today, it is Fahrenheit.