Sync Status Pending Changes

I have a few Zooz zse42 water detectors. On one of them, it isn’t reporting battery %, and has a “sync status” of “1 Pending Change”. My others all report battery % and show the status as “synced”.

When I first open up this detector I also get the grey message “This device hasn’t updated all of its status information yet…”

If I try swiping down on the app screen when “inside” the device to try to refresh it, I get “There was a problem connecting. Try again later”

The device DOES work. If I trigger the sensors with water, it does send a “wet” signal.

I’ve tried excluding and reinstalling it more than once and always the same problem.

I’ve tried time…but even after 24hrs, the issue remains.

try rebooting your hub

Just tried that…unless it takes a while post hub reboot to update, it didn’t work.

It is assigned the same Edge driver as the ones that are working?

Yes. And it it the zooz specific driver for that device…not a generic one.

I’ve seen situations where this occurs and can be remedied by using a Routine to set/change some value in the settings. I have a virtual device that I keep around for various scenarios, including this one. I just create a Routine like “When virtual device turns on, then ‘set something on misbehaving device’”.

Awesome Idea, however in this situation, the devices are water sensors…so there are no parameters I can change via routine. I just tried this, and when I selected the “then” option in the routine, all the water detectors don’t even show up as an option to select. They only show up in the “if” section.

Darn. I thought they might at least have a setting for changing the wakeup interval.

If you open up the device and press the config button 4 times, does that sync all the changes?

nope. Tried that multiple times all with no luck.

So to close the loop on this topic…no actions on my end were able to force the sync.

The device did, however, sync itself after about 4 days. Not sure why it took so long, but it is sync’d now and is reporting battery percentage.

How odd.

A few notes:

  • The zse42 has a default wake up of 12 hours and supports changing the wake up interval (according to the manual anyway.) I’m surprised the official Zooz driver doesn’t have a preference for changing it. Kevin’s drivers usually do.
  • As it’s a zwave sleepy device, doing a refresh (pull down in the app) really does nothing. The device isn’t listening even if the hub sent out any “send me all your current data” type messages.
  • The device should sync any parameter or configuration changes on wake up. That’s what the counter is trying to show, how many are pending.
  • Some attributes may not be refreshed every wake up, only when they change. For instance, battery level.
  • However, drivers should set an initial value for all attributes on the device include (or after a driver change). That way the UI doesn’t complain that “the device hasn’t updated all of its status information yet” until an update from the device (unsolicited or during wake up).
  • Rebooting the hub wouldn’t help solve the issue. Doesn’t hurt anything either.