Sylvania Lightify Motion Sensor


(Pete_ST) #21

Hi,

Since there is no published device handler for this motion sensor you need to create your own one locally using IDE, https://graph.api.smartthings.com , What I did was I copied device handler code from Samsung Smartthings motion detector, just changed the name of the handler and saved in locally and used this device handler for my Sylvania motion and temperature sensor and it started to work!


(Zbug) #22

I can’t seem to find the Samsung Smartthings motion detector device handle in the IDE “type” drop down. Where should I be looking for it to copy locally.


(Zbug) #23

I went to GitHub and used a few “Samsung Smartthings motion detector” dhc’s and am able to get battery info but nothing else. I should be able to obtain temp as well as get alerted to motion. Interesting thing is that with the new device handle, the motion sensor turns pink when sensing motion, but never notified the hub / ST app.
If anyone have the like they used for the dhc’s which works please respond back.
Thanks for your help and guidance in advance!
Dan


(Pete_ST) #24

My Device Handlers -> Create New Device Handler -> From Template -> SmartSense Motion Sensor -> Create


(Sunil K) #25

Were you or anyone else able to make it work ? I tried to connect mine and it connected as a “Thing”. Changed to the IDE device type to “SmartSense Motion Sensor” and it did not work. Then I made a copy of my own using the code and removed/readded the device, changed to this new device handler - but it does not report anything back to ST.

The device is currently showing a PINK color on motion. Please help.


(Christos) #26

I got it working without a custom DTH. Here is what I did:

  • First I let the Smartthings App recognize it as a Thing

  • Then I logged into the IDE (Web interface of Startthings) and selected My Devices from the menu

  • Clicked on the device (Named “Thing”) to bring up the device properties page.

  • Scrolled all the way to the bottom and clicked on “Edit”

  • Changed the Type to SmartSense Motion Sensor

  • Changed the Label to Sylvania Motion Sensor

  • Clicked on Update to save the changes.

  • Went back to the ST App and selected Home.

The Sensor is now identified as a motion and temperature sensor. It detects motion within 30 seconds (no 3 minute wait like other sensors I have tried). The temperature is very accurate as well.
So far it has been working great for over 2 hours. If anything changes I will post an update.

Hope this works for you.


Lightify Motion sensors--any DTH?
(Max Tay) #27

@Chris75
Tried your method and got first one to work perfectly. Tried a second sensor but this time it doesn’t seems to work properly. It doesn’t return temperature on the app and motion detection tile is always ON on the app display.


(Max Tay) #28

Working now after three attempts. First change device type to SmartSense Motion Sensor. Then remove device from device list. Reset Sensor. Add new Sensor and found “Thing”. Edit device type of “Thing” to SmartSense Motion Sensor. Works fine now.


#29

What appeared to work for me:

Click the + to add a new device in ST
Pull the battery tab on the Sylvania Motion sensor
It’s discovered as a “thing”
Log into the IDE and change the handler to Smartsense Motion Sensor and save.
remove battery from motion sensor
Click the + to rediscover new devices
Put battery back into motion sensor
verify in the ide that you see temp and batt data from the device
click X to cancel discover devices on your phone. It won’t have found anything, but somehow this makes the device work fully, rather than being stuck in the motion on, and no temp or batt data state.

This sensor has a nice build quality. Very similar in appearance to the Iris/Centralite one from Lowes, but a little sturdier.


#30

This is exactly what worked for me. I just pulled the battery out before I saved the settings in the IDE.


(Steve) #31

This worked for me as well! Thanks!


(Bill) #32

I just tried this and what I see for states in the ide are “battery” and “checkinterval”. I don’t see anything for temperature. Any ideas?


(Otávio Ribeiro) #33

I’m stuck. Not been able to factory reset two of them. Tried everything I found. Press for 10 seconds. Remove and reinsert battery pressing the button. The led never blinked blue any more. Smartthings do not find them neighter as a Thing.

Did someone face this issue? What can I do to make them work again?

Thanks


(Andrey Glavchev) #34

Did you manage to reset yours? The same happened to mine 2 days ago. Now it appears to be dead. No blink, nothing. Pressing the button or removing the battery does not help either. The battery indication is always stuck at 78%. I checked whether the battery is dead - it measures 3.02 volts. Should be good.