Sylvania LIGHTIFY 74099 ZigBee 4-button switch

The lightify gateway does not link with the smartthings hub. Each is a primary zigbee coordinator, and you can only have one of those on a network. So it’s very different than, say, the Phillips hue bridge where the bridge itself allows integration with other systems.

Can’t tie them together so one can pass commands to the other? IE tell smartthings throuhgh routines/scenes to turn on the bedroom lights and have it throw the command to the lightify gateway to turn those lights on that are under its control?

No. They can’t both be on the same network. And each bulb can only belong to one network. So you have to choose one or the other.

I’m not saying bind the bulbs to both networks(nothing really supports that, you can do it with PCs but need multiple network cards). But rather let the two hubs talk to each other and let one tell the other “hey, turn these bulbs on”. If no, they can’t talk to each other and cooperate… come on ST and Osram, GET TOGETHER!

The two hubs don’t talk to each other. That’s a decision that Osram/Sylvania has made, so write to their support department and tell them you would like to see more third-party integrations. They don’t even have an IFTTT channel for their Gateway. :disappointed_relieved:

Not tried the button yet but I’ve achieved this for bulbs with eventghost as middle man.
Using simulated switches and dimmers in ST they trigger eventghost and using a python script it runs Lightify’s API to control the bulbs. It also updates the ST switch when Lightify changes using ST’s API.
I did have the bulbs connected directly to ST but response was really slow when trying to do a colour change routine for Xmas/ alarm and the Lightify app has some nice colour change effects and can group bulbs together.
I have got a Lightify button, I try and see if works.

1 Like

since you guys already have it and i wanna buy it, i think i found a solution over an amazon review. Can you guys try it out?

the butons that you have to press for 3 sec are the top right and botton left

if you need to reset it, you press the top left and botton right for 10 sec.

1 Like

I will try it, but I’m 99% certain that it will not work with the US Version. SmartThings simply does not register a button press for 2 of 4 buttons.

Did it work?

Just tried this, still no luck. Smartthings only sees 1 and 2, so it can’t trigger the other actions. Pushed and held works, so it’s still a cheap 2 button 4 function remote.

1 Like

This makes no sense, it being what it is, it should be sending a signal on each button, so there must be a way to see the packets for buttons 3/4 - no? Even if they are ignored by ST, they should be there… This is very odd.

Meanwhile, how do you disable the broadcast on/off for ALL zigbee devices on buttons 1 and 2? This is very odd in itself - but it seems to bypass the ST hub and send signal directly to all zigbee devices, kind of like Z-Wave association - but I did not think Zigbee had this sort of capability… though it would be nice if it did…

Odd device…

Zigbee has groupcasting (Among other things, that’s how the hue dimmer switch communicates to multiple bulbs at once), but the last time I looked smartthings had not implemented it for its hubs.

Similarly, Smartthings has not implemented all of zigbee’s multiple endpoint capabilities, which is why you can run into issues with a lot of devices of this type.

Also, Osram In Europe and Sylvania in the US do not use the same zigbee firmware even though the devices look identical. This has been true from their very first smart device offerings. In Europe they have decided to mostly follow whatever Phillips uses for Hue, which has led them to ZLL and then zigbee 3.0 . In the US, they had different competitors, mostly for the commercial building space, and they adopted the zigbee home automation ( ZHA) profile instead.

So this is on ST. :frowning:
Any way to disable group-casting (or change group) on the switch, so that we can at least use the two buttons that “work”?

And, stupid question but begs asking - can we load European firmware on US hardware?

That just depends on the individual devices, and I don’t have one of these. Hopefully Someone else can look into it.

And, stupid question but begs asking - can we load European firmware on US hardware?

Not as individual consumers. You would have to talk to Sylvania support and you would probably have to have their gateway, but I haven’t heard of them making The out of region firmware available for the switches.

Early on they did make it available for their smart bulbs for a year or two, but then they stopped doing that, I think because of some organizational issues between the two regions (it was Around the time when they changed the name from lightify.)

Anyway, you can try asking Sylvania support and see what they say.

Thanks, If I get some time, I will try to play around with it. I just got one of those since they are $9 on amazon (and now I know why) - but I should be able to set up a parallel ZHA network and examine what is actually being sent. Wish there was some documentation about this device’s internals…

Thanks again.

1 Like

I tried to test mine, but it keeps ripping through batteries in 5-7 days. So I gave up and threw it out.

Interesting, I have several of their two button ones and those seem to work great. I wonder why these are so much more problematic…

I also have the US version, has anyone else noticed that the first tap of button 1 does not always register and send a signal? No green light will flash, especially if the tap is quick. It’s like the device is asleep and has to be woken up before accepting a proper button push. Frustrating!

I’m having problems even pairing the device. I tried holding down the top right and bottom left for three seconds but the led does not turn blue let alone pair. Anyone have any tips?

Thank you!

You actually need to hold down for a little over 10 seconds. If that doesn’t work press the top right corner and bottom left corner quickly (to wake it up, I had this issue on one of mine) and then immediately hold the same 2 buttons down for longer than 10 seconds (until the light starts flashing).