SmartThings Community

Switch to turn on Alexa Group

(Ron Talley) #9

Have you actually tried this? Did it not work?

(Matt) #10

yeah it turns on the switch but does not turn on the group. I need an ST switch to trigger an Alexa group

(Ron Talley) #11

But it doesn’t turn on the switch in the other HA System?

This is not possible.

(Nathan Curtis) #12

How about we approach this a different way. What is the other HA system? The community is VERY good at integrating various systems. Let’s start there.

(Matt) #13

the other is Hubitat. All local processing and am trying it out.

(Ron Talley) #14

Thread here. Some have gotten ST to talk to Hubitat and visa-versa…

1 Like
(Glen King) #15

It can do basic ‘automation’… but any such automations stem from a voice command, not from a condition being met.

1 Like
(Ron Talley) #16

Not to push back too much but Alexa Routines can also be triggered in the Alexa App based on a Scheduled Time. But yeah, still very basic compared to what you can do with a true HA System.

1 Like
#17
1 Like
(Dan) #18

Today, you can get your Hubitat devices to show up in ST and control them from ST. This might get you what you need.

Details in this thread

https://community.hubitat.com/t/best-practices-for-migration/84/36?u=ogiewon

2 Likes
(Matt) #19

I did. Could it be that I used a different Email account for my Hubitat account than my ST account?

(Dan) #20

No, that should not make any difference. The ST-side of things is simply discovering devices (only a subset are supported) via the Hubitat “Hue Bridge” device. That is what creates the child devices. The ST-side SmartApp is simply an OUATH endpoint which listens for device status updates coming from the Hubitat-side App. The Hubitat-side App needs to know the OAUTH endpoint URL of the ST-Side app so it can send updates. Your account credentials are never used.

Both the ST Hub and the Hubitat Hub need to be on the same network for the discovery to work. Also, it takes a while after you press the REFRESH button in the ST-Side Hue Device for the devices to be discovered. Be patient. The Amazon Alexa uses the same discovery mechanism. Do you have one? Are the Hubitat devices showing up in Alexa? If so, I would think that @krlaframboise 's code should work as well.

1 Like
#21

With the increasing popularity of Wi-Fi mesh systems we should also note that they may need to be not just on the same network but on the same branch, depending on the exact Wi-Fi system being used.

1 Like
(Matt) #22

Yes I have Alexa nd it works great. They are on the same lan together and I have selected three devices in the Hubitat app.

This is what I get in the st hue

(Dan) #23

Hmmmm… for me, I just clicked refresh and waited a minute or two, and the child devices appeared. Did you remember to Publish the child devices?

(Matt) #24



(Matt) #25

and I get this in the logs


image

(Matt) #26

should it show my hubs IP in the ST Device?
image

(Matt) #27

ok now it is giving me feeds in the IDE but still no devices in the app or DH
image

(Matt) #28

I am getting stuff from Hubitat in the DH and in the App but still no devices discovered.

image