Sudden DTH error from both Homeseer HSM200 sensors

I’ve had my ST network up and running for about 3 months without issue. Three weeks ago I added two Homeseer HSM200 multipurpose sensors to the network, along with a few smartapps that interact with them. I noticed earlier this week, Tuesday I think, that something was wrong.

One of the smartapps I’ve created turns the LED on the HSM200 devices red if my garage door is open at sunset. This worked perfectly for the first few days. I noticed, as I said, early this week that this smartapp was no longer working. The LEDs were no longer turning red if the garage door was open.

After some trial-and-error I discovered that I can’t interact with either HSM200 in any way. When initially installed, I could open either HSM200 device under “My Devices” and choose an LED color from the color palette. The LEDs would change as expected. That no longer works. In fact, none of the device controls work. I can’t turn the on/off, can’t change colors. I can’t even rename the device - the message “An unexpected error has occurred” is displayed.

Further experimentation from the smartapps side of things finally revealed an error message. Every attempt to send a command to either HSM200 throws a long string of errors, this one being the most clear: “DTH version mismatch for id:9481f564-5696-4296-b2b0-ac8b6731e7a8 and version:1”.

To make this even more interesting, if I go to the web IDE and try to rename either HSM200, I get the same error: “DTH version mismatch for id:9481f564-5696-4296-b2b0-ac8b6731e7a8 and version:1”,

I’ve removed and readded both devices multiple times with no effect. I don’t know what to do next. Help!?!?!?

I recommend emailing Support @

I recently ran into this when renaming devices. It seems that the controller still caches old names/references. A reboot of my Smartthings hub cleared it up, but definitely an unfortunate bug to run into.

If it still exists, make sure you delete all devices from the device list (that access the smartapp), remove the smartapp from any hubs (Click the x next to each location in the properties of the smartapp), refresh any browser windows, and restart the Hub again.