Stuck - Things not found, no support, hub losing connection, account won't save - First hour with ST


I’m turning to the wonderful people in this community as I’m feeling rather lost and a little worried. I finally was able to get some time this afternoon to install my ST hub. While some pieces were very smooth, overall, I’m completely stuck and unable to move forward. I don’t know what to do and multiple attempts to contact chat went on with me getting connected, giving detailed info for what happened, and never getting a single response.

Here are my issues:

Finally have the app setup and it won’t find a single “thing” I try over and over to connect following the instructions specifically, using the detailed page that says exactly what I’m connecting (rather than the general connect), and it just sits there spinning on and on with nothing actually connecting. So, I literally can’t move forward.

My hub has lost connection with the ST server multiple times already and it’s only been connected an hour or so. I’ve had to power cycle to get it back after waiting a long time (much longer than the 5 minutes stated in the support). This is after it’s downloaded the firmware and fully setup with a solid connection. My internet connection is a rock solid 50/12 and will generally be a bit faster than stated. My router is extremely solid and reliable and I don’t have other connected items disconnecting on me. ST isn’t plugged into any switch but directly into the back of the router as I didn’t want to risk reducing latency, etc.

When creating my location, I got an error saying something along the lines of “location created but missing a mobile device”. I’m not sure what that means. I tried to go back and create the location again but always received the same error. I decided to try just sorting out once I make it through setup.

Once setup was basically done, I went back into my location to try to see if anything was looking amiss. I couldn’t see anything but when I tried to leave, I got an error that my changes hadn’t been saved. I attempted to save the settings and got a page with a spinning circle in the middle for many minutes until it switched back to my account page. Trying to leave again was greeted with yet another warning that nothing had been saved so obviously, the save features is also failing. I finally had to just leave it all as it is just to get out of that page as I went through trying to save things over and over.

So, I’m completely stuck. I’m a little worried at so many things I can’t get working. Most are somewhat small but not being able to connect “things” isn’t small. I’m not what I consider an advanced tech person but I’m the one that any of my friends call to do anything from setup a A/V system to fixing a computer. I’m not a total dummy on it. If I’m having this many issues so quickly what happens to the rest of the population? The quick start guide saying that it’s super simple and easy is a bit oversimplified, to say the least.

Any help anyone can give me on any of this would be so wonderful. Not being able to get in touch with support is quite scary. I read through all the installation help in the FAQ/Knowledgebase before getting started but it definitely didn’t prepare me for this process. Even after learning about this for more than a year.

Thanks so much. I’m so grateful for the people in this community.

There is a problem with SmartThings cloud right at the moment, and you probably ran into some of this. You can check status at I’d wait until we get the all clear, and then see if things don’t go better.

1 Like

Yeah, today is not a good day to get started.

1 Like

OK. Don’t know it that’s comforting or frightening.

Could this be a reason why I cannot connect things? Specifically a SmartThings switch/outlet? Or why I’m getting other errors? I don’t know what all would be affected and if I have a connection to the ST server when trying to connect, I would think it should still find my devices. Which I have had when trying to find my devices/things. But I wondered if I still might get strange errors given the issues going on.

I did finally manage to get it to find my lights but nothing else yet. At least it’s a positive step. I’ll continue to watch the outage link.

Devices get connected to the local controller, which is inside the plastic box, but they have to be recorded to your account information, which is in the cloud. So who knows what will happen if you try to add devices while the platform is having problems. Best to just wait until it’s stable again.

1 Like

I am SO GLAD I went back to the default lock after 30 seconds and setting multiple local codes in the Z-Wave lock firmware.

It is a sad day as we used to use SmartThings to only lock the door after it closed and send lock codes to the lock for temporary access.

With the cloud failing routinely, and manual hub reboots when we are out of town, it was undependable. I have gone back to the way it was over two years ago!

What a waste of an investment.