Stuck in Download device controller loop

I updated the app on my Iphone to 1.6.69-546 and now when I try to go into any device (I have around 120 devices) it spins for about 30 seconds and then I get a message:

“Download device controller? To use all the features of this device a controller needs to be downloaded”

I hit download and the device displays “Downloading” for about 20 seconds and goes away. I then tap the device and the “Download device controller” message just pops up again.

So far I have tried to log out of the app and back in and I checked for device and app updates in the IDE and did not see any. I also looked at the live logs in the IDE and did not see anything unusual.

Anyone else see this?



You will not find anything in IDE since it is an update for the app. :slight_smile:

You will probably need to uninstall/reinstall the app.

I just tried removing and reinstalling the App with no change. When I tap on a device (physical or virtual) it spins for 30 seconds and pops up “Download device controller? To use all the features of this device a controller needs to be downloaded”. I hit download and the device displays “Downloading” for about 20 seconds and goes away. I then tap the device and the “Download device controller” message just pops up again.

i had something like this happen with one of my android phones that did not have a sim card and was just using it with wifi. once i put a working sim card in it and started it and ran the st app and then took out the sim then ST worked going into device detail.

I know you said it’s affecting all of your devices, but could you give us a couple of specific examples?

I did run into this once on a cloud to cloud integration with a Meross device where it turned out that the device itself needed an update through the Meross app before it could move forward with the integration update.

That could only come up with cloud cloud integrations, I believe, so if you were seeing it on zwave or Zigbee hub connected devices it would be something else that just happens to have the same symptoms. But I just thought I’d mention it. :thinking:

I’m also stuck in this same loop. Ever since Samsung Family Hub discontinued its bespoke smart fridge app and defaulted to SmartThings’ app I’ve experienced a lot of bugs with this app. Not to mention its features pale in comparison to the marketing materials and original app that led us to buy this fridge. Currently the SmartThings app continues to ask for the device controller download, can’t show inside the fridge and won’t upload photos. I reached out to SmartThings customer service two weeks ago and never heard back.

Was any resolution found? I am having the same issue with all my devices. My automations work but not the individual devices. Download device controller? To use all features…

I click download and it goes back to the screen.


1 Like

Which platform are you using… iOS or Android?

I’ve noticed the same behavior in ST for iOS

1 Like

Noticing the very same thing.

1 Like

There is a notice on the status page that the device controller problem occurring on 5 May 2022 has now been identified and fixed.

1 Like

YES! Finally - it is working. I had sent in a ticket, and they just told me to delete and reinstall the app, which did nothing.

1 Like

Some of my devices such Schlage deadbolts are struck downloading. This prevents automations such as status of one unlocks/locks the other. Any ideas, this is new after 5 years of normal operation.

if iOS, try force quitting the app
if Android,try clearing the cache for the app

It has been a year and I still have this problem as well. Force closing the app, logging off/on, reinstalling does not resolve the problem. The only solution I have found (which also leads me to believe I know the cause) is to force close the app, disconnect from my home wifi, connect to cellular data only, and then launch the app on cellular data only. Works every time. This leads me to believe that my home firewall is blocking either a county (I have geo-blocking enable) or some kind of traffic that is important to SmartThings. I have not been able to find out for sure what traffic, IP’s, or countries need firewall exceptions created for the SmartThings App to work properly so I have just lived for a year now with when I want to use the SmartThings app to disconnect from my internal wifi and make sure I have good cellular data reception before using app.


Was there any resolution to this? I have the same issue :frowning:

Small Background

  • I reached out to SmartThings Support Team. They gave me many suggestions on how to reset the hub, etc, etc. They did mention that the Hub cannot connect to 192.168.42.xx subnet.

  • I looked at my network configuration, and my network subnet was running on 192.168.50.xx range. Although the network IP range is not exactly the same (as mentioned by the Support Team), it was still in the same class (Class C Network).


  • I changed the DHCP in my router to a Class B Subnet range. Now I run on 172.16.53.xx range.
  • Once the network IP range was changed & internet was running, I had reset the SmartThings Hub again
  • Post the reset, connected the hub via Ethernet and started the discovery process in the SmartThings App.
  • The hub was discovered as everytime, but something was different. Post discovery, the hub registration took about 40 seconds, compared to 5 seconds during failed attempts.
  • After registration, there were a few updates downloaded on the hub, during this time the light on the Hub changed from flashing Red/Green to blinking Blue and then solid green. It is possible that hub got the new settings and was rebooting to apply them
  • The process on the SmartThings App completed & the hub was now successfully connected.

I can see the hub in SmartThings App as well as on

Root Cause

  • SmarThing Hub cannot connect to a network running Class C Network (192 - 233 IP range)
  • The error on the SmartThing Mobile App - Couldn’t download device controller. Try again by tapping the device card is misleading. It should be more meaningful such as Network Subnet not supported or something on similar lines.

I hope this helps someone in the future

1 Like

Anyone experiencing this problem with iPhone? I’ve reinstalled,reset the app but it’s still not working

Me too . Did you find the solution for iphone