Stuck at "Setting up hub"

I initiated a chat with support late yesterday, and referenced my ticket (which also referenced this thread). They basically just verified information about my hub, and said that some others are also affected by it, that they are working on it.

This is my first smart home hub type device, so I was excited to play around with it when it was delivered… kinda sucks that this has happened, and concerns me about being dependent on cloud services.

Same problem here. Light stays blue. The hub is detected on the web portal but shows inactive.

1 Like

I have the same problem, light is green but can’t hit “next”. Awaiting response from support

I gave “ricnic” troubleshooting tips a shot but no success, the Hub appears to be offline on the SmartThings’s app and inactive on the IDE. Did anyone get it to work?

Same issue. Hub light green, but it shows hub is offline

Same problem here, solid green lights. I’ve been talking with tech and a new one is one the way… Some problem with how the hub updates when it first connects is not working properly…

If your lights are solid blue, that’s likely related to a network issue (firewall, blocked outbound port) on your end - it means it’s not reaching their servers. Try power cycling your router, then power cycling the hub.

After working with support for a few days, they are just sending me a new hub.

Got my hub yesterday and have the same issue. Solid green lights, did a suggested reset and still hub is offline and inactive on website.

Still got nothing! Green light on the hub and offline on the app. Shouldn’t have deleted my current hub before setting up v2.0.
I did not receive a response from support either.

Send them a message on the live chat, they are very responsive there. I ended up needing a new hub, so if you’re the same as me you want to get that process going ASAP. Especially since it sounds like you have an existing set of devices, at least I’m an all-new customer so I am not at a loss of functionality right now.

1 Like

Live chat opens at 9 so will chat with them when they open.

1 Like

I’experiencing exactly the same issue and battling for 4 days now…I have tried all the tricks mentioned in this thread and still get stucked in that looping circle. Really frustrating for a brand new gadget does not work the first time and support/information not readily available…Also no chat available on the specified hours…just email. Finally I got a response yesterday after 2 days of waiting.asking for my hub’s MAC and S/N…of course I will have to wait again for the next answer. Looks like pranalli is getting a new hub…did they explain on what is the issue? Do I have to send this one before they send a new one? A memo of of some sort on bad batch would have been helpful…Sorry for venting frustrations here

1 Like

Got it all figured out via SmartThing’s live chat (as I did not get response via email). It appears that some of the Hub’s are defective and need to be replaced, so they will send out a replacement unit next week. It is unfortunate that I found out after I removed my older Hub from my SmartThing’s account.

1 Like

Got a new hub shipped to me also. Hopefully it will resolve communication issue.

Add me to the list for being stuck @ “Setting Up Hub”. I have contacted support but have not made any progress. So far here is what I know -

  • Hub connects to local network, gets IP address and responds to Pings.
  • Hub connected at least once to the smartthings network as evidenced by hub being listed on
  • I have disconnected the hub, removed the batteries, waited a couple of minutes and then reconnected the hub to first my switch, then direct to the router and finally directly to the cable modem. Removed batteries & rebooted on each move.
  • As suggested by ST Support, I reserved an IP for the hub and then added port forwarding to it on ports 37, 39500, 11111, and 9443.
  • Support also requested that I whitelist the following domains on my LAN. I have NOT been able to do this.

I am currently waiting on the next step, but really feel the problem may be on their end. I feel that if something on my LAN or router was preventing connection, I should have seen the hub connect when connected directly to the cable modem and my LAN was disconnected. Anyway, still waiting and wondering.

Same here, hub just didn’t work. Solid blue lights. The hub was not block at all by my router, via viewing my router logs. They ended up putting me down to get a new hub instead of waiting for a fix (they had no timeline for the fix). Hope it all works out. This is my first attempt into home automation instead of getting the vera.

I did all of above, including whitelist. Still didn’t work

My hub got the green light but it still did not appear on the app. Did you get in touch with support? I contacted them via live chat this morning and I have a replacement scheduled to arrive on Monday.

sigh, exact same issue here. Hub boots and I get a green steady light. App stuck at setting up your hub…just emailed support.