Stuck at "Setting up hub"

Yep 000D, still waiting for support to get back to me :disappointed:

Yes, mine says 000D as well. I did delete the hub and readd it last night which worked but I"m still having the same problems. Nothing will pair with the hub. Support was being very responsive for a short time with me last night, but then they stopped responding. It detected my GE Link Bulb ONCE but it saw it as a Zwave Switch (and it’s a Zigbee dimmer) and nothing worked. Support tried changing the device type but nothing worked still. Then they asked me to reset the bulb and try re-pairing it with the hub, which I have been unabled to do since and they also stopped responding to me.

After that I figured well let me try one of the official sensors, surely they will work. Put the open/closed sensor on the shelf right next to the hub and nothing.

I checked with a friend with a V1 hub and his hardwareId is “0001”, so I don’t think there’s any significance to ours being “000D”. Nevertheless, I really want to hear from Smartthings about how I can get this thing working!

I am having the same issue, but my lights are a constant blue. After power cycling router and Hub still the same. My outgoing log shows it is communicating under port 9443. But no green lights. I did contact support last night , but no response.

My hardwareID:0006. Still nothing and constant blue LEDs

No response from support here as well. Even the chat support in the app said no one was available…to email support. I don’t really have a good first impression so far. For a device tied to cloud services, you’d think they’d have a robust support team.

I’m still waiting for support to get back to me. Heard nothing from the UK email address all day. The US support emailed me last night and I’m waiting for them to reply when they start in the morning.

The live chat link for the UK just goes to the samsung website which doesn’t list smart things as an option for support!

I have the same problem too.

Hi all,

This seems to be an impacting incident. I recommend to get in touch with @April and @Ben for this.

Definitely reach out to for that.

:slight_smile: They’re quite the best crew - and admittedly, better response times than @ben and me. If you haven’t heard from them yet, it’s because there’s people in front of the queue. They’ll get to you as soon as they can.


1 Like

Thanks @April, is this the recommended approach for UK customers too or is there a different support email? I’m having the issue described above.


Whoops - for the UK , the best email to go to is : :slight_smile: Please send my regards to the strong and awesome support team currently at the UK - Aaron + Blake (who’s from the US but currently in the front lines at UK!), and Tom - who was just recently introduced to a chipotle burrito for the first time today ;).

1 Like

An excellent food choice by Tom there.

For anyone else finding this thread I managed to get my hub ‘online’ with a general power cycle, so try that first if you’re in my situation at least. Note that I haven’t linked any sensors yet…

Situation: newly arrived v2 hub, in the UK, iOS Smartthings app.
Symptom: When going through the setup wizard, it hangs on ‘Setting up hub’ (> 20mins)

  1. Exit the app
  2. Unplug ethernet and power from back of the hub
  3. Pull battery from the hub and leave out for 1-2mins
  4. Put batteries back in
  5. Plug ethernet and power back in
  6. Wait for hub to power on.
  7. For me it stayed on blue lights for a few mins then eventually went to green.
  8. Force quite the iOS app
  9. Start the iOS app
  10. App should now indicate that hub is online (or warning that hub is offline is no longer there)

That’s what worked for me at least, and I can see my hub is active on the developer site.


Most of us in this thread already did that with no success.

We have green lights, but the hub doesn’t seem linked to our accounts.

For the record, I witnessed Tom’s first Chipotle experience… it was quite magical. I think he fell in love. There may have even been tears (although he did go a bit excessive on the hot sauce).


Lou, if you’re talking about the developer site (and assuming you’ve got a green light on your hub), I did find the behaviour a bit strange. It looks like they have a different server(s) setup for Europe.

North America seems to be:
Europe seems to be:

When logging into the North American site, I was authenticated successfully but then redirected to the European server when I clicked on ‘My Locations’, at which point I could see my hub. If, for some reason, that isn’t working for you, maybe try logging in on the European url directly?


I made a linked topic (link is to the right of my OP) that is specifically in regards to the lack of ability to pair any devices. The original intent of this particular thread was getting the hub set up. Now I (and others) have been able to get it set up, but we are having problems pairing anything.


My hub is correctly listed in the US site (assuming all the data is correct and complete). That’s never been the issue. My hub has always gotten the green lights, which means it can communicate with their servers. It just doesn’t seem to be correctly tied to my account.

The UK sites doesn’t list my hub, which is what I’d expect since i’m in the US.

I don’t think there is anything I can do, since I think the problem is on their end w/ my account and device pairing.

Any luck?

Two days now, nothing works. Support stopped answer my emails. The chat support told me to reset my things and retry pairing them, to no avail. This is very frustrating.

Just want to mention also that when I go into discovery mode in the app, the lights on the hub do not blink green as it says they should according to this page:

1 Like