Stringify and ST failing authorization


(Eric) #1

Cross post…

I installed Stringify today and upon attempting to connect to the Smartthings API, I get the "Authorizing the selected devices failed; please try again later or contact support@smartthings.com.

I tried any and all of my devices. Same error each and every time. What gives? I’ve tried logging out, logging back in, closing out all my apps, and so on.

Android/S7/Stringify/Smartthings


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2

It would be helpful to capture your Live Logging output (in another browser, tab, window) from the SmartThings IDE/API webpage while you execute the authorization.


(RH) #3

I don’t know if it’s related but my SmartRules app cannot authorize any devices, even devices it has done for over a year. When I go to their help page, there is a message saying Smartthings has changed something and the two of them are working to sort it out


(Eric) #4

I spoke to Stringify and it turns out you have to select the Hub “and” the devices. Works now!


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #5

I’m not sure what Stringify’s authorization screen looks like, but that is the usual requirement across all Web Services provider SmartApps.

SmartThings wants you to explicitly authorize your desired Things to the 3rd party (like ActionTiles).

The only SmartApp that has an exception to this, is Amazon Echo.


(Paul Ockenden) #6

I’m seeing something similar. I select both hub and devices, but get the same error message.

I can’t see anything relevant in live logging.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #7

Check your Live Logging tab in the SmartThings IDE/API web page.

There’s a chance it will have more useful information regarding the error.