Stelpro releases the first Z-Wave Plus Line-Voltage thermostat: the STZW402+ Stelpro Ki Thermostat

Both Stelpro and Sinope are in the same point in their Google Home
compatibility implementation. I guess I’ll just have to wait and see.

Thanks for the update!

The Stelpro gets my vote because Sinope requires another ethernet port which I try to avoid.

If it is possible to set programs with IFTTT then my buying decision is made.

EDIT: I noticed in IFTTT, there is no option to switch the thermostat on to a set point. It is only showing up as a temperature sensor.

@killer23d They have new model that is Zigbee compatible. That’s what I was talking about. Problem is their shipping for one device is 20CAD. I wanted to buy one and test just as I did with Stelpro but the shipping cost held me back.

Both the Sinope and Stelrpro will require a third party SmartApp for programming schedules or be creative.

My local electrical distributor could order the Stelpro thermostats for $80, I think I prefer the Stelpro better.

FYI, In the past 3 years, I have built the ScheduleTstatZones smartapp which allows you to create zones inside your home for more targeted heating/cooling.

In the ScheduleTstatZones smartapp, you can configure your rooms/zones/schedules. You then associate your zone/room thermostats to your zones and schedule your zones during the day.

In your home, you don’t always want to heat/cool all your rooms. In the evenings or at night for instance, you may want to direct more heat to your bedrooms.

The smartapp lets you choose a master thermostat which controls other slave (zone/room) thermostats in terms of mode and setpoints. The thermostats need to follow the ST standard capabilities.

You can also define enter some delta temp adjustments to make some specific zoned rooms cooler or hotter. You can also use your room’s motion sensor to take into account if the room is occupied or not. The occupied threshold can be defined on a room by room basis for more flexibility.

There are many other features, refer to the ST community wiki for more details:

And the following ST community thread:

You can download the code at my store.


Awesome. I will give it a go.

Since these smart thermostat is almost 2x of the normal Honeywell 5-2 programmable ones, and I would expect it to have wireless capability as well as programmer-able. Am I asking too much :slightly_smiling_face:?

Nice, glad to hear about the effort to get Google Home integration working. I’m likely going to pick up a few more to finish off my upstairs soon so having the option to voice control the temps will be great.

Hi all,

Find below the updated device handler which makes your Stelpro Ki Z-Wave thermostat compatible with Alexa and Google Home!

1 Like

I just installed this, and I’m having the same issue with alexa I’ve been having the past few weeks… it seems to set the setpoint properly, but Alexa is reporting what seems like a random temperature. “Alexa, set the den thermost to 60degrees” She sets the setpoint to 60 and then responds “The Heat is set to 58”. I don’t have google home.

This has been happening with Josh Conways DH as well. No clue what’s going on.

Tested with Google Home. Works great. Seems you cant set .5 values but otherwise works well.

1 Like

Mine is working now with Google Home

1 Like

Hey Cory - I’m having the same issue. The value Alexa is reporting is the “ThermostatSetpoint”. The value displayed on the device (and the app) is the “HeatingSetpoint”.

Hey JF - Thank you for publishing a new device handler for the Stelpro! The thermostat is now usable with Alexa, which means I can get our other baseboard heaters set up with this thermostat - Yes!
I have a question. There are two Setpoints, “ThermostatSetpoint” and “HeatingSetpoint”. In asking Alexa “Alexa, set the heater to 70”. She will respond with: “The Heat is set to 72” , when the actual device displays 70, and the app shows the Setpoint as 70. So the correct thing happened, but Alexa is reporting on the incorrect value. She should be reporting on the “HeatingSetpoint” verses the “ThermostatSetpoint”. I can see this happening in the API when I look at the properties of the specific device.
So my question is: Is there any way to set the ThermostatSetpoint to be the HeatingSetpoint? Since this device only controls heaters it really doesn’t need both values, and the ThermostatSetpoint is the value being read by Alexa. Did all that make sense?
Thanks again for putting out another device driver. It’s really close to being perfect!


Interesting… I couldn’t figure it out after looking at the logs, but you might be right. It almost seems random, sometimes it’s right sometimes it’s off, so reporting a different setpoint could be it! It definitely worked last winter, so it did change at some point, although it could have been a change in Alexa.

I purchased these a year ago and never had the time to install it. I finally did yesterday, however, I can’t get it to connect to my network for some reason. I keep getting the Error code. I have the Google WiFi with a 2.5, 5, and a guest Network it can connect to. All password protected. My Smartthings hub obviously isn’t finding it for this reason. Which is the only reason I bought it. Anyone have suggestions?

Hi @Dove,

Please make sure you download the latest device handler from the Stelpro Github account.
The device handler from SmartThings is outdated of over 2 years now, and there is no sign they are going to publish a updated version soon.

Hi @ScottyG12,

Interesting, I will take a look at it. (ThermostatSetpoint vs HeatingSetpoint)

The thing is, the ST platform changes from time to time and I’m not getting notified in advance.
So things that were working become broken.

When Alexa answers “The heat is set to 72”, could it be the ambient temperature?

it’s not the ambient room temp unless it’s somehow getting it from a sensor somewhere else. The display will show, say 63, and the heat 50… I’ll ask alexa to turn the heat to 67 degrees, and the heat will change to 67 on the display, and she’ll say “the heat is set to 65”, or some other number.

Good Morning JF,

The heating setpoint value Alexa is reporting is definitely the “thermostatSetpoint”. So if I ask Alexa: “Alexa, increase the room temperature by 2 degrees”. She responds “The heat is set to 72”, when the heatingSetpoint increases by 2 degrees, but the thermostatSetpoint stays at 72. I haven’t been able to determine what sets the thermostatSetpoint. Its value changes periodically. Below are the values I typically see reported while looking at the heater device within the ST API.

temperature: 69.0 F
heatingSetpoint: 67.0 F
thermostatSetpoint: 72.0 F
thermostatMode: heat
thermostatOperatingState: heating
outsideTemp: 36.0

And good job keeping up on this driver. I’m not surprised that ST is a moving target. The market is moving fast on voice actuated interfaces and automation in general.

Thanks again!


I’m not having much success so far. The first time I tried I was able to get Alexa to tell me the current temperature, but when I asked to turn up the heat (or to set it to a specific temperature), she told me the device didn’t support it.

I tried another handler by Jon (Conway? something like that) and that didn’t work at all. But that handler is about one year old.

So I put this one back in. Now I can’t even get the current temperature. She answers “I’m not quite sure what went wrong” (this is the kind of answer I was getting with the “stock” handler.

When updating a handler like this, what exactly are the step to have it take effect? I’m wondering if I’m just doing it wrong. I tried excluding and then re-including the thermostat, then had Alexa scan for new devices. I’d think that was “extreme” enough, but maybe there’s more to it?

Any help would be appreciated!


I am getting the same behavior. Does anyone found how we can fix this?