Stelpro releases the first Z-Wave Plus Line-Voltage thermostat: the STZW402+ Stelpro Ki Thermostat

For those who are using the Z-Wave version of the Stelpro Ki Thermostat, here is the updated device handler, now available on Github:


I am using the zigbee thermostat.

I am not able to use automation for reducing the set point or turn off (available in zigbee version) the heater.

Also, when I ask Google home to reduce or increase the temperature, it says that the thermostat is OFF.

Any ideas to fix the above?

scroll up and read @JCon fix. I used his device type on my zwave version and corrected the google home problem.

Thanks. I saw that. However, I have the Zigbee version so that handler won’t work.

Has anybody used this for hydronic floors fed via a line voltage circulator? Seems this should work, providing it’s acting as a temperature based on/off relay. Hot water is provided by our on-demand system and has no attachment to the thermostat.

Has anyone successfully controlled this thermostat via Alexa. It works fine with the smart things app. But when I use Alexa she says the device is in a mode that doesn’t accept requests.she tells me to change its mode in the app or on the device. Is there a way to make this change?

I had the same issue, it refused to make any changes via alexa. I couldn’t even get the updated device handler from Stelpro (on another thread) working. I installed Josh Conley’s Stelpro STZW402+ from github, and that fixed my issues. I even created a “heat” group in Alexa with two thermostats, and now I can adjust the two thermostats at the same time.

I did notice that if you manually put the device in ECO mode, Alexa can’t adjust it. I didn’t figure that out until after changing drivers, but I don’t think that was the issue with it.

Thanks so much! This fixed my Alexa connection problem.

Now if only I could get her to recognize half degrees!

Anyone able to publish an updated device handler for the zigbee version. I’d love to let Alexa control this bad boy

Sorry, newbie here. I ordered 12 of these. Do you install to your ST hub by just using the “add a thing” and it should find them?

Just click “Add a thing” and the SmartThings hub will detect it

Just saw your note…Ask Alexa can control the StelPro units…I had these in a condo I just sold and included the specific commands for these devices right in the code.

Thanks, does it have to be in pairing mode? Can I do that remotely?

Clicking the “Add a thing” will put your SmartThings hub in pairing mode.
While the hub is in pairing mode, put your Stelpro Ki Z-Wave thermostat in pairing mode as well (“On” in menu #1) and confirm the selection.

After few seconds, you should see your thermostat on the SmartThings app.

Thanks. I got it all set. 9 more to go. I appreciate all the help.

Thanks for taking time creating this smart app that makes the stelpro more functional that the default control of the ST application. I tried creating smart app from your code but this is what I got:
No signature of method: script1490418496263286009026.metadata() is applicable for argument types: (script1490418496263286009026$_run_closure1) values: [script1490418496263286009026$_run_closure1@5fdab025] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

Am i doing something wrong?
Thanks a lot

Added this to my hydronic floor line voltage circulator system recently, promptly removed it the day after. Had some strange behaivor as it made a heat call every 10-15 seconds until the room was up to the set point. Took a lot longer to reach temperature and my on demand hot water heater was constantly firing. I expected the heating intervals to be much longer.

I’ve sent a message to Stelpro support for more info as this seems odd.

Has anybody else tried this with hydronic? Here is a screen shot:

Hi @Zoggied,

The Stelpro Z-Wave thermostat is NOT meant to be used for hydronic control.
It is designed to work with baseboard heaters and convectors only.
As you have discovered, the heat cycle in 15 seconds, therefore you cannot use it on hydronic systems.

Yeah, figured that out. If they would provide an adjustable heat call period this would work well for my use case.

Hello J-F,

Well, it would appear that I do have a problem after all. After upgrading to the latest version of the device handler, everything was working. The day after, I can no longer adjust the setpoint from the Smartthings app.
I can still adjust the setpoint from Google Home, Alexa and even ActionTiles. But not with it’s own app.