Status of Hue bulbs not updating when using the official Philips Hue app

I just bought the Smartthings hub today but i am very confused. While using the ActionTiles to create a dashbord i noticed that the tiles for my Hue bulbs do not update when the bulbs are switched on/off via any of the Hue apps (the official Phillips Hue app included). After checking the SmartThings app on my Note9 i noticed that the status of the lights in the app is not properly reflected/updated whenever i use the Philips Hue app to turn the light on/off. Is this a normal behavior? Is my Smartthings hub defective?

The status won’t update immediately if you use a method other than smartthings to change the state, but it should update about every five or 10 seconds. The bridge will communicate the new state to your smartthings account on a regular basis.

If that’s not happening, contact support.

1 Like

Thanks JDRoberts, the status will not update in the Smartthings app regardless of how long i wait (i’ve been checking it several times even after 30 min or longer periods).

I find sometimes you have to close (properly) and reopen the app to pick up a change.

Thanks Inge_Jones, it seems it doesn’t apply to me. I have closed the app and even disconnected the phone from WiFi and cellular data. Then i have used both Google Assistant via my Sonos Speakers and the Dimmer/Hue switch to turn on/off the lights. Then i logged into the SmartThings IDE via my computer and noticed that the time stamp for the last activity of the tested bulb was not getting updated when using other methods than Smartthings to control the bulb. As expected, the time stamp for the last activity of the tested bulb updated immediately when using the ActionTiles (ie. smartthings) to change the state (remember that my mobile phone was disconnected from internet all this time and the connection to the cloud was made via the Smartthings Hub and not the Smartthings app). This makes me believe that the problem is caused by the miscommunication between the Phillips Bridge and Smartthings Hub

I think I’m having the same issue. My set up had been working fine, able to switch hue lights on and off through either smartthings or with the hue app and the status would show correctly in ST. In the last 2 weeks I can’t see the correct status and it’s preventing lights being switched off by pistons. Coincidentally I started using Webcore a couple of weeks ago, could this be the problem?

I have the same issue. Bulb looking off in app but are really on and automation of bulb not working. I can force status back on by enabling bulb in smartthings - then it tracks againg. If I however use the hue app to change the state, smartthings is again out of sync. I have tried waiting and restarting the smartthings app but the state does not align it self with the bulb.

I have looked in the IDE and I can see the changes doen thorugh Hue are not reflected

I solved the issue for myself. I removed the hue device handler and all the bulbs. I then reinstalled the hue bridge choosing “With smartthings hub” and then scanned to add all the bulbs again. Now they update instantly to correct status even when using the hue app!

1 Like

Can you explain in more detail what you did. Thanks.

It is sometime ago now, but what parts are you struggling with?

So you used the hue bridge, but clicked use with smartthings hub?

I am having the same problem so.

I too am having this problem. When setting up HUE in the ST app, it does not let me pick the “Philips Hue with SmartThings Hub” … @Henrik_Riis how exactly did you managed to solve it?

I am sorry but it has been a year since I posted and I do not recall in detail anymore. Have you tried following my instructions from back then?

Yeah, sorry for the delay :stuck_out_tongue: I only started using webCoRE a couple of days ago…
When I tried adding hue with hub option, it says no Smart things hub is connected.
As I read elsewhere this shouldn’t be necessary. I have contacted support to help resolve this issue, but I haven’t heard back from them…

Your instructions (to use the “Philips Hue WITH Smart Things Hub” option) was what did the trick for me. Now bulb status is updated in a second or less in ST app whenever changes are made in the HUE app.
Thank you!

1 Like

I do not have a ST hub so choosing the option without hub, but i have the issue mentioned above if i re apply the devices it scans and shows correct status but as soon as you change something with the Hue app it loses sync, Question has anyone got hue to work without a ST Hub ?

This is probably due to the Cloud 2 Cloud integration and the changes made on your bridge are not mitigated to the SmartThings cloud, or maybe not to the Hue “cloud” neither. You should give a try to this:

Turn off the Wifi on your phone when accessing the Philips Hue app to use “out of home” connection for Hue.

Change some lights and check their status in SmartThings. If they do represent the changes correctly then your local changes on the Hue bridge are not pushed to the cloud. If the changes are not represented, then your changes made outside of the SmartThings app are not pushed to the SmartThings cloud.

Then you need to report the issue to SmartThings support and Hue support as well. I have no idea who maintains exactly that integration.

But mostlikely you are facing the second one, and that is due to bad C2C connection., what many other integrations are suffers from.

Thanks for the detailed, reply I can concur there is no difference using wifi or out of home control, so must be related to C2C integration, do you have a link for who to report the issue to

Since that’s an officially supported integration, you can just report it to smartthings support. I think there’s a link inside the app, or you can use the webpage:

Level one support was folded in with general Samsung support a couple years ago so don’t expect them to really know anything about how smartthings works. But they’ll take the report and see if it matches existing known problems. And if they don’t have a resolution it will get referred over to engineering eventually.

1 Like

Just follow what @JDRoberts said. First line support is a pain in the… Just report it with all the information what you have. Don’t expect a resolution promptly.

A temporary solution should be to remove and add the integration again, it should fix the issue with the websocket callback, but depending on the number of bulbs, it could be a pain to re-configure things.

If you do want a resolution promptly then I could suggest to purchase a hub and set up a the local version of the integration, that “should” work without any issues, but I cannot promise it, that it would work, but should be. Sorry…

I forgot to add which country are you from US or UK/EU?

Smartthings support line has different addresses, but if you sent it to the wrong one, just ask them to forward it to the right support queue.

1 Like