Stale mode info displayed in iOS app until full app restart

I’m using the iOS app and have several automated scenarios that change the mode. For example, my Good Morning routine fires at 7am, Goodbye when my presence is away, etc. While these mode changes are detailed in the “Notifications” page, and I do see they have been made, the display on the mobile pages like Rooms, Things, etc does not get updated. The attached image shows where I’m talking about.

Even if I refresh the page or exit the app and re-enter, it still shows stale mode information. However, if I kill the app completely (ie touble click the home button to show background apps, then toss Smartthings) then relaunch it, the status is always properly updated. So it seems there is a bug with that display in that it isn’t always triggered to update. Can make things confusing IMO.

Anyone else seeing this?

You are not the only one! I have experienced the same in the SmartThings iOS app. There are other posts about this issue. Hopefully it will be resolved soon.

yes… guys! 20 chars. Please open a ticket to bump it up on priority list. We were just discussing this in another thread.

Started in 2.04 and seems like a very odd way to save some bandwith in the app not properly checking the mode.

Reported this on September 11. Was fixed in some release and reappeared in 2.0.4.

See #1 below.

I have opened a ticket on Septembrer 9, almost two month ago.

This is what support came back with:

Thanks for reaching out. This is a known issue I am afraid. We’re working hard to address it.

For now if you force quit the app and relaunch it, the status on your menu will likely update, but for now there isn’t a permanent fix. Sorry for the inconvenience. We’ll let you know when it’s addressed

It’s still broken. If they were “working hard”, I’m sure it would be fixed by now.

Same problem for me since 2.04…Mode wont update in the mobile app unless app is closed and restarted. Happens every time.

I’m having the same issue. Not that it’s unique… I opened a service request, so maybe it’ll push it further up the list?

I was so excited to see today’s “bugfix” update, yet this mode info display seems to be even more broken than before the update for me :frowning: I’m currently stuck in “Night” mode on the display regardless of killing the app or performing “I’m back” or “Good Morning” type routines. The message feed says stuff like “I am already in Home mode as you requested.” So just display it correctly, right !!! Ugg…

For me typically it always shows the stale mode transitioning from night to home in the mornings. It happened today as well. Force killing the app always fixed it.

Just updated to 2.0.5. Will see what happens in the morning. Does this fix appear in the release notes? Have been totally out of touch the past few days.

Release notes on the phone itself only say “SmartThings 2.0.5 includes bug fixes and overall performance improvements for enhanced stability.” Not sure if there are more details online somewhere.

Not sure I have much hope for automatic changes if I can’t even force manual ones. :grin: But we’ll see…

Hmm… thanks. IMO most of those are pretty minor compared to unreliable mode information. Oh well…

Aah! Well! I have stopped worrying about these annoyances! :wink:

This has been a problem for a long time, even before 2.0, (I opened a ticket in May for this) and it’s still not addressed. It must be more of a complex problem to fix than we think because it does seem like a pretty annoying GUI bug. I experience it from time to time.

I’m seeing it too. Just submitted a ticket as well.

OMG… I think today’s update fixed this. :beer: :beer: :beer: :beer: