ST, WebCore & LIFX troubles :(

Long post, but not sure what’s actually at fault with my setup.

I have two pistons set up to control two LIFX bulbs.

Around 3-4 weeks ago I noticed the lights failed to come on as they should. I could still switch the LIFX bulbs on and off with the ST app, and according to WebCore that was working OK still. Yet they weren’t working as before. (One of the lamp tiles also changed to ‘Tiles Missing’ on the dashboard.

I did some researching and it appears a lot of people have reported issues with ST and LIFX.

I unlinked the LIFX account and was unable to re-add it. LIFX was no longer in the ST app.

I installed the new ST app and again, no LIFX stuff.

Fast forward to this week, I can’t even even open WebCore in the new ST app. I get a network or server error, and after 2 or 3 attempts I get a ‘Processing’ message pop up and I have to force close the app.

I emailed ST last week for a solution, and not had a reply!

Any help would be appreciated. Is this a fault with ST or LIFX? And what is this new ST app about?! I much prefer the older app!

Is ST dead/dying?

I see LIFX in the new app. What country do you live in?

Do you have any type of blocker type of software/apps installed such as AdGuard?

UK. Perhaps I’m being blind. Where should it be?

I run PiHole on the network; https://pi-hole.net/

And I have AdAway running on my rooted phone.

I’ve checked both and can’t see anything relating to ST being blocked

One of them could be the cause. You may want to try temporarily disabling them to see what happens.

Tried that to make sure. Have also tried WiFi and mobile data without difference

You may want to view live logging in IDE while you attempt to open webcore. If there any errors, report them on the webcore forum and one of the webcore_minions will assist with resolving it.

You should be able to tap the + button in the upper right, choose Device, and then By Brand and see LIFX.

Thanks, I’ll try that in a minute

OK, so I was being blind. I found it. I selected it, but nothing changed.

I’ve now removed all my LIFX devices from the new ST app.

I re-added LIFX and it says successful, but the lamps aren’t showing in the app anywhere.

I’ve also looked in the classic app, and again no LIFX lamps shown.

I’ve attmpted to re-add LIFX in classic app, but can’t find how to.

go to settings>connected service and delete lifx from there. Then try to add again.

That’s got the LIFX account linked again, and the devices are showing again. - Thanks.

Just leaves the WebCore issue to solve

This is how I have one of the pistons setup.
I noticed that it won’t pass the first time it needs to communicate with the LIFX bulb. I did change it to light level rather than switch state, but it didn’t help.

This time I removed the condition of the LIFX bulb. It’s now moved on to the next bit, but again, it gets stuck when it needs to communicate with the LIFX bulb.

Just to note, I’m still not able to access WebCore from the new ST app, I’ve had to revert back to the classic app which at the moment is behaving OK

What exactly is the issue with webCoRE? Both pistons seem to have run to completion. The first one evaluated the IF as false, presumably because SmartThings believed the RGB Bulb 2 switch was on. The second one entered the THEN block and saw the Location as Home so will have attempted to set the level on two bulbs to 100%.

It needs the webCoRE logs to show the detail of what it did and reveal any error messages.

What do you mean by it being ‘stuck’?

By stuck, I meant it wasn’t completing the green bar.

The first instance the bulb is off, but WebCore doesn’t see this.

The second instance should have turned the bulbs on, it didn’t.

Just taken a snapshot of the log.

Ah I see. Does the SmartThings app match the actual state of the lights? Does it see webCoRE setting the level?

ST can see the light state and control them.

I’m not sure how to check the WebCore bit. If I open the lamp for example, turn it off, make motion, the lamp doesn’t do anything within ST.

A lot of the new cloud to cloud integrations don’t seem to work correctly with Groovy smart apps like webcore. Did you re-add them to webcore after setting back up?

Yes. The lamps just had addresses allocated to them. I was able to re-add the correct lamps.

It’s just strange that’s it’s been working perfect for the best part of a year, but now decides to play up.

It’s also a shame ST can’t handle more involved automation natively.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.