ST login issue (Samsung?)

Weird: I have 2 iPhones (a personal and a corporate) and both have the old ST app on the same ST account. Haven’t used the personal phone in about a month… now I’m going to use only the personal, and I’ll be getting rid of the corporate. Today the corporate phone was logged in and showing all my devices as usual. The personal was logged out- When I tried to log in, it wouldn’t accept the pword. So I tried my Samsung pword and it did log me in, but didn’t have any of my devices- just a Samsung TV. Then I went back to the SmartThings login page, and I did a forgot password. Although it said that it was sending me a password reset email, I have not received it. Any ideas?? I’m afraid to log the corporate phone out of the app because I probably won’t be able to get back it.

first, check to see if you have more than one Home Location. If you do, try switching to the other one to see if your devices show up. let us know what happens and we can go from there.

Thanks @jkp - looks like that was it. I guess I had two Home locations. I switched, and now see all devices. Excellent!
Screen video