ST Hub, SharpTools, Tasker & SiimpliSafe Alarm

I have a Samsung ST hub. I also have a SimpliSafe Alarm. I have an app in ST that controls SimpliSafe. SharpTools is connected to SimpliSafe as well thru the ST hub. In Tasker, I use SharpTools in a task to turn the alarm on and off. However, it is not working well. When I run a task to turn on the alarm, it takes about 10 seconds. When I run a task to turn off the alarm, it doesn’t ever seem to turn off. I’ve waited 30 seconds or more and nothing happens. I have to then go to the SimpliSafe app to turn it off (or use the keypad). Anybody have any suggestions on how to get this to run faster? I am using both the Class and New ST apps if that matters. This was all working fine until this year. Not sure what changed. Thanks.

Tagging @joshua_lyon

Thanks for the tag, @JDRoberts! It looks like this was cross-posted over in the community where @jamesguitar3 has already responded:

I’d agree with James’ suggestion around reviewing the SmartThings IDE logs to get a better idea of what’s going on.

I don’t recall there being an official SimpliSafe SmartThings integration, so I would hazard a guess that this is using a custom community developed integration. In the SmartThings IDE live logs, you should be able to see the SharpTools SmartApp receive the command and then hand it over to whatever device the command is sent to. From there, it depends on what kind of logging the device/smartapp exposes. :slight_smile:

I did cross-post this because I think the issue is not directly related to SharpTools. I will check the logs (as I posted over on the SharpTools forum). I posted her as well to see if anyone else is having issues with the SimpliSafe integration. I used the @rboy LUM app to control my locks. I have it set to set SHM to Disarmed when a lock is opened with a specific code. This no longer turns off the alarm. I think it’s setting SHM to Disarmed, but not sure. I’ll have to check. I emailed Rboy support and they suggested it’s a latency issue, but not how to deal with it. So, maybe the SimpliSafe integration I installed from @tbycth3 is no longer working? I even tried using a WebCore piston to turn off SS. It runs, but it doesn’t turn off the alarm. I think it’s setting SHM to Disarm, but I’ll have to double-check. So, I’ve tried numerous ways to try to turn off SS. They were all working a couple weeks ago. Now none of them seem to work. Anyway, I’ll keep plugging away. Although if it’s something to do with the SimpliSafe monitoring app I installed in SmartThings, then coding that is beyond me. Thanks.


Sounds like you’re headed in the right direction at least! If the SimpliSafe integration isn’t turning off from any other SmartApps, then it leads me to believe it might be something with the SimpliSafe integration itself.

Are you familiar with how to check the SmartThings IDE Live Logs?

I’m curious if the SimpliSafe integration is throwing any errors or warning messages when you attempt to issue the off command.

(For the record, I think cross-posting is perfectly reasonable! I just wanted to make sure I thanked JD for the tag and let him know we had started conversation in another community as well.)


I don’t see any errors yet. I watched it a bit last night while locking and unlocking a door and resetting the alarm. In my Rboy LUM setup, I clicked the option to turn SHM to Disarm. That doesn’t seem to be triggering SS. However, I have some SmartThings routines that turn SHM to Disarm. When I changed my LUM setup to run the routine, it turned the alarm off. Weird. For some reason, the SS integration read the change in SHM to Disarm when the routine ran, but doesn’t when LUM just changes SHM to disarm. Obviously, there’s some delay in the SS integration reading the SHM switch to Disarm, but if there is, I wouldn’t know how to fix that.

And then there’s the issue of what happens when I switch the new app when has an STHM rather than SHM. I guess I can create a Scene that switch STHM to Disarm and then maybe the SS integration will pick it up, but probably not because it was written with the Classic App in mind and not STHM. :frowning:


1 Like

I don’t know if anyone still follows this thread, but I thought I’d post about my latest attempt to arm my SimpliSafe system. The problem with the prior method was that AutoNotification wasn’t able to “press” the “arm system” “button” on the SimpliSafe notification on my Pixel 6 if my screen was off. I tried several methods to fix this, but none seemed to work. Over on the Tasker subreddit, someone suggested using Google Home to arm the system. I created a “SimpliSafe Switch” in SmartThings (it’s a momentary switch, so it only stays on for a few seconds, and then turns itself off (thanks to @TAustin for creating his Edge driver for creating these; I never knew the benefit of motion and momentary switches until I started using his Edge driver!)). So, I created a routine in Google Home that arms SimpliSafe if the switch is turned on. I then created an HTTP triggered rule in SharpTools to turn the switch on. I modified my Tasker Profile to send an HTTP Request to SharpTools to turn on the switch when SimpliSafe issues an arming reminder notification to my phone. So far I think that Tasker, using AN, is reacting to the notification without having to turn the screen on my phone. Tasker then issues the HTTP Request to SharpTools, which in turn turns the switch on, which in turn triggers Google Home to arm the system. A roundabout way, but seems to be working so far, and better than my old routine of having AN arm the system from the SimpliSafe notification. Enjoy!

1 Like

How are you integrating Simplisafe with ST? I’m interested in it but haven’t found anything via search.

Are you asking how to integrate SmartThings with SharpTools? If so, go to for info. You can sign up for a free account to try it out. You would link your SmartThings hub to the SharpTools site that you can interact with your SmartThings Hub devices. You will need a SmartThings Hub, though. If you just have SmartThings devices, I don’t think that they integrate with SharpTools without a SmartThings Hub.

Simplisafe and ST. You mentioned that in your first post so I was curious on that integration.

The post is from 2020. SmartThings has changed a lot since then. The SimpliSafe integration with SmartThings no longer exists. It was a community developed app using the legacy SmartThings drivers. Sorry.