[ST EDGE] Zooz Edge Driver Channel

I’ve now migrated a few other of my ZEN25. Unlike the first one I migrated, these two are on V1 of the firmware, so I couldn’t disable reporting entirely. Instead, I disabled the wattage reporting threshold (set to 0) and set the reporting frequency to 600 for everything.

Behavior is much better than it was originally, but still intermittent. Sometimes, it works fine to turn on and off an outlet repeatedly (10+ times), waiting just long enough for the state to be reflected in the lamp before toggling. Other times, the request to change state seems to get lost and I need to make 1-2 other attempts before it takes effect. Rarely, a lost event seems to suddenly take effect a long time later.

I’ve tested from within the device panel itself, from a scene that turns one or several outlets on or off (triggered from the app), and also from my Aeotec Wallmote Quad, which I’m using to trigger a toggle event for an individual outlet. (I don’t have any other way to trigger a routine right now.) Behavior seems to be pretty consistent no matter which mechanism I am using. It’s just as likely that I’ll get a failure from within the device panel as when using the Wallmote switch or when executing a scene.

When testing in the device panel in the app, I have sometimes gotten a toast telling me about a network connectivity problem, around the same time I’ve experienced a failure. However, it only happens some of the time, and it’s not clear from the error whether it’s a wifi problem or a device network problem.

The Z-Wave network currently contains 3 ZEN25 outlets, 5 ZSE11 sensors (on battery), and 3 Wallmote switches (on battery). The battery devices should be pretty quiet in general. Z-Wave network repair doesn’t report any problems.

If there’s anything else I can do to help debug this behavior, let me know and I’ll dig in. The net result is now roughly as good as I had on the old custom DTH, but I’d like to help iron out some of the remaining wrinkles, if possible.

How far apart are the ZEN25s and how far are they from the hub?

Do most of your scenes/automations control more than 1 of those devices and/or both outlets together?

I added that check feature to the ZEN25 driver so the next release should solve the problem of the state not getting updated. The state not getting updated will cause those network errors your seeing. Unless they recently fixed an issue with the mobile app you’ll also see those errors if you drag down on the device details screen.

The ZEN17 driver is kicking my butt, but I hope to have it posted by late tonight…

1 Like

So I think I found a little glitch with the Zen 51 stock groovy device handler that I hope can be fixed with the Edge driver.

When the load control for the switch and Z-Wave are both turned off and it loses power it will shut off power to the load when power is restored. To get power back to the load you have to go in the settings and turn back on control to the switch and manually turn the load back on then disable the switch again.

If the device is ignoring the “On/Off Status After Power Failure” setting and not turning the load back on then that’s a firmware bug that can’t be fixed within the DTH or Driver…

It will still report on off status from the physical switch to the hub but the physical power to the load it is wired to will be off. I set Power status after power failure to, forced on. This did not effect the physical load. To restore power to the physical load you will have to enable the switch and manually turn it back on.

If this is a firmware issue I guess I’ll have to report it to Zooz. Unfortunately I don’t think you can update firmware through SmartThings.

The driver/DTH just passes setting changes to the device and confirms that the device changed the setting so the issue isn’t in the DTH/Driver and I’m pretty sure the device doesn’t send a power related notification report when the power is restored so I don’t think there’s a way to build in a reliable workaround either…

Please report the issue to Zooz, but unfortunately you’re right about ST not supporting firmware updates. If Zooz confirms it’s a bug and they release a new version that fixes it at some point then you’d need to get a z-stick, remove the device, and use a free 3rd party app like Z-Wave PC Controller to perform the update.

1 Like

I’m using the Edge driver for the Zen16. I’ve got a routine that turns on the main device (all relays) at sunset and then another routine that turns off relays 2 and 3 at midnight. (And a third routine to turn off relay 1 at sunrise).

For several nights, this second routine has failed to turn off both relays. One night both were left on. Last night, relay 2 turned off but not relay 3.

Is there an easy way to diagnose the issue? Could it be related to timings? Could there be an issue in the driver? This used to work fine with the DTH.

Two of the three ZEN25 are in my living room, which is one room away from my hub. It’s around 30 feet (~10m) from the hub to the first ZEN25, and then 5-6 feet (~2m) further to the second ZEN25. The third ZEN25 is one level down, on the same wall the second ZEN25, and almost directly below it.

It’s a combination. The Wallmote has 4 buttons, so I have two of them set up to each toggle a single outlet (a single lamp), and two of them set up to turn on or off the entire room (4 lamps across two ZEN25s) via scenes.

Thanks. I appreciate the time you’re putting into this. The results I’m getting with the Edge driver are at least as good as I was getting before, and everything feels more responsive (less average delay before an action occurs), so this is definitely a step up for me.

I setup those 3 routines, each triggered by a location mode, and ran the full cycle 5 times, but the lights turned off every time they were supposed to…

Are those routines doing anything other than control the relays?

I think relay 1 is selected by default when creating a routine so is the Main device the only one selected in that first routine?

What version does the firmware tile show on the device details screen?

Did you fix those scenes so that they’re only using the main switch?

I have multiple Z-Wave devices turning on and off.

Routine 1 - Time = sunrise + 15 minutes
Turn on front door light (Inovelli switch)
Turn on soffit lights to 10% (Leviton dimmer)
Turn on landscape lighting (Zen16 relay 1, relay 2, relay 3 = house numbers, front yard, back yard)

Routine 2 - Time = midnight
Turn off front door light
Turn off front & back landscaping (Zen16 relay 2, relay 3 = front yard, back yard)

Routine 3 - Time = sunrise - 30 minutes
Turn off soffit lights.
Turn off house numbers (Zen16 relay 1)

So yes, there are more devices being turned on/off in the various routines. In particular, the second routine also turns off the front door light which is a separate Z-Wave switch (not yet using edge drivers).

For the first and third routines, I’ve selected the individual relays (1, 2 and 3), not just ‘main’.

The firmware version is 1.04.

Unfortunately the history logging doesn’t show me which relay is turning on or off, but what I see is:
Sunset + 15 min → Zen16 powered on 3 times (I assume for the 3 relays)
Midnight → Zen16 powered off 1 time (I assume for relay 2)
5:15 am → Zen16 powered off 1 time (I manually turned off relay 3 that was still on)
Sunrise - 30 min → Zen16 powered off 1 time (I assume for relay 1 that was on)

Is there anything else I can check to diagnose this? Or any additional logging I can turn on?

Also, is there anyway to get the history to show more than the whole device turning on or off rather than the individual relays? Or is that a current ST hub limitation (similar to being unable to rename the relays)?

If you want to change all 3 relays to the same state in a routine then ALWAYS use just the Main switch. If you select all 3 then it’s sending 6 addition commands to the device which makes the bottleneck problem even worse.

Technically there should only be 1 light on when the 3rd routine executes, but since you want all relays to end up being off you should also change that one to just the main switch too.

I’ve found that the driver platform often drops z-wave messages if you attempt to control multiple devices at the same time so switch 1 and 3 to just the main switch and also using the delay option for the relay actions of all 3 routines to make them execute a few seconds after the other actions will most likely solve your problem.

Okay, I switched the first and last routines to use ‘main’.

I’ve added delays into the middle routine between other devices, however I apparently can’t add a delay between the two relays turning off. So if that still ends up being an issue, I’ll try creating another routine that runs at 12:01 and put one relay in each separate routine.

It was controlling 4 devices at the same time that might have been messing things up so delaying the relays together should be fine…

The more recent firmwares for the zen72 and zen77 dimmers create multiple ramp rate settings. Would it be possible to update the driver so each of these can be set? The ramp rate setting currently in the driver seems to only impact the physical toggle, but does not adjust the Z-wave ramp rate.

Ramp Rate Control

Parameter 9: Adjust the ramp rate ON for your dimmer when the top paddle is pressed (physical ramp rate on). Values correspond to the number of seconds it take for the dimmer to reach full brightness when operated manually.

Values: 1 – 99 (seconds). 0 – instant on. Default: 0.

Size: 1 byte dec

NOTE: On all other previous firmware versions including 1.0, 10.0, and 10.10, this setting was used for all ramp rate control (to adjust behavior for on/off physical and Z-Wave ramp rate). The default value for this parameter used to be 1.

Parameter 27: Adjust the ramp rate OFF for your dimmer when the bottom paddle is pressed (physical ramp rate off). Values correspond to the number of seconds it take for the dimmer to turn off when operated manually.

Values: 1 – 99 (seconds). 0 – instant off. Default: 2.

Size: 1 byte dec

Parameter 28: Adjust the ramp rate ON for your dimmer when a Z-Wave command is sent to turn the dimmer on (Z-Wave ramp rate on). Values correspond to the number of seconds it take for the dimmer to reach full brightness when operated via Z-Wave.

Values: 1 – 99 (seconds). 0 – instant on. 255 – match physical. Default: 255.

Size: 1 byte dec

Parameter 29: Adjust the ramp rate OFF for your dimmer when a Z-Wave command is sent to turn the dimmer off (Z-Wave ramp rate off). Values correspond to the number of seconds it take for the dimmer to turn off when operated via Z-Wave.

Values: 1 – 99 (seconds). 0 – instant off. 255 – match physical. Default: 255.

Size: 1 byte dec

It already does, but they’re only visible if the device has a firmware version that supports them…

If you don’t see them then let me know what firmware version is shown on the device details screen and the name of the profile shown at the bottom of the settings screen.

Is there an edge driver available for the Zen15?

Thanks!

2 Likes

Thanks. I updated both of my Zen77 dimmers to firmware 2.1 and the additional ramp rate settings now appear. Unfortunately, even when the ZWave ramp settings are set to 0, the light ramps on and off instead of turning on/off instantly. The setting for physical ramp rate on the other hand does work when using the paddle on the switch.

Hoping for that exact update also.

1 Like

Did you factory reset the device after upgrading the firmware? Some of their switches/dimmers require that…

1 Like