[ST EDGE] Zooz Edge Driver Channel

I am seeing the same across multiple iOS devices.

I just pulled out my Samsung S6 with v1.7.65.43 and the “IF” target for the ZEN32 does allow choosing the LED colour etc… But the button labels are not there.

However when I try to edit the routine on my iPhone I cannot access any of the options.
Unsettling

It appears that the issue is related to custom capabilities so is anyone seeing this issue with other devices?

The 700 series switches/dimmers and ZEN30 should be having the same problem…

I dont have a ZEN30 - does the Aeotec Illumino Dimmer have custom capabilities? (I’m running the Aeotec Advanced Configuration Edge Driver on it).

No problem with the 700 series dimmer


I am also not seeing all the relays for Zen30 or Zen16. They all show for the ‘if’ portion of the routine but not the ‘then’ portion.

Also no issue on the 700 series switch


Same here only relay one shows on Zen 16 and 52


It appears to be a regression as it also occurs on a Fibaro double relay which is using @Mariano_Colmenarejo driver

I’m on iOS

@nayelyz are the developers aware of all the new iOS app issues mentioned in the 10+ messages above?

Hi, @krlaframboise
If I understood correctly, the issue is that not all components of a device appear in the Routines “then” section and, in the conditions, all components appear correctly, right?

1 Like

Yes that is what is occurring

ok, thank you for the confirmation, I’m seeing this with my multi-component devices so, I’ll report it right away. Once I get more info, I’ll let you know.

3 Likes

On the ZEN16 - for me the relays dont show up in the parent relay, however if you create the child relays, then those are selectable.

I’m trying to avoid creating child relays for two of my devices based on how I use them. I figured I could get it working by creating child devices if I had to but hopping ST can resolve this issue.

@nayelyz On top of this, my brand new aeotec hub (had for 3 days) has now stopped adding or excluding any devices. The lights blink but it cannot find any devices in either add or exclude mode.

I hope so too Guy. In the meantime I created a room called “Hidden” to put junk into (sadly you can’t hide the room but I put it at the very end of the list of rooms)
:wink:

1 Like

@nayelyz , please respond to that one in a PM since it’s not related.

1 Like

Enabling child devices is the workaround for users that don’t have access to an Android phone and need to create a new routine that controls a multichannel device.

Fyi, the enable child device setting is just a trigger that makes it create them. Once they’re created you can disable that setting and delete the ones you don’t need…

2 Likes

I just went to get an android tablet and I can confirm that the issue is with iOS devices. On my iPhone I cannot access the ZEN32 custom capabilities in the “THEN” section of a routine. It IS available on Android.

Hopefully this helps speed up the fix to know that it affects iOS and not Android.


From Android Tablet


From iOS

I just went to get an android tablet and I can confirm that the issue is with iOS devices. On my iPhone I cannot access the ZEN32 custom capabilities in the “THEN” section of a routine. It IS available on Android.

Hopefully this helps speed up the fix to know that it affects iOS and not Android.


From Android Tablet

Sorry for duplication. Editing on multiple devices