[ST EDGE] Zooz Edge Driver Channel

For Edge devices, use the smartthings CLI to get the “deviceManufacturerCode:” with:
smartthings devices <n> -y
where <n> is the “#” of the device in the “smartthings devices” list. The deviceManufacturerCode for the ZSE40 might be 027A-2021-2101.

The smartthings system matches devices to drivers by looking for the device fingerprint among matching driver fingerprints. Up to now, you needed an exact match. As we’ve passed October 15, that restriction may have been eased and devices might be matched to drivers with less stringent criteria. Eventually matching will use only device “type” - switch, sensor, etc.

I hope Kevin weighs in… I think there are two possibilities. You may have a variant ZSE40 which doesn’t match the fingerprints he was given, in which case he might update his fingerprints.yml list to include your variant. The second possibility is that there was a Z-Wave radio collision when you added this device, and the fingerprint was corrupted or lost. Four of my devices had fingerprints of 0000-0000-0000 and had to be excluded/included before they got Edge drivers.

Addendum: I have a Monoprice 15902, a rebranded Vision ZP3111US, which is very similar to the ZSE40. Its fingerprint is 0109-2021-2101. I put a couple of batteries in and included it and my device got a SmartThings Edge driver which reports motion, temperature, humidity, and illuminance. Pretty cool. The fingerprint is right there in SmartThingsEdgeDrivers/drivers/SmartThings/zwave-sensor/fingerprints.yml (I stopped using it because it ate batteries, and replaced it with a ZSE18 on USB power.)

There was another case in this topic where a user had a Zooz ZSE06 which was actually a rebranded Hank SO03 that reported the Hank manufacturer code. I suspect that if your device doesn’t report a manufacturer code of 0x027A then it will be outside Kevin’s remit. The best answer might be to post the request on the Edge Drivers request topic.

1 Like

For all my ZSE40 deviceManufacturerCode is 0109-2021-2101

These are Vision devices, not Zooz. A good driver is available on the “SmartThings Drivers (Beta)” channel. For links, see this post. Install the “Z-Wave Sensor.”

Out of curiosity - do your motion detectors have a Zooz label? Vision Security? Or no label?


My sensors have no branding on them. I believe that I bought them at Monoprice. The paper manuals that came with them have Zooz ZSE40 brand/model on them and I used Kevin’s Zooz driver with them before Edge.

Thanks for the tip on Vision, I’ll try those drivers.

Sorry for not responding sooner…

The first release of the device shared a fingerprint with other devices and it’s officially supported by SmartThings so Zooz decided not to include that fingerprint in their driver.

If you’re still able to get the device to join with the DTH then you should do that, apply the settings you want and let ST migrate the device to the built-in driver so that you won’t lose your settings.

Thanks for letting me know. I found this driver for the Monoprice 4 in 1 and it works fine.

Is there an ETA on Edge drivers for the Zen 23 or 24, or are there equivalent Edge drivers for other devices that would support the 23 or 24? Thanks.

I’ve asked this before, the 500 series switches. Are discontinued by zooz so they are very low on the priority list. I believe @krlaframboise will get to them after he finishes up getting drivers out for all current products. Hopefully @TheSmartestHouse will hear are plea to have the a driver made to mimic all the functions the DTH did.

1 Like

Hi @nayelyz
Do you have an update on this issue? I have the same issue with the IOS app (Version and ZEN16 (Firmware 1.04) Edge device driver. This issue impacts utilizing routines to control relay 2 and 3 on the ZEN16, as they will force unwanted control of relay 1.

1 Like

Hi, @rbenson60!

I’m reposting this here as well, sorry:

Any updated ETA for the ZEN51 driver?

there is a lot of other things we need to set the dimmer value with a routine

Please add edge driver support for ZSE19

The ZSE19 driver was discussed above. Because it’s certified as “Works with SmartThings,” an Edge driver is already available in the SmartThings Edge Drivers Channel here . Discussion is here . Code is here .


Hopefully this weekend…

1 Like

The default siren driver is there. But we do not have the capability to play other sounds as the one provided by zooz had (the dimmer functionality)

1 Like

Check the discussion above.

Documentation for the advanced settings is https://www.support.getzooz.com/kb/article/1156-zse19-s2-multisiren-advanced-settings/

This driver lets you set any parameter on a Z-Wave device.

1 Like

Any chance you’ve had an opportunity to add the fingerprint? I’ve tried a few times the last couple weeks but it still joins using a stock DTH.

Maybe I’m just missing something I need to do?

I just received a replacement ZEN30 device. It’s an S2 Double Switch ZEN30. I installed it this morning and added it to my Z-wave network. It showed up but remained unresponsive to ST. I tried to control the device (on/off, relay on/off) with no luck. I tried to delete it, no luck. I force deleted it with the CLI and that got rid of it. I can reset it alright (hold bottom paddle 15 seconds until it flashes, then hold the top paddle 15 seconds until it flashes again) but when I tap the top button three times I get no response. I tried tapping the top button four times and again five times but nothing happened. The two switches work locally but I cannot add the device to ST. I installed a different ZEN30 yesterday in my room without any problems. This one is in an adjacent room so there should not be a network distance problem. I may try to fire up my USB stick and see if it is responsive there. I have had two S2 ZEN30s so far which I installed easily but this one, which I just received to replace a V1 ZEN30 that died after about a month of flawless use until it died, is acting weird. Anyone have any suggestions to try?



You should be excluding not deleting Z-Wave devices.

So you will need to run Z-Wave exclude before you can repair the device.