[ST Edge] Zigbee Driver for MOES 4-Button Scene Switch (TS004F)

Yes, and the version 1.4.0 of my driver is accurate.

The most interesting stuff is the Zigbee Groups feature, as I can set the knob on “Remote Mode” (as the manual points out) and the define the group on the settings… repair and thats it.

The only remaining thing would be to add the bulbs into the same group.

Now!.. about the Scene Mode, which actually sends button and this Generic 00-01 for the twists, I think the best way to implement it is by the Switch Level capability and the mirror it through SmartLightning SmartApp, because ST doesn’t support plus operators on automated stuf… e.g.:

Right => LIGHT.LEVEL + 10
LEFT => LIGHT.LEVEL -10

I’ll see if I can add it today of tomorrow… it shouldnt be that much of work


@Subramanian_Swaminat I owe you the fingerprint. But, it is for a in-wall switch, right?

So no battery?

1 Like

That’s right Erick, both this one and the finger print for the 2 gang I provided before are in-wall with no battery.

Thanks
Subbu

That is great, thank you! Do I just remove and pair again to use the new driver?

Hi @erickv,

I can’t see version 1.4 on your shared driver area. V1.3.2 is the latest I can see on there.

Thanks,
Riaan

Hey @RiaanUK, @Subramanian_Swaminat

I’ve submitted a few changes at button-battery-1.4.2, details below:

  • Yagusmart fingerprint added and profile update for 1 and 2 button switches.
  • Switch Level for SmartKnob will be enabled for mirror automation.
    • This feature is enabled at Scene Mode.
    • Zigbee Group automations under Dimmer Mode (aka remote mode).

So, to follow up on the respective versioning, please enroll your Hub into the following channels and once you install the driver, it will be available under your device’s Driver settings.


UPDATE

@RiaanUK I’ve managed to integrate the Switch Level capability, so you can automate it along your bulbs through the SmartThings Lightning SmartApp or if you already have a Zigbee Bulb, try to check if you’re able to:

  1. Configure its Zigbee Group.
  2. Change Knob to Dimmer Mode (on settings) and repair.
  3. Match both devices under same Zigbee Group and Voila!.. I hope you’re able to test it out. = ]

Cheers!!!

3 Likes

Hi Erick,

Thanks for this, but I am way too stupid to get it working:). I have followed your advice and bought a Sengled bulb, bit then WiFi one and not the Zigbee one. Smartthings picked it up by assing the Sengled Serives to it. Should I rather get the Zigbee one?

I have also installed the new 1.4.2 drivers. Removed the Knob, but now Smartthings does not detect it anymore. Any advice please?

Many thanks,
Riaan

Hi, Erick.

It works great with TZ3000_wkai4ga5!
Thank you very much!

I have tried to use other drivers for the button,
but there was a issue of lossing battery.
I have read others comments at this thread, it seams there is no issue on your driver.
I hope no issue on it too.

Can you please add a fingerprint below as well?

  • zigbeeNodeType: SLEEPY_END_DEVICE
  • application: 42
  • endpointId: 01
  • manufacturer: _TZ3000_dku2cfsc
  • model: TS0044
    Raw Description 01 0104 0000 01 03 0000 0001 0006 02 0019 000A

Hi Erickv,

Hope you are well. I have managed to get the Smart Knob connected again. I have bought the bulb in this link - https://www.amazon.co.uk/gp/product/B07FL465KV/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&th=1
What I have done so far -

  1. I have installed your latest driver.
  2. I have installed the SmartThings Lightning SmartApp
  3. I played around to see how I can get it working, but no luck

I need a step by step guide I think. Would you be able to help at all?

Really appreciate all your efforts so far and cant wait for this to finally work!

Thanks again,
Riaan

Hey, @RiaanUK

I’m glad you got the SmartKnob integrated again, and don’t worry, your Sengled Wifi can be synced as well as a Zigbee one.

On how to set up the SmartThings Lightning Automation, the configuration should be as follows:

  1. on Which devices do you want to control? input, select the Sengled bulb
  2. on What do you want to do? input, select Mirror Behavior
  3. on Mirror which switch? input, select the SmartKnob

… yeah, it is a bit weird selecting the knob as the switch to mirror, but the other way won’t work.


@ywr1560 Thanks for the feedback and for contributing!.

I’ll add the fingerprint in a couple of hours, I’ll ping you back then =]

1 Like

Thank you erick, but the Smart Knob does not show up in the list in the last step. I can see the Smart Knob under Devices though and it registers a press on the App.

Is it using the latest version of the driver? That’s the one that unblocks the device from being used at that SmartApp.

Also, it is possible that the knob was integrated with initial driver versions, but you can switch it at SmartKnob >> DetailView >> Menu (vertical dots) >> Driver.

2 Likes

Spot on! It still had the old version on there. It works and I am forever thankful!

Thank you sooo much

2 Likes

= ) @RiaanUK I’m happy it is now working.


@ywr1560 I added the fingerprint. Give it a try on the button-battery-v1.4.2 version.

Cheers!

It works perfectly. Many thanks!!!

1 Like

Great! Thanks for the feedback!!!

Hi @erickv ,
excellent work. Any chance the knob driver will work with this one as well?
Link to device on Aliexpress

1 Like

Can you add also this moes 1gang button?

  • application: 42
  • endpointId: 01
  • manufacturer: _TZ3000_axpdxqgu
  • model: TS0041
  • onOff: catchall
  • zigbeeNodeType: SLEEPY_END_DEVICE

Regards, Chris

1 Like

Could you please add the 2 following fingerprints?

1 Like

@sulisenator @Krzysztof_Siwiec I added the fingerprints on version 1.4.2, so give it a try.

In addition, the driver already supported the SmartKnob and its modes… but! The one I’m using is a bit dummy whe it is on Remote Mode, so I hope yours work better than mine lol (modes available on device’s settings)

First thank you very much, oth device are now entitled to use the driver.

They both work perfectly!

Thanks again.

2 Likes