[ST Edge] Zigbee Driver for MOES 4-Button Scene Switch (TS004F) Plus Some Smart Knob Models

Does it looks like battery drain? or Does It works again if u repair the device.

1 Like

Maybe that device is a very sleepy device that doesn’t report, even if the attribute reporting configuration was set properly.

Also, I think my driver possibly fails for the same reason, i.e. the device turns into sleep mode as soon as it joins the network and not until the whole discovery configuration finishes.

I believe that some brands recommend pairing their devices while pressing repetedly any button to keep the device awake.

All 4 lights start flashing and the device becomes unresponsive. I have to remove and re-pair it again. Although getting the lights to stop flashing is very challenging!

Ok thanks for all your help. I’ll give it a few more tries then I think it’ll be a return job! Far too much hassle!

I got sent a replacement switch and tried your driver again @zambobmaz and it installed ok but started getting the 4 lights flashing again. So removed the switch and tried to uninstall the driver but it says the driver is still being used by a device. At first the switch kept showing back up but seems to have been successfully removed now. Any ideas why I can’t remove the driver? It’s now preventing the switch being added back.

I also tried your driver again @erickv but still nothing.

1 Like

The same thing is happening to me, if you find a solution please let me know.

Finally done it!

I found I had some automations left from the device. These couldn’t be deleted at first, so I re-paired the device, deleted the automations, removed the device again. I was them able to uninstall the driver.

Check for routines from the device usage and the automations list. A couple of mine were under other names I had given the device, so I had to check my whole list.

Hope this helps!


Hello, my zigbee 4 button device is recognized like Hejhome Smart 4 Button but i dont understand if it worrks or not…

I get battery % to 97 and all button are in pause status. If I push a button the status dosnt change.

I need to do anything??


Or you’ve installed your device using a custom DTH or is @zambobmaz 's driver.

Either way, to check whether is working or not, try following the state updates at the detail view of the device


I’m using this driver:

I found the problem.

The version 1.3.0 is incompatible

I installed the 1.2.0 and now it works.



Maybe your device couldn’t finish the scene mode setup using the 1.3.0, which is a little bit odd. I believe that it would be nice to check if the fingerprints are actually supported by my driver, and for this, you’d need to uninstall drivers and dths supporting your device, adding it back again as a Thing and track the fingerprints… but since it is already working, it is up to you = ]

Also, regarding the screenshots, both of them are from different devices, because even if the one from the first screenshot shows that it is integrated via edge driver (mine), the groovy screenshot points to a different device profile, i.e. the zigbee-tuya-button-4.

Here is how it looks a device using the battery-button-v1.3.0:

There are the info from the device:

Data * zigbeeNodeType: SLEEPY_END_DEVICE

  • application: 41
  • endpointId: 01
  • manufacturer: _TZ3000_xabckq1v
  • model: TS004F
    Raw Description 01 0104 0104 01 06 0000 0001 0003 0004 0006 1000 08 0019 000A 0003 0004 0005 0006 0008 1000

now I’m investigating about the question of screenshot…

many thanks for your help, it’s very appreciate

I probably understand the problem.
I removed all the drivers, the DHs and the device, then I installed your version 1.3.0 and re-paired the device which is now recognized as a “scene switch” and works correctly.

So I think the problem is that during the first pairing I used the @zambobmaz driver, and that simply replacing it with yours is not enough.
I think the correct procedure is to remove the device and re-pair and bind the correct driver from 0 instead a simplu driver exchange


1 Like

Hey, @Steve_Mason

Finally, after a heavy sprint on my job I’ve been able to check this once more time and when I was about to consolidate my driver versions I noticed something quite important regarding the fingerprint you shared, see below:

As you can see, the manufacturer is simply TZ3000_wkai4ga5, without the initial underscore, as it happens with all the other tuya fingerprints I’ve pushed so far into the repo (for a better reference, check here), so, I believe that it should be as follows:

manufacturer: _TZ3000_wkai4ga5
model: TS0044

I’ll submit the update at the battery-button-v1.3.1 version under the @erickv Shared Drivers in case you’re able/willing to test it out.

Cheers man!

1 Like

Anyone know if there is an edge driver (or even a groovy DTH) that handles
the loratap 4 button battery remote

  • zigbeeNodeType: SLEEPY_END_DEVICE
  • application: 41
  • endpointId: 01
  • manufacturer: _TZ3000_ee8nrt2l
  • model: TS0044

Looks like this

I have same looking 3 button and usenit with this edge driver:

Following up to my own post
just tried the zemismart groovy dth here

and this works for 4 buttons on the loratap 4 button (single press, not experiments with other options).

Hey, @Declankh

I was reviewing the fingerprints that my button-battery driver supports and noticed that it is already supporting the 3-Button Loratap Remote, so, I’ve added the fingerprint you shared and you can install the driver enrolling to the following channel:

(Note: to make an effective installation, you might need to delete the DTH from your setup.)

Brilliant, thanks very much, much appreciated

1 Like