[ST Edge] Zigbee Driver for MOES 4-Button Scene Switch (TS004F) Plus Some Smart Knob Models

I still can’t see my new buttons on Smartthings.

When I try to enroll a new device, the Smartthings apps don’t see it, but the button stop flashing very fast, like it found the Zigbee controller. But nothing shows up in the app.

Any idea how to enroll an additional one of those when you already have one.

Hi! have very similar device to the Zigbee LoraTap 4-Button Remote.
but from another Manufacturer ‘QCSMART’

Can you please add the Fingerprint for my device?
as follows, thanks!

QCSMART 4-Button Remote

  • id: “_TZ3000_ufhtxr59/TS0044”
    deviceLabel: “Scene Switch”
    manufacturer: “_TZ3000_ufhtxr59”
    model: “TS0044”
    deviceProfileName: 4-button-battery

Hey @erickv greetings!
Could you please include this FPs to your last Moes Smart Knob driver?
I already got installed button-battery-knob-v1.0.0 and v1.0.1, both undetectable by device.

TY!

Should be supported with @ygerlovin driver. His channel is here:

https://api.smartthings.com/invitation-web/accept?id=b119aed9-4083-46bc-bc16-584b9d738abe

Got this MOES button working fine with ‘the button-battery-v1.4.4’ driver!

1 Like

Hi @erickv @TapioX I’m having an issue with 1.4.4 driver, my device is Moes _TZ3000_wkai4ga5, sometimes when I press a button to turn on a light, after a second the device turns off and viceversa. I’m not 100% sure but I think this happens when the button has not been used for a while.
The button is not defective because I have 2 of them with the same problem.
What do you think it might be the problem?

Thanks

Hi @JaimeT

Maybe the button makes a double touch and that’s why it sends information about two presses.

I have the opposite state as a precondition in the routines.
If I want to turn lamp on I have precondition that lamp is off.
If I want to turn lamp off I have precondition that lamp is on.

Thanks for your answer! I’m sure it’s not a double press, because I tried with Bob and Yakov drivers and it doesn’t happen and also the double press doesn’t show in history. Anyway, I’m going to try with your suggestion for a quick temporary solution.

Correction: just tried again and the two presses appear in history.

This only happens when the button goes to sleep and @TapioX the pre condition that you suggested doesn’t work. I had to do 2 routines, press to turn on and double press to turn off.

Hi, what brand of cr2430 are you all using and how much does it last? I tried with 2 muratas and they died in 10 days or less.
I found the 4 button lights blinking and unresponsive, tried with a new battery and it worked again, so I guess that happens when the battery is low?

Thanks

Hi @erickv
Can you please add this device to the button battery driver?

TS004F
_TZ3000_b3mgfu0d

All features, functions, and zigbee communications are exactly the same as

TS004F
_TZ3000_czuyt8lz

Neither device supports battery level reporting.
If possible, I would suggest removing the reporting of battery levels for these IDs.

Thank you

You can also ask via issue in his channel
@zambobmaz

His Github is here: