[ST EDGE] Z-Wave Sensor Driver Channel - including specific Ecolink, FortrezZ, HomeSeer and Zooz models

Hey @philh30 can I get some help on finding what you need to help me? Never got a resolution. I added the driver and it shows up as having like 12 different sensor types and none work. What am I doing wrong?

Hi @csstup , I wanted to check in to see if you’ve been able to look at the HS fls 100. I know before you hadn’t had a chance but I’m thinking you are my only hope!

Thanks for all your contributions to the community!

Not yet. I’ll see if I can get some of it this weekend and the coming week.

2 Likes

@philh30 and @csstup. You added the Monoprice 4-in-1 sensor to the “Z-Wave Sensor PH” driver back in September and it has worked very well until the New version (1.7.93.26) of the mobile app was released a few days ago. I am assuming the same problem will happen with the Zooz 4-in-1.

The problem is that the display has the large Multi-Tile icon which causes the new Mobile app to crash when you open the room that contains that tile.

Could you modify the driver so there is an Option to use the small device tile until ST fixes this problem. If they ever fix it.

I am temporarily using the stock Z-Wave driver to solve the problem, but that driver does not have the setting menu that lets you customize things.

1 Like

I’ve got Ecolink flood sensors (FLF-ZWAVE5-ECO) previously on RBoy’s device handlers, and am now moving them to Edge. I have these drivers installed, but I’ve noticed that I’m not getting a battery status when doing so? Also, I saw it mentioned previously that polling intervals may be configurable, but I don’t see these options at all? I have changed these sensors to all available drivers, and see the same in all.

At the end of the day, I want to be able to tell when a sensor is offline (using ‘https://api.smartthings.com/v1/devices/device_id/health’ in SharpTools, but that status does not appear to change for me. A side benefit would be accurate battery level reporting.

Any ideas?

This driver doesn’t have native support for the Ecolink flood sensor. It can support them as generic sensors, but you won’t get any custom parameters and it doesn’t know that its battery powered.

Damn, so that’d also include the health API status?

Edit: Let me clarify this. If I can’t use ‘https://api.smartthings.com/v1/devices/device_id/health’ to grab the status (online/offline), is there any other way to detect the status of the sensor? I assume SmartThings regularly polls the devices, though I guess it may be the other way around (where ST just stores the last result the sensor provided, and that’s that?).

Health status is something that is no longer in control of the device, thats up to the hub to determine based on the radio indicating if the device seems to be responding or not. Doesn’t have anything to do with a particular sensor or attribute, its just communication in general.

So when you’re querying the API, its basing it on what the hub has forwarded up as its current health status.

Got it - I appreciate the replies!

I had written support for that a couple months back but never packaged it into the released version of the driver. Worked fine while mine was on it. It should pull battery reports from the device since it uses the same battery and wakeup logic that @csstup wrote for the other devices on this driver. I’ve pushed out an update to the driver that includes it - give it a try once your hub gets the updated driver.

2 Likes

Nice, I’ll absolutely check it out. Is this a new driver I’ll have to install from the invite link, or just an updated version of ‘Z-Wave Sensor PH’?

Update of this driver. If you already have it installed, the update should push to your hub in under 12 hours (maybe already). If not, installing now should pull the new version. If your device is currently using this driver, you’ll probably have to swap it to a different driver and then back (or exclude/include) to this one to pick up the correct profile.

Got it. I’m currently using the standard Z-Wave Sensor driver, so I’ll just pick this up tomorrow morning and will give it a shot, and will provide feedback (if it helps). Thank you!

Got the new driver, and am testing it on one of my sensors now. I’ve updated the wake up interval to hourly just for testing, but do I need to do anything after that (pull the battery and let it start fresh)? I’m hoping that it tries to report in at this interval, because I think I’ll be able to work with that in SharpTools.

Opening/closing the case should trigger a wake up immediately. Otherwise the wake up interval change won’t populate until the next scheduled wake up, which could be several hours.

1 Like

I was hoping that the ‘state’ would update with the change, but that doesn’t appear to be the case. All of my Ecolink sensors are showing 100% for the battery life, but given that I’ve heard that it’ll report something crazy high and then drop when it gets lower, I guess I’ll have to just wait and see if that rings true here, because it doesn’t look like I have any other way to report on actual health of the sensor. I may just look for a better sensor that actually reports in every once in a while so that I have better insight into this.

I don’t think you followed what Phil was trying to explain.

By default, the device will wake up, check in, and send battery reports every 12 hours. If you change the wake up interval setting to something else, it will be the remaining of that default 12 hours before it checks in again to a) report its battery and b) get any updates for it, including the new check in interval setting. From that point forward, the checkin/battery report interval will be whatever you configured it to be.

If you don’t want to wait for that initial difference between the default and your new interval, you can wake it up manually by opening/closing the case, which triggers a TAMPER report and a forced wake up. Just as if you had waited for that initial check in period to expire, from that point forward the checkin/battery update interval will be whatever you set it to be.

I find the battery reporting percentage curve on the ecolink sensors to be fairly accurate.

For leak sensors, I tend to have them check in every 4 hours at the minimum.

I understood what he wrote, but that’s not what I’m seeing with my sensors. Pulling the case to trigger the tamper does appear, but the status time and date does not change at all. I had all 3 sensors set to 1 hour update intervals the last two days, waited, and saw no changes in anything. The sensors have been online for over a year, so there’s zero chance that they’re still at 100% battery.

@csstup & @philh30, Could you add Ecolink’s Motion sensors to your driver?

PIR-ZWAVE2.5-ECO with a fingerprint of 014A-0004-0001 (Manual with command classes here)
PIR-ZWAVE2 with a fingerprint of 014A-0001-0001 (Manual with Command Classes here - same classes as above model)

I am happy to help test. Thank you!

Those are already in the ZWave Sensors PH driver.