[ST EDGE] Z-Wave Sensor Driver Channel - including specific Ecolink, FortrezZ, HomeSeer and Zooz models

So I tried again and it added but doesn’t show battery status and open/closed status isn’t outing or correct. Not sure on fingerprint. Unsure if it’s the first or second Ecolink listed or how to find out.

EDIT: I’m thinking it’s the second Ecolink as it’s listed on their website as 2.5 as well came up in Z-Wave JS database as 2.5.

Still new to edge so what is it that I’m supposed to do with the fingerprint @philh30?

I don’t see anything called fingerprint in both the web interface (groovy ide) or the app. How do I find this?

@philh30 i have same device. This is fingerprint for a Monoprice tilt sensor

I don’t know why I can’t generate that “Device Info” screen on iOS SmartThings? I just installed SmartThings on my Android tablet, and I still can’t find any kind of Device Info or Fingerprint. Is there like a Dev mode I need to turn on?

Mariano’s driver Z-wave Thing. You need to change drivers to show that info

1 Like

Install this driver, then change the device’s driver to it.

@csstup , Ii know you are busy with other things, but wanted to check if there is any progress on a driver for Remotec ZFM80.

1 Like

For Monoprice Open/Close sensor with External Contact, is that the HKZW-DWS01? I am looking for the right edge driver for it. Do you have any information about it? Thank you very much.

I’ll followup on it, thanks for the reminder!

1 Like

It probably as much a hardware issue as a software one, but I have a Fortrezz valve that falls permanently asleep about 24 hours after being rebooted.

I see under the Smartthings Edge driver wiki they list three different Fortrezz valve drivers and was hoping to try each one to see if this helps the problem. When I look under my ST app, there are no alternative drivers listed. Where can I found the drivers that are listed in the page in the link? Thanks.


|FortrezZ|0084/0213/|Zwave|FortrezZ Valve||zwave-valve
|Zwave|FortrezZ Valve||zwave-valve
|FortrezZ|0084/0243/*|Zwave|FortrezZ Valve||zwave-valve

Those 3 models all use the same Zwave Valve (zwave-valve) Edge driver available as a beta from SmartThings directly.

Got it. So that’s one driver for three different devices / fingerprints, as opposed to three drivers for three separate devices. Is there any chance of doing something with the driver to keep things communicating beyond 24 hours, or is that pie in the sky? I’ve read a little about nodes and associations when it comes to z-wave, and was wondering if there was anything that could be done that way to help.

Whats your Zwave network look like? How many devices? How far is the device in question away from the hub? Do you have any powered repeaters in the network (plugs/outlets/switches generally) if the device is too far away from the hub? It appears as though that valve is powered, so it doesn’t have the issues that sleepy devices do.

Thats a Zwave 300 series (non Zwave plus) device, so its range isn’t great out of the box.

@csstup, this particular device has a very clearly written custom DTH that could be used for reference when adding it to your Edge driver.

1 Like

Thanks, yeah I have that bookmarked.

I actually ordered a FLS100 G2 during the black friday sale. I’ve not had a chance to work on it yet though.


I did too. :smile:

Hey @philh30 can I get some help on finding what you need to help me? Never got a resolution. I added the driver and it shows up as having like 12 different sensor types and none work. What am I doing wrong?

Hi @csstup , I wanted to check in to see if you’ve been able to look at the HS fls 100. I know before you hadn’t had a chance but I’m thinking you are my only hope!

Thanks for all your contributions to the community!

Not yet. I’ll see if I can get some of it this weekend and the coming week.


@philh30 and @csstup. You added the Monoprice 4-in-1 sensor to the “Z-Wave Sensor PH” driver back in September and it has worked very well until the New version ( of the mobile app was released a few days ago. I am assuming the same problem will happen with the Zooz 4-in-1.

The problem is that the display has the large Multi-Tile icon which causes the new Mobile app to crash when you open the room that contains that tile.

Could you modify the driver so there is an Option to use the small device tile until ST fixes this problem. If they ever fix it.

I am temporarily using the stock Z-Wave driver to solve the problem, but that driver does not have the setting menu that lets you customize things.

1 Like