[ST Edge] Virtual Things Edge Driver

Thanks for your reply Yakov. How do I get the logs? Also, I have deleted the switches and recreated new ones.

@ygerlovin - Again, the same problem and now two of my key switches got stuck now. How do I send you the logs and please can you let me know the permanent fix for this?

Worst case, I have to again delete and re-create the switches.

Hi, is it possible to disable the user button of a switch? I need something that can reflect the state of my home alarm. I am using a Z-Wave relay to send the state into ST, but I can’t find the right way to only show the state, not have someone able to change it…


Hello Yakov! was the vSwitch with no contact sensor option removed? I remember we had this possibility to create switches without contact sensor in the past and now I tried to create a new vswitch and I couldn’t find this option anymore.

There is an option in his Virtual Switch under settings to make it a simple switch.

@Paul_Oliver Oh I completely forgot that. Thank you very much for the help!

You can also modify a switch after creation to remove the contact sensor, in device settings.

Removed as I was able to fix the problem.

Pardon my ignorance as I am struggling with some basic issues. Here is my situation:

  1. I control my 2 garage doors by installing zooz z wave multirelay (just switched from old groovy driver from the vendor to their new edge driver)
  2. New setup didn’t create child devices (Garage door 1 and 2) like the old one and so I am trying to create 2 virtual devices for this purpose instead of controlling the doors via multirelay device in Smartthings
  3. I did install the new vDev Controller as per the instructions on this page but I can’t see the detailed view screen (split screen that show all types of virtual devices) as mentioned above when I click on the virtual device in my Smartthings app on my iphone. I only see 'Off/on, Timer, Virtual Thing Type (I can change the type when I click on cogwheel), Controller Status and Info
  4. I am on 2.3 version of this driver

Not sure why I can’t see the detailed view like you guys. I also don’t see where I can input number of devices I want to create.

Another question is how to link the virtual device (garage door in my case) to Relay 1 of multirelay device ?

You manually create the Multi Relay child devices.

Go to 3 dots in upper right corner of device page, select settings, near the bottom of the list go to “separate devices for relays” and change to Enable.

Thank you Paul. After doing what you suggested, I now see the new child devices from multirelay created. Now how do I link virtual device to the child device from multirelay ?

There is NO need for any virtual devices since the driver update pushed last week allowed the creation of child devices.

The child devices should be functional and will show up in Alexa and Google.

Got it. I should have realized that from your previous reply

1 Like

Could you add a FRIDGE icon to your virtual switch?

Thank you

I’ve added the driver to my hub, searched for nd added the device, but can’t open it. Tapping on the device does nothing

Try to force close the app and reopen. I’ve had some devices not work until I did that.

looks like this app has been removed? Internal server error

I use virtual devices to group and control other devices. Specifically I have motorized window blinds. Rather than controlling them each individually I created a virtual dimmer switch. When I set it to 20% I use the Rule API to then set all the shades in that room to 20%. (This driver does have a virtual curtain switch which I wish I could use instead of a dimmer, but it only supports open and close, no percentage in between).

Nothing to do with this particular edge driver, it’s a platform problem affecting many channels. :disappointed_relieved: See the current active discussion thread:

Unable to join channels (25 Jan 2023)

Yes, was asking a question since some worked yesterday and several do not. It’s not all that are affected.

1 Like