[ST Edge] Virtual Things Edge Driver

Could you add a FRIDGE icon to your virtual switch?

Thank you

I’ve added the driver to my hub, searched for nd added the device, but can’t open it. Tapping on the device does nothing

Try to force close the app and reopen. I’ve had some devices not work until I did that.

looks like this app has been removed? Internal server error

I use virtual devices to group and control other devices. Specifically I have motorized window blinds. Rather than controlling them each individually I created a virtual dimmer switch. When I set it to 20% I use the Rule API to then set all the shades in that room to 20%. (This driver does have a virtual curtain switch which I wish I could use instead of a dimmer, but it only supports open and close, no percentage in between).

Nothing to do with this particular edge driver, it’s a platform problem affecting many channels. :disappointed_relieved: See the current active discussion thread:

Unable to join channels (25 Jan 2023)

Yes, was asking a question since some worked yesterday and several do not. It’s not all that are affected.

1 Like

Running version 2022-09-05T16:43:00.263002113 - I only see a v1.7 (2022-05-30) listed above btw, but assume that there was in fact a later version.

Have 25 contact sensors, all of which worked perfectly until today. Today, one contact sensor shows a spinning wheel when you try to turn it on in Smartthings. It eventually stops spinning and state does not change. All other sensors seem to be working fine. I rebooted my hub, which is on 000.046.00008, as well as my phone but no change. Any ideas?


I got vDev controller installed and created a couple of vTemperature devices. How do I get the vTemps to be updated with something now, currently default of 20C. If its important I have a couple of Aeotec multisensor devices.

You can use Rules API to update temperature on virtual temperature device.
(MQTT device is also virtual temperature measurement device)
This example is for [ST Edge] vEdge Creator virtual device driver.

Edit: This driver is not supporting any commands for temperature measurement.
If you want use Rules API you have to use [ST Edge] vEdge Creator virtual device driver.

My issue looks like it may be similar to what @Subramanian_Swaminat was experiencing back in October. It looks like @ygerlovin has not been online in the community since then … is all OK with him?

While I’m still unsure about what caused it to begin with (last hub firmware update was weeks ago), I temporarily installed @TAustin driver, switched to it, and switched back as discussed in an October post, and then put the Contact Sensor back into normal state. Hope all is well with @ygerlovin

Is there any way to expose the vMomentary to the updated built in “Smart Lighting” app? The regular vSwitch shows in “Smart Lighting” just fine, but the vMomentary never shows up. I am trying to migrate several virtual momentary switches from DTH “Anidea for Virtual Momentary” to this Virtual Things Edge Driver. Thanks for this great tool and thanks in advance for your help on this.

Answering my own question. It seems quiet here from @ygerlovin so I just gave @TAustin’s vEdge Creator a try, and his Virtual Momentary button is both visible in and works with Smart Lighting. Here is a link in case anybody else runs into this issue:


2 posts were split to a new topic: How to Use Edge Momentary Device?

Regarding the issue that I reported a couple of days ago about the contact sensor / switch becoming inoperable (just 1 of my 25), it appears that it does recur. I think I have narrowed it down to 1 contact sensor (not always the same one) becoming inoperable after my Hub is rebooted. I’ve rebooted it a few times today (unrelated - to test some notification functionality i’ve implemented) and when the hub comes back, one contact sensor is hosed up. If I change to another driver and back it fixes the issue, but it would seen there is an underlying problem. As I believe that I can repeat it frequently, I would be happy to pull logs if that would help … just need some direction on what to do. Thanks, Todd

@DaWeav did you ever get “vThermostat” to work?

And if you did how are you transferring the current temperature from a temperature sensing device to the virtual thermostat?

Small bug @ygerlovin, is that the kwh are not correctly shown when i use a blitzwolf plug with your driver.
An hour of charging at 3,2kwh, adds 0,3kwh usage.
Start: https://i.imgur.com/WIExey3.jpg
Charging rate: https://i.imgur.com/TIQoCdA.jpg
End: https://i.imgur.com/DDfWI3c.jpg

(see the phone time top left corner of screenshots)


I’m using the Virtual Things Edge Driver [YG] (version: 2022-09-05) and I would like to start using the Power Meter (vPower [YG]) - but I cannot deal with it.
I tried many different commands to set it up, but I failed.
I suppose the commands should be something like:
./smartthings devices:commands “…its.id…” “powerMeter:value(9)”
./smartthings devices:commands …its.id… {“energyMeter”,“value”:10}}
Could you give me an example what the commands should look like for the vPower virtual device?
I would like to set up the powerMeter and the energyMeter as well.


Help. Samsung has erased my hub accidentally I’m being told after noticing my devices, scenes, routines all missing from the ST app. Has this happened to anybody else? Is there a way to recover my Vedge devices I created that as I understand live in my hub and nowhere else, right? When I login to the graph.api website, I can still see my missing devices (see pic). Does that mean they are still alive in the cloud?