[ST Edge] vEdge Creator: a virtual device generator for end users

If I am experiencing that bug where no device gets created when scanning for nearby devices, what are my options?

I just purchased an Aeotec hub.

I did successfully install the driver, but now just can’t create the controller.

Any ideas?

Just noticed someone posted the same thing above. Are we stuck? Is there anything to be done or is it just wait and see?

FYI, if you run into the issue with the device screen not opening, DO NOT TRY UNINSTALLING. It’ll break all the rest of your devices, too. Clearly a ST issue, and i sent a bug report

1 Like

We are stuck until Samsung decides to fix it. Being an iOS issue they don’t seem to be in any hurry…


Well darn. Thanks for the reply.

This driver is featured in today’s video from @AutomateYourLife


Cause it’s fantastic!


Nice work @TAustin ! Admittedly jealous :slight_smile:


This is cool; thanks for the coverage!! :pray::+1:t3:


Don’t thank me. You made it!

1 Like

@Derekeys and @aaronburro - It looks like SmartThings have reverted some software to address the discovery problem with iOS apps, so if you were having this issue, you should try again now and see if it works.

1 Like

Thank you!!! I went ahead and got a cheap android tablet and that did the trick so i can’t test if I can just discover through iOS just yet. Thank you for your work, do you have a Venmo or somewhere we can donate? Thank you again!

Hi…all installed no problem
I want to use the presence sensor to show if someone is at/away from home (the iphone doesnt show that as you know in ST app) Then I can use that presence to trigger something else…
Do I create a routine to switch presence sensor on when iphone is present,(using member location) then another to switch it off when not present? - so 2 routines per phone?
I think thats what is said on an earlier thread , BUT having tried that , its showing as NOT present when at my home location?
Do I have to switch it on manually first time to get it to “sync”
sorry for the basic question…ive not used virtual switches before !

Not sure how the iPhone dies things, but on Android i had to allow the SmartThings app to have location access all of the time.

I only use it to detect when either myself or my wife is returning home after having been away for more than 30 minutes.

I have a 150 meter geolocation radius set up in the Home location.

I use it in a routine like this, for an Alexa announcement

Thanks Brad…yes iphone has a similar location access which I have on…
That looks like what ive set up except I want mine to stay on rather than turn off.
Problem is it seems to think im not present when I am?
maybe I have to leave and come back for it to sync first time…
I DID use life360 for all this , but of course its disappearing in ST…

I thought Life360 was a cloud to cloud integration. Therefore not going away with the loss of the IDE and Groovy?

I have noticed at times my wife’s Iphone gets lost and quits updating. Usually if I go in and refresh the connection in the linked services it gets back in sync.

I was using Life 360 as my presence sensor in smarthings to trigger rules… , which worked really well… but its being removed from Smarthings integration as an app as part of the migration , as far as I have read …so I need to now move to iphone presence to control lights/alarms etc…
Hopefully iphone presence is more reliable than it used to be :slight_smile:

I had similar situation first time I set this up. I turned off the presence sensor and turned it back on. It worked perfect ever since. Only thing, you need to keep your Wi-Fi on at all times. Even if your not home. Geolocation on phones work better when Wi-Fi is on. Also check that you gave ST app the permission to check your location “Always” in your iPhone settings. If it’s not set to “Always” it will only check if you open the ST app.

Thanks for the tip ! …yes wifi is always on and permission is set as you described…
hopefully the sensor will sort itself out now ive turned it off/on as you suggest
appreciate it

1 Like

@wakevortex let us know if it works or not. The community is always here to help

Yes that did the trick…seems to know the phone location now…I did a test out and back and all registered correctly - thanks for the help !

1 Like