[ST Edge] vEdge Creator: a virtual device generator for end users

Tod, your Virtual energy switches seem unafected ?

Well, if the problem is the same as the smoke detector, shake your head!! :man_facepalming:

It has been like this for 10 months and it must be very difficult to fix or it has priority -1000

I have over 20 virtual devices and I’m only seeing the one virtual switch doing this. Most of my virtual devices are virtual motion devices that look and are working fine.

Just your virtual switch. I have not noticed a problem with your other virtual devices.

@ygerlovin virtual switches are not affected. And @Mariano_Colmenarejo virtual mirror switches are not affected.

Don’t think so, but wouldn’t it be nice if that got fixed?!

1 Like

It would be great and I don’t understand how smartthings hasn’t fixed it yet!

So I hope that this new problem that has appeared is not the same.

1 Like

My virtual switch has been fixed by changing the profile icon in preferences.
Once this is done, both the plug and switch profiles work fine for me.


Agreed, just tested and i see the same

I have also changed back to switch and the tile reports condition (on or off)

However a long term result has yet to be established, short term may see connected return

Android S10

I just tested changing the Icon, and it did not help at all. iOS here.

Thanks @Mariano_Colmenarejo - changing the icon worked for me IOS15… issue on virtual switches only…

Are you changed the icon in preferences or editing device?

Icon changing worked for me too. Now all seems to be fine.

@TAustin Changing the icon using settings on Android fixed the problem.

Thanks @Mariano_Colmenarejo

1 Like

Interesting. The change of icon didn’t do anything for me, it was the change of profile from ‘Switch’ to ‘Plug’ in the settings, with the dashboard tile needing a further state change to display the correct icon. It remains OK on reverting to ‘Switch’.

1 Like

Ok, changed icon in settings, and it fixed it

1 Like

@TAustin I appreciate the most likely explanation for what we are all seeing is that you have been able to push out new profiles/presentations and we are basically cache busting. But just in case …

The change from ‘Switch’ to ‘Plug’ changed both the Profile and the VID the device was using, as you would expect. The Plug VID does have the states array populated in both device-config and presentation. Changing back from ‘Plug’ to ‘Switch’ does not seem to change either the profile or the VID back, or at least the change has not been reflected in the API yet. I’ve added the CLI output to the DM in case it is relevant.

Update: The profile has now reverted to a different ID, but it is a ‘switch’ profile with the same VID as the ‘plug’ one.

Strange… I am on iOS and have not experienced issues with any of my virtual devices.

I have indeed updated the profile used for this device to include an explicit device config VID that I created. I’ve done this ahead of pushing out a new driver, which I had been planning to do, but have held off as of this moment.

You know, it never was really clear to me whether or not changes you make to a profile that is used in a driver get pushed out before you actually re-assigned the driver to the shared channel (which I have not yet, but am about to do). So I can’t say for sure whether or not everyone is seeing it working again because of my (presumably local) profile change or because of changing the profile for a new icon. I’m not surprised the icon change works, since it probably forces a re-initialization.

1 Like

vEdge Driver Update!

As promised earlier, I’m pushing out an update to the driver that includes a number of new virtual device types as well as some other updates.

After some investigation regarding the ‘Connected’ state always showing in the dashboard for virtual switches, we found that the platform failed to initialize a default dashboard state for some as-yet-unknown reason. Thanks to @Mariano_Colmenarejo for finding a quick fix.

To try to prevent this from happening again, I’ve added an explicit device config definition for the virtual switches. I’m fairly confident this will eliminate this problem for any newly created switch devices. I’m “cautiously optimistic” that this will also fix existing virtual switch devices.

New supported device types:

  • Air conditioner: set mode, cooling temp, fan speed, and temperature
  • Fan: includes on/off, fanspeed, fan oscillation mode
  • Garage door: includes contact sensor, open/close with switch or button
  • Panic alarm: turn on/off with switch or button, set alarm type (siren/strobe/both)
  • Refrigerator: includes fridge, freezer, and icemaker components; for fridge & freezer, control door contact state with switch, set cooling temp, set actual temp, icemaker on/off
  • Temp/Humidity - including the ability to set either
  • TV: includes on/off, set channel & volume; (warning: media playback buttons included but currently not functioning due to platform issue)
  • Video camera: create dummy camera to enable creation of camera groups (useful if you have only one actual camera device, but need to create a group)

Other new features:

  • Motion virtual device now includes device Setting option to change dashboard icons (additional icons are then available through device Edit menu)
  • Thermostat virtual device now includes ‘actual’ temperature field plus a control to set it

WARNING!: For A/C, Refrigerator, Temp/Humidity, and Thermostat devices, ensure your desired temperature unit (C or F) is selected in device Settings.

This driver update will automatically be installed to your hub. The driver version is: 2022-07-16T16:45:18.764904719

Once the new driver is installed to your hub, if you get persistant broken cloud icons for the creator device’s create and inventory buttons OR you still aren’t seeing the newly added device types listed, you can first try clearing your app’s cache or restarting the app.

If that doesn’t work, then (1) delete the creator device, and (2) do an Add Device / Scan for nearby devices, and you will get a new creator device. Once the new device is created, it may take a few tries, or exiting and re-entering the device Controls screen, but eventually it should function properly and list all the new device types.



It was by chance playing with the app.

Here we say: When the devil has nothing to do, he kills flies with his tail! :grinning:

I don’t know how this will sound when translated to english, lol

Good job and much appreciated!