[ST Edge] vEdge Creator: a virtual device generator for end users

Just to avoid future confusion:

There is no “V3 WiFi Hub.”

The 2018 standalone hub, no WiFi Mesh router, is commonly called the V3 hub, since it was the third US version of the standalone hub. It does have a WiFi radio so it can join a WiFi network, which the previous versions did not, but it is not a WiFi mesh router.

The model number varies by country. For the US:

Samsung SmartThings Hub 2018 (US), also called V3, model number GP-U999SJVLGDA or STH-ETH-300

Now that Samsung is no longer marketing hubs, the similar version from Aeotec is model GP-AEOHUBV3.

There have been two versions of the WiFi mesh routers. The first, SmartThings Connect Home, model ET-WV520, was discontinued over a year ago but is occasionally still sold from old stock.

The current version, Samsung WiFi with Plume (US), model number ET-WV525, has not been announced as discontinued but also no new hardware partner has been announced and it was not included in the new Aeotec line. So its future remains cloudy.

When posting in the forum, describe model ETWV525 as “the Samsung WiFi hub with Plume,” not as “V3,” in order to make sure you get accurate answers to your questions. :thinking:

1 Like

@JDRoberts - you rock! Thanks. Will refer to it in future as Samsung Wifi hub with Plume. I have two of these at different locations and also an Aeotec GP-AEOHUBV3.

The Samsung phone support was not very helpful regarding Edge support on my hub.

1 Like

The Oct release of version 38.11 was supposed to support Edge drivers on the Plume Wifi Hub. In another thread, Samsung acknowledged that there are some bugs that are preventing it from working properly. When they might actually fix the bugs is anyone’s guess. It’s been nearly 6 months since that release and there have been 3 releases for the Aeotec hub in the same timeframe. It seems pretty clear which platform they are prioritizing.

1 Like

Understood, but I would cut frontline support a little slack since edge is still in a developers beta. It hasn’t even been opened up for a general customer beta yet, it’s just that if you come to this forum, you can get the link the developers have posted and try it out.

That said, I am personally very annoyed that they haven’t said one way or the other what they’re going to do about the Wi-Fi hub with plume. Maybe they’re still looking for a hardware partner for it since Aeotec doesn’t seem interested in that model, but the silence is not helpful.

Well, that’s a conversation for a different thread.

Just wait until next hub comes out this month.
It’s scheduled for debut in March in Korea.
I am talking about SmartThings Home Hub announced on CES 2022

That would be way off topic for this thread. It has no zigbee radio, no Z wave radio, can’t run edge drivers, and isn’t really a hub. Here’s a discussion thread for that one:

Samsung “Home Hub” announced for 2022

Is there any way to add an alexa enabled trigger to the window shade?

Make routine in Alexa to activate virtual switch which then activates your shades. To my knowledge that is the only way to make it work.

Sorry if I wasn’t clear. I have smart blinds that work with Alexa. I wanted to use the window shade virtual switch with an Alexa routine to enable ST routines, but the virtual window shade doesn’t currently show up as a trigger for Alexa. Right now I’m using the contact sensor which works but I’d like the icon to be the blinds

Ok. I see. I think there is no solution for this. There has been discussion about it in some older threads. You could contact developer and ask if it is possible to add shade icon to it though.

Thank you @TAustin for this solution. It neatly solved my issue of getting Alexa to announce one or more of my garage doors was open between specified hours. I’m already looking forward to replacing all of my virtual switches to achieve (finally!) a lot more local execution.

(Just realized this is my first post in, well, several years!)

2 Likes

Awesome! Glad it met your needs and thanks for posting :+1:t3:

Perfect! Tested and love it. This saves me a ton of time. You are the best bro!

2 Likes

Hey @TAustin really appreciate your hard work with this as I’ve created a lot of virtual devices using your driver…for several months now, so many thanks!

However, two nights ago, I rebooted my SmartThings V.3 hub, and when it came back online, none of the virtual devices that I created with the vEdge Creator were responding.
I have several device types using the V2 driver and they all are inoperable right now. When turning on/activating any of these virtual devices the button will rotate for about 5 seconds, then an error: “A network or server error occurred. Try again later.”

When I try to create a new virtual device using the generator, it will time out after ~5 seconds with the same error as above.





What is interesting is that I still had the v1 drivers installed, so when I change a device from v2 to v1, the device works again.
I can also use the v1 Generator to create a new virtual device, which works (using the old driver), so then I change the v1 device to the v2 driver, and it stops working again.

What is also interesting is that there are NO logs created for the above issues when they occur in the IDE or in the ST app.

I also have several virtual edge devices that use ygerlovin’s drivers with no issues.

I’m assuming I could change all the v2 devices to the v1 driver, then reinstall the v2 drivers and then switch all the devices back to v2? I have SO many drives with complicated routines, that it scares me to uninstall the associated driver – as I believe that would uninstall all the devices using that driver, is that correct?

What are your thoughts?

Here’s the hub’s info:

Hub Firmware version: 000.042.00007
Hub Hardware version: Hub v3 US

Zigbee:

  • State: Functional
  • Version: 5.4.0
  • EUI: 286D970002003681
  • Channel: 14
  • Node ID: 0000
  • Pan ID: 82C0
  • OTA: enabled for all devices
  • Unsecure Rejoin: true

Zwave:

  • State: Functional
  • Home ID: D6916F2A
  • Node ID: 01
  • Suc ID: 01
  • Protocol Version: 6.04
  • Region: US

Firstly, I’m really sorry for the trouble you are having. It sounds like with that last hub reboot that for some reason the driver did not get successfully restarted.

My recommendation would be to reboot your hub again to force the driver to re-start. Hopefully that will get your devices working again.

3 Likes

I’ve been in IT for a long time my man, so I respect your answer - REBOOT IT!!! However, I rebooted the hub several times after turning off most of my devices and disabling a lot of automation. I left it alone and went to bed. Woke up today and it’s all working now.

I’ve been on the ST platform since launch, and I’ll tell ya, that was a crazy flap my man.

Thanks for your work.

1 Like

We’ll these are quite frustrating situations. As the Edge platform is still in beta it’s possible this was just an anomaly - they seem to happen less often with zigbee & zwave drivers. Personally, I see regular cases where a driver (re)install doesn’t always run to completion, thus my recommendation to reboot the hub. But why you saw such a long delay before the driver started working again, is a mystery.

I recommend to anyone using Edge drivers to have the CLI available because with it, you can force driver reinstalls and monitor progress via log output.

Anyway I’m just relieved that your devices are working again; I appreciate the huge pain it would have been to have to recreate them and their associated routines!

2 Likes

Yeah my man, it was hard to go to bed w/o resolving it, especially since I rely on a lot of virtual switches to run automation w/ external services. And yeah, not being able to see logs is painful, so lesson well learned.

Thanks for your work!

I hope all this Edge stuff stays stable because I currently have a total of 21 various virtual devices running using this driver. Thank you!

BTW, the one thing that I was running Webcore for to flip a Virtual switch On/Off when the v2 Hub was On/Off its internal battery power stopped working after the last Hub v2 firmware upgrade. So I’ve now had to switch over to a dedicated canary smartbulb solution which only triggers when power is restored. So do you know if SmartThings exposed the v2 Hub battery power condition somewhere in this new Edge programming language where it shows when the v2 hub is on battery power and when it isn’t? If they have, then since SmartThings themselves do not support any battery condition switch on their hub device driver, maybe a Virtual device could follow the On/Off battery condition to trigger routines when there is a power outage and restoration of power.

Not that I can see. If I display capability status for the Hub using the CLI, it shows a ‘bridge’ capability but nothing else. And it shows no status for ‘bridge’. If I display health status for the hub, it shows only deviceID, state (.e.g. “ONLINE”), and last updated date.

1 Like