[ST Edge] •• Tasmota Edge •• for Sonoff, Tuya & many other ESP WiFi devices - over 2000 Tasmota supported devices

84 - 78 - 48 - 96 - 94 differente for all my device, but all not work after update drive edge.
Do you have problem with other Edge drivers/devices?
[/quote]
no, no problem.

yesterday after rebooting the hub everything is back to working perfectly. This morning, however, the socket did not go out after the input came from a routine.
I will continue to try to understand why

EDIT: now all ok, with routine my socket correct power on.

Still problems today.
I don’t understand why, but all my tasmota devices (I only have shelly smart plus S and Shelly 1PM) from 3:28 this afternoon have no longer transmitted updates in the history, and they do not work from the Smartthings app. If I log in from a web address it works correctly. I don’t know what tests I could do, but I’m pretty sure it depends on the drive considering that from web address they work fine

Do you have duplicate ST devices for the same Tasmota device?

Can you try going to the device settings and change the “IP address” to a different one, then change back to the original one?

No dublicate ST device.
Yesterday to try to solve the problem I tried to add a new tasmota device from the “Tasmota edge” device to see if it worked.I deleted the Device “tasmota edge” is with him all the tasmota devices created are deleted. I deleted the edge drive, and reinstalled it from your link.
In this way I lost all the automations and all the presence on Acton Tile scenes and dashbars, patience, I will have to redo everything, but at least now the ones I inserted are back to work. Maybe some problem in the drive in my hub after the update, I can’t find any other explanation

Hi,

I got two plugs running tasmota I’m trying to control using the Edge driver, but recently they started dropping connection to the hub. I can still connect to them using the web interface.
Yesterday I removed the driver and then added the driver and plugs back and it worked for couple of hours. This morning the connection was lost again and I tried rebooting the hub which restored the connection to the plugs.

I believe the problem started when I had to reset my broadband modem to default settings and the plugs which get IP address from the modem DHCP got new addresses. I changed Edge driver settings to use the new plug IP addresses to get them connected again and that is when the problems started.
I then changed the plugs to use static IP address and to the old IP addresses they had before resetting the hub and Edge driver back to the old plug IPs. But still losing connection.

Deleting the “Tasmota Edge” device will delete all Tasmota devices.

@Diegocampy @JP3000

When a device is not working, open up the Tasmota console and interface, and toggle some action (e.g. on/off), does it send a WebQuery to a IP address http://<ip>:<port>/j and receive a "WebQuery": Done. If it failed, does this IP address match the IP address as shown on the “Tasmota Edge” - Gateway?

And any actions from SmartThings App (e.g. on/off) will also be captured in the Tasmota console.

1 Like

06:27:02.122 RUL: POWER1#STATE performs “WebQuery http://192.168.1.2:49525/j POST [Content-Type:application/json] {“Mac”:“D8BFC0DBF351”,“STS”:{“POW1”:“1”}}”
06:27:07.272 RSL: RESULT = {“WebQuery”:“Connect failed”}
:roll_eyes: Connect failed. In ST i see all the change of Voltage but not the state on or off.

I again deleted all devices, from IDE I saw that all Tasmota devices were duplicates. I tried to delete the older of the two, but still nothing worked, so I deleted everything, including the drive, and reinstalled by plugging in only one socket with the key. For now it works, I don’t add any more and just monitor this one to see if it continues to work

I forgot to make this check, yes the ip is correct, but the door is not, I only checked now though. Maybe because I deleted the dirve edge and then reinstalled? Could it be that the door has changed for this reason? In the query from the edge console I see port 49525 while from the app ST on the tasmota edge I see port 43111.
When I get home I check from the console if the port will be updated to 43111

Ok after check, the port 43111 is correct and the socket for now work fine. I don’t know what was the problem. I wait 2-3 days before added new socket.

And here I am again… Little by little I reinserted all the devices, they worked for a few hours, now they no longer work, none. And from console you see the connection error when I try to change state from the browser (which works, only from SmartThings does not go)


I have no more ideas about what to do, :pensive:

Does the IP:port (192.168.1.2:39363) match the “Gateway” IP:port in the “Tasmota Edge” device?

If they match, are you able to control the tasmota device within the SmartThings app?

Yes, they correspond but are not able to control from the ST App. From browser it works, console detects the failed connection, but nothing else happens.


hello
i added my th10 as pool temperature, its not showing temperature at main page, how to fix it ?

I tried to test drive edge with CLIi : https://github.com/SmartThingsCommunity/smartthings-cli

with the command: smartthings.exe edge:drivers:logcat

hangs here. while with other drives it works. It is precisely the drive edge that no longer communicates

Hi @hongtat

I am facing similar issue, the tasmota device loses connection with hub after few hours
I deleted devices and added them Again many times and still i have same problem working for sometime and stop working

It was working perfectly but i don’t know why i am facing this issue now!!?

Once my device loses the connection, i can’t control from ST app but i can from web browser

After much testing, I can say that in my case, the problems come after adding a certain number of devices. I have 10, I connect 8 and the problems begin, loses the connection and none of the tasmota devices responds to commands, while from browser they work perfectly. I deleted 5 devices, and the other 3 after a few minutes started working again. I emphasize, that when the devices do not work, the parent device tasmota edge does not work either. It is impossible to create new device.
This is to say that it is precisely the drive that no longer works, perhaps clogged with too much information.

1 Like

@Diegocampy @amin300

It’s probably due to this, I’m investigating -

(And it appears it may work again after a few retries in the ST app…)

1 Like

Maybe your guess makes more sense than mine. I say this because none of the 3 Tasmota devices works this morning, not even Tasmota Edge to create new devices. Everything blocked. I tried unsuccessfully to exist but nothing. It was therefore not a question of the quantity of devices.

EDIT: If it is for development, I have kept three active holds. They don’t work for hours, then at random they start to work for a few hours, then that’s enough again. In fact, if I look in the chronology now it doesn’t work and the last data in chronology is 6 hours ago. Maybe a coincidence, but before the last drive update, I had no problems.

EDIT2: i deleted other 2, now only one device tasmota and it work fine.

Hi @hongtat
Any results of your investigation?
The issue is still there!

Thanks

You may try reboot your hub.

There is a new SmartThings Hub firmware version 0.43.4 releasing 06 June 2022~ 10 June 2022, and it appears to address these problems.

Thanks for your reply
Hub was rebooted and devices started to work for sometime but after they have stopped responding.

I will wait for hub update and test again.

Is there any driver update to follow the firmware changes? As i understood from release note there should some changes done in driver too! Maybe i am wrong