[ST Edge] SmartThings MyQ Edge

So I love Brian and all he has done for us over the years and will it be ever grateful for his work. I opted to go with the Zooz relay and remote and love the solution so far. I to have 2 garage doors and set up automations for left, right, and both. While you can control the relay directly, I set up a series of virtual switches that I call, and those virtual switches are in the logic to compare for door position. The automations confirm the position of the tilt sensors, so I’m not randomly opening and closing the door just because a virtual “button was pushed.” These virtual switches (buttons) are what I use with the Alexa.

Here is a helpful article

And if your not into soldering or just to lazy like me. Here is a link to purchase modified remotes. I received mine in just a few days.

https://www.garadget.com/

Enjoy!

1 Like

I have seen this with mine before - hub reboot seems to be the only fix. It’s not a common scenario, though.

The unique ID of each device is the MyQ serial number, so as long as that stays the same, it should pick it up just fine! Glad that went smoothly.

Still having issues with this? That’s a pretty weird sequence of events that it would discover devices but then bail on missing password after.

1 Like

Daily for the last week or so, I have been getting an invalid credentials error. I have had to go into the Controller settings, change a character of my password, save, re-enter the correct password, save and viola…working again…until the next day or so. Any reason I might be experiencing this? Changes on the MyQ side perhaps?

Running the Windows bridge exe.

Hi,

So i’m kind of dumb and not sure what i did wrong. Like an idiot (possibly) i installed all the drivers which i probably don’t need. I was able to get just about everything else up and running but the MyQ-Controller (i have 2 and i think that’s the driver problem) the one i was able to log into and it shows “myQStatus: Connected: 1 Devices” and the shows my bridge IP. However no garage door ever appeared under my unassigned devices and nothing comes up when i do a scan. The controller portion doesn’t seem to do anything as far as opening or closing the door. Is there something i’m missing or have just done something super wrong? Any help or insight would be appreciated. Oh i can say i’m currently running HomeBridge on my RPi4 and it is also using the same port 8090 not sure if that could also be the problem.

which drivers did you install?

What do your bridge server logs look like?

bet he installed MyQ ConnectorBETA and MyQ Door in addition to MyQ Connector :slight_smile:

100% like literally all of them because i was not sure. But when i try to uninstall it says they’re in use.

So after much confusion on my part. Reading comprehension isn’t always my strong suite. These are the logs. I did edit the IP there, better safe than sorry. I was able to remove all the other drivers and now only have the MyQ Connection installed. However the in trying to uninstall everything i removed each device and now when i scan it’s not finding the MyQ Connector anymore. Sorry i’ve made a mess of this and do really appreciate the help and insight.

2023-05-21T06:21:25.093586270+00:00 DEBUG MyQ Connector MyQ-Controller device thread event handled
2023-05-21T06:21:35.050636942+00:00 INFO MyQ Connector Ready to create Garage Door (CG0860A56982) MyQLock.v1
2023-05-21T06:21:35.093738608+00:00 INFO MyQ Connector Refresh successful via (new user was yelled at about links):8090. MyQ devices: 1, ST-installed devices: 1
2023-05-21T06:21:35.100269275+00:00 DEBUG MyQ Connector MyQ-Controller device thread event handled
2023-05-21T06:21:45.098047280+00:00 INFO MyQ Connector Ready to create Garage Door (CG0860A56982) MyQLock.v1
2023-05-21T06:21:45.100204613+00:00 INFO MyQ Connector Refresh successful via (new user was yelled at about links):8090. MyQ devices: 1, ST-installed devices: 1

2023-05-21T06:26:25.307878957+00:00 INFO MyQ Connector Incoming ping from 192.168.0.0:8090 4b0c60ad-45c3-4b8b-ac62-e78d9e7a4b63
2023-05-21T06:26:33.233456909+00:00 TRACE MyQ Connector Received event with handler discovery
2023-05-21T06:26:33.235062909+00:00 DEBUG MyQ Connector Device discovery invoked
2023-05-21T06:26:33.701131576+00:00 DEBUG MyQ Connector Exiting discovery
2023-05-21T06:26:33.702093576+00:00 DEBUG MyQ Connector discovery device thread event handled
2023-05-21T06:26:35.367678910+00:00 ERROR MyQ Connector Non-200 response calling: http://192.168.0.0:8090/devices - 401 - body: Unauthorized
2023-05-21T06:26:35.374920910+00:00 ERROR MyQ Connector Refresh Failed.
2023-05-21T06:26:35.376279910+00:00 INFO MyQ Connector Send broadcast looking for bridge server
2023-05-21T06:26:35.479411577+00:00 INFO MyQ Connector Listening for a response at 192.168.0.1:54075:4b0c60ad-45c3-4b8b-ac62-e78d9e7a4b63
2023-05-21T06:26:35.552462910+00:00 DEBUG MyQ Connector MyQ-Controller device thread event handled
2023-05-21T06:26:35.592023910+00:00 TRACE MyQ Connector Server:tick
2023-05-21T06:26:35.644402577+00:00 TRACE MyQ Connector Server:_tick
2023-05-21T06:26:35.730358577+00:00 TRACE MyQ Connector Server:route
2023-05-21T06:26:35.734938910+00:00 INFO MyQ Connector Host: 192.168.0.1:54075
Accept: application/json, text/plain, /
Connection: close
Content-Length: 72
User-Agent: axios/0.27.2
Content-Type: application/json

Just modified my Z-wave control setup for the Chamberlain garage door opener so that the remote control now has an AC power supply instead of a battery. I ordered an AC power supply that puts out 12v DC. I also ordered a resistor that steps down voltage from 12v to 3v DC. I soldered the output wires from the resistor to the battery terminals in the remote. As with the relay wires, I melted the plastic on the remote cover with the soldering gun to form holes so I could pass the power wires through the cover.

The Zooz Zen16 Multirelay can be powered by the USB 1 amp power supply or by the 12v DC power supply. Zooz told me not to use the 12v power supply simultaneously for the Zen16 and the Chamberlain remote, but, as you can barely see in the photo, I did it anyway, and it worked. So, now I just have one AC plug-in for the whole shabang. As with my previous work, it ain’t purty, but it works. It’s parked in the garage so, hopefully, we will hardly ever have to mess with it and it is out of sight.

Someone told me that I could use the USB power supply to power the multirelay, then tap power from the 12v terminals to power the remote. I put a multitester on those terminals while using USB power and found no power at all coming from those terminals. So, that idea doesn’t work.

I got the AC power supply from The Smartest House. I couldn’t find one I liked at Amazon. I got the 12v-3v stepdown at Amazon. There are a variety available there.

Update: while investigating this issue, I found I had 2 instances of the bridge exe running on my PC, so I closed and removed one from my windows startup folder and has not been an issue since. Fingers crossed!

I am done with trying to get MyQ to work with SmartThings. It is just not worth it anymore. I went with the new Konnected Smart Garage Door Opener. I love it! It works with SmartThings out of the box. The only bad thing is the open/close senor does not show up in STHM, so if you want to monitor the garage door you have use a different sensor.

Any old garage door smart controller will work if you solder the trigger wires to an old garage door car remote. Then it bypasses all the MyQ security and just opens the door like you pushed the remote button. The controllers come with a tilt switch and everything works like before this edge driver world.

I am trying to get this up and running and also stuck on “Searching for bridge server.” I did initially install the beta and garage door drivers as well, but after reading this thread I realized that was a mistake and uninstalled them, so now I only have the MyQ Connector driver installed. I’m running the bridge server on an x64 (not arm) Mac mini. My hub is connected to my xFi router via Ethernet and the Mac mini running the server is on a Wifi network from that same router. All seemed to go fine until this last step where my hub and the Docker server seem to not be able to find each other.

Here is all my server log says:

2023-05-30 17:03:47 5/30/2023, 10:03:47 PM | HTTP server listening on port 8090
2023-05-30 17:03:47 5/30/2023, 10:03:47 PM | SSDP server up and listening for broadcasts: urn:SmartThingsCommunity:device:MyQController

I also tried going into my router settings and adding a port forward for the Mac mini for port 8090, and that made no difference. Is there anything else I can try? Thanks so much in advance!

Can you expand on that Terminal command? I am also trying to run the executable on a Mac and it’s reading as a text file. I don’t have much experience with Terminal commands - can you write out the full line you used?

I’m running the LAN bridge server in a docker container on a Firewalla Gold router (running Ubuntu 22.04.1 LTS) with a Chamberlain myQ Smart Garage Control and everything worked smoothly out of the box!

Thanks very much for this!

1 Like

Same, this worked great out of the box. Detected both of my garage door openers automatically and quickly. Now what do I do with those extra SmartThings tilt sensors I had attached to the doors? What will I do with all those extra batteries?! :laughing:

While on the topic, is there any chance of getting garage door opener light controls thru the new edge driver?

1 Like

MyQ does not expose remote door light control unfortunately. Missed opportunity in my opinion. If that ever changes, I can certainly update the driver to work with it.

Anyone else experiencing issues with the setup recently? Everything was working perfectly and like 2 days ago it stopped working. I’m using the windows 10 .exe file and it just keeps timing out when posting back to the server.

The myq app is working just fine. So i know the bridge is talking to the garage door opener.

Try power cycling your hub maybe?