[ST Edge] SmartThings MyQ Edge

That is the way I had it set up also, but the door only opens a couple inches and then stops.

Known iOS issue - can’t deselect the turn on / turn off action in the latest release of the app.

1 Like

Screen Shot 2023-01-26 at 5.32.45 PM
any experiencing this? It is just started to happen and now all my garages are offline! @brbeaird

I do see this quite often but it recovers on its own.

@Nezmo My garages are offline and not connecting!

Yes, mine was down for awhile but came back up.

Hey all. I keep running into this on an almost daily basis. Any ideas? Thank you!

Same here. Any idea after?

Hi - I could really use some help here. I have downloaded all of the files etc and can get the garage doors to connect via the MyQBridge Server with Windows.

I just cannot get Docker to recognize Smartthing and add Garage doors. I have the Container running and an Image installed

is that docker on windows or other system such as Pi or NAS?

Hi
It is on WIndows

I was a big user of the old MyQ groovy, and this awesome… however I don’t want to host my own server. I have found another way for those of us that in the same position! It’s using an app called LiveKey (new iOS name) / Simple Commands (old name on Android)… LiveKey/Simple Commands can connect to your MyQ account and can also connect to smartthings and also Alexa! You can also make routines within the app too.

You can use only the app with it’s routines along with SmartThings to get MyQ working by creating a virtual device in ST… but I’m using Alexa in between because I wanted to be able to close the garage door with voice…

For those that want to use Alexa too in order to close the door here’s what I did:
First let me preface by saying if you turn Alexa integration on after you’ve connected to your MyQ the app will create 2 scense in Alexa - one for opening the garage door (I deleted this one) and one for closing… so I created a virtual device in SmartThings that “turns on” when I get home… then in Alexa I set up a routine that “when” the virtual device from SmartThings “turns on” it runs the scene to open the garage door… and wala it works perfect!

2 Likes

What version of Windows? And what is the exact command you are running to start the container? I had issues with Windows 11 and Docker Desktop and and had to run the container with this command: docker run -d --name=smartthings-myq-edge --restart always -e 'MYQ_EMAIL'='your_myq_email' -e 'MYQ_PASSWORD'='your_myq_password' -p 1900:1900/udp -p 8090:8090 brbeaird/smartthings-myq-edge in order to be able to access the MyQ Connector on my local network (apparently the --network host doesn’t work with Windows 11).

1 Like

You no longer need the parameters for email or password as they are now set from the ST app :slight_smile:

Any chance that you can provide some more details?

1 Like

This code worked fro me.

Thanks Adam

1 Like

Hello all! Now that my old garage door sensor has ceased to function I am trying to get this running. I have a Windows 11 machine and am trying the .exe version before jumping ship and going docker container route in my Firewalla. Any help on why I have this continuous error will be appreciated!


Yes, please, more details would be great! I have Android; downloaded Simple Commands (LiveKey) from the Android App PlayStore (and created an account.)

I see I can add a connection to MyQ (using it’s login credentials). I also created a connection to SmartThings with the new API key generated.

But not sure what to do from here.
Thanks

@mypaintrain

In MyQ Connector (running in the SmartThings App), 3-Dots Menu, Settings:

These are the Settings that have worked well for me in Windows 10:

  • MyQ Polling Internal is set to 10
  • Device Include List is blank
  • Server IP (left blank to autodetect)
  • Server Port (left blank to autodetect)
  • Configure doors as locks (enabled)

I had reserved an IP in my Router for this computer, then tried to use it in the Server IP field, but it didn’t work as well as the autodetect.