[ST Edge] SmartThings MyQ Edge

changes made the notification work. thanks!

1 Like

Try to delete the driver and it will force an update

1 Like

Hi @brbeaird

I’m looking for a better understanding of what happens when you toggle on “Configure Doors as Locks” in MyQ Connector.

I was hoping to find & use them in SmartThings Home Monitor > Security (Set up Armed Away/or/Stay) > “Use All Locks”.

In the individual Garage Door Device Card, I don’t see any options for “Lock”.

I did try shutting down my Server, as well as closing/opening the SmartThings App.

I’m running:

  • Your Bridge v1.01 on Windows 10/64bit executable.
  • MyQ Connector v2023-01-21T00:…
  • Samsung SmartThings v3 Hub
  • Hub Firmware 45.00011 (Controller v2.3.13-9)
  • SmartThings App v1.7.94.21
  • Android v12

If you already had doors created when you toggled that option, you need to delete the doors and let them get recreated as lock devices - did you try that yet?

1 Like

Ahh… I get it now… thanks !

I had not tried that yet.

I’ll give it a shot sometime this weekend.

@brbeaird I’m having such a hard time with the step of hosting the bridge server on my LAN.

I tried the simple executable, but no devices are found in the SmartThings app when I scan for nearby devices; and despite going down an hours-long rabbit hole about CLI and daemon errors, I cannot get the image to pull. :frowning:

There are endless posts with “solutions.” Might you be able to point me in the right direction? Thanks so much!

@ brbeaird Thank you!

I am running the Windows OS executable LAN server and haven’t been able to add the device from ST app.

I saw someone mentioning the details check which I went to at “http://server_ip:port/details”, I think I am hitting the server but it does not provide any meaningful feedback except the following error.

Cannot GET /details

Unknown extra garage door found

Thanks for making this. Everything is working perfectly for me except an extra, non-functioning “Garage Door” is found. I have 2 garage doors in my MyQ app, but the Edge driver (or Controller app) is finding 3 devices. In the logs I see:

“Refresh successful via http://[redacted]:8090. MyQ devices: 3, ST-installed devices: 3”

In the SmartThings app, I see three devices, two of which have the same name “Garage Door” (which is the name of one of the garage doors in my MyQ app). One controls the door and works fine. The other does nothing. If I try to use it to open the garage door, it’s status changes to “Opening” but then goes back to “Closed” on next refresh. If I try and delete it from the SmartThings app, it comes right back. For now, I have de-deduped them by renaming the non-functional one “Garage Door X” in the SmartThings app to avoid confusion.

Update: I figured it out – the duplicate is a shared Garage Door that I had access to and was just named the same as my home Garage Door. (Nothing was happening because that garage door opener was replaced a couple of years ago – I just had not removed it from my account.) Leaving this comment here in case someone else has the same issue.

1 Like

Is there a way to have the bridge server executable minimized to only the icon tray and not the taskbar? Or even completely hidden and just auto start? I have it set to start with windows in cases when the pc reboots.

From executable:
1/23/2023, 10:53:32 PM | HTTP server listening on port 65484
1/23/2023, 10:53:32 PM | SSDP server up and listening for broadcasts: urn:SmartThingsCommunity:device:MyQController
1/23/2023, 10:53:37 PM | Detected SSDP broadcast. Posting details back to server at http://192.168.86.23:35783/ping
1/23/2023, 10:53:37 PM | Got status 200 from hub.
1/23/2023, 10:53:38 PM | Got new username/password from hub. Initializing connection.
myQ API: Successfully connected to the myQ API.

Easy to get the executable to find my doors but having issue with Docker. Docker is running but not finding devices:
2023-01-23 22:52:05 1/24/2023, 4:52:05 AM | HTTP server listening on port 8090
2023-01-23 22:52:05 1/24/2023, 4:52:05 AM | SSDP server up and listening for broadcasts: urn:SmartThingsCommunity:device:MyQController

Thanks for the work on this!

I think someone posted some instructions earlier in the thread for running a script at startup. You can also look into something called NSSM that can turn the executable into a service, which I would recommend.

I have learned Docker can be tricky in getting it to listen for SSDP broadcast. If you can’t figure it out, you may have better luck just specifying the IP/Port directly.

Will you also push a new docker image?

Also, what is the process for updating it if it is running as a docker image on my NAS? Brute force would be to delete the container, pull image from registry again, rebuild new container from it…

When connected with the executable it showed port 54370. I tried manually entering that with Docker and it connected right away. Not sure how I would have figured that out though with only having Docker. Thanks again!
Also configured and tested ‘always’ restart for the container. Good to go now.

A couple questions:

  1. I don’t know PI’s at all. Is: “Raspberry Pi 2 Model B V1.1 with 16 gb SD Card” sufficient for this effort?

  2. Have people already experience their Groovy-based MyQ / SmartThings integration stopped working? Asking, bc mine is still working as of today…

I’m using a Pi 1 and it’s been working for a few weeks without any issues.

Quick question, I have everything working ok, but when I try to use the garage door in a routine, it starts to open the door, but then stops. I have multiple options for the door in the routine and have tried different combinations, all with the same results. I don’t know if it’s supposed to be on or off or door open.

Have you tried clicking the TurnOn to remove the check and just using Door open?

2 Likes

When I try to uncheck the turn on, the door option disappears.

Interesting. Not seeing that in Android. Maybe somebody can confirm that’s an iOS issue?

in iOS, I have the “On” checked and “Door” set to Open in my Auto-Open Routine and setup like that has worked flawlessly since impementing this driver setup on my system.

1 Like