[ST Edge] SmartThings MyQ Edge

He said earlier

1 Like

@dualtronic, I think that most of us running docker on an SBC are running it on a Raspberry Pi that we obtained prior to the scarcity and price increase. I look forward to that time next year when it’s promised that RPi supply will increase and prices will drop.

I too would be interested in the insight of any others that have had success with SBC alternatives to the RPi, particularly still-affordable models.

However, it’s hard to beat the convenience of the RPi, due to all of the premade images, aftermarket parts that fit exactly, etc. Almost balances the current high price of the RPi. Lastly, don’t count out finding one used, though those prices are also high.

1 Like

Yeah, sorry. I missed that. It’s right there.

Just adding to it. ideally any SBC which can run a linux distro should work. I run mine on PineA64 (again acquired a few years back) with dietpi linux distro.

with the scarcity of pi and such boards, you’re better off buying one of the used micro PCs off of ebay (example not recommendation :slight_smile: ) or something and set them to reboot on power loss and such. They can run either Linux or Windows and can support docker instance or stand-alone executables.

1 Like

Thank you all for explaining the options. After thinking it over, the myQ integration makes perfect sense if you already have a Linux always-on computer conected to your home network. If so, it’s a couple configurations and done, no-brainer. But if you have to buy and configure a new always-on computer, then perhaps the relay and remote control method is most efficient. For $17, it’s simply cheaper and easier at the moment. However, when rPi (or alternative) becomes available, I’ll circle-back and give it another shot.

1 Like

Fair enough. Glad we could help.

$17 for the Zigbee relay. Wouldn’t you also have to add a tilt sensor to complete the solution?

I was going to say the same thing. Moreover, if you have more than one garage, then maybe ZOOZ ZEN16 is a better alternative and can control upto three doors and is zwave plus for SmartThings control.

1 Like

I had the original myQ integration, so the sensor is already there.

1 Like

I have a Raspberry Pi Model A Rev 2 (2011.12), has anybody tried running the software on that version? It is quite old, but it’s the only one I have.

+1 for painless migration from old driver (MyQ Door) to new (MyQ Connector). Portainer Stacks makes docker MUCH easier. below is how i have it set. it works on my Pi but i think we discussed previously that Docker code can be different for different OS’s?


services:
    smartthings-myq-edge:
        image: brbeaird/smartthings-myq-edge:latest
        container_name: smartthings-myq-edge
        restart: always
        network_mode: host
        security_opt:
          - seccomp:unconfined
        volumes:
            - ./smartthings-myq-edge:/smartthings-myq-edge

edit: removed the myq credential environment variables

2 Likes

Yes, I personally found where I tried using an old Pi that was running other stuff that I didn’t need anymore. I had issues and had to work at it.

I then created a fresh new SD for the same Pi and those issues went away and some of the hoops I had needed before to make it run weren’t required anymore.

So it definitely makes a difference to update and start with a current fresh install.

Just as a note - the bridge server no longer uses the MyQ email/password as environment variables anymore.

1 Like

oh yeah, makes sense

I have been going through this thread for a few hours and also the github and I am either very confused or very tired. Maybe both.

I am running the exe on windows… I am trying to set a specific port. I keep reading about a config.json but cannot find one. So I saw above the syntax is “{
“MYQ_EMAIL”: “email@email.com”,
“MYQ_PASSWORD”: “yourPassword”
}”

So I did that. I also saw where someone said to add PORT=

The exe when run as admin doesn’t seem to recognize any of this. I have it running on a vm that is on 24/7 but auto reboots once a week so I want to make sure everything is static. Can anyone point me in the right direction.

I also want to say how much I appreciate you building this for the new edge platform.

I have tried using both of the options to get this connection made. When I run MyQbridgeserver-win, I get the following log entries:
12/1/2022, 8:41:23 PM | HTTP server listening on port 58846
12/1/2022, 8:41:23 PM | SSDP server up and listening for broadcasts: urn:SmartThingsCommunity:device:MyQController

On the MyQ-Controller the myqserver address is http://192.168.0.3:58846 and the MyQStatus shows:Error: MyQbridge Offline:http://192.168.0.3:58846

I don’t know what I am doing wrong, but this is where everything stops.

Any help appreciated.

I have a ton of them never did anything with ?How high are we talking?

A ton of SBCs or thin client PCs?

I’m rather tech illiterate when it comes to setting up these things, but I was able to follow enough step-by step instructions to successfully install the the Dock on my Windows computer and install the image/container.

I was able to see the new MyQ Controller device on the ST app, but after entering username and PW, it just sits and says “Awaiting Credentials”. I have verified my credentials are correct.

Any ideas what the issue is?

Do I have to tweak the code anywhere on the Docker container? And if so, can someone please help show me where? I’ve looked everywhere and can’t seem to find where to troubleshoot.