[ST Edge] SmartThings MyQ Edge (Obsolete)

Got things working. Removed everything down to the driver, reinstalled, 'Viola!

I also have the MyQ login failed. Restarted the container on my Synology NAS, rebooted the hub, verified the login credentials were correct in the app. This is the log that goes over and over and over again:

@brbeaird - I think you do an amazing job. Will keep watching the boards to see if something might help!

EDIT: I was just looking around in the container app, and I found in the “image” section, the ability to update the program? Never knew this was here, but when I did it MyQ came online immediately in SmartThings. No idea what I did but it seemed to work! Maybe my instance of your driver was outdated…

1 Like

I was able to get the devices loaded into Smartthings. However, when I lock my computer I am unable to access the server and the devices go offline. I am trying to run the docker in detach (background) mode, but I cannot figure out how to do this. I went into the docker container and tried to use the exec setting to do this. When I use “docker run -d --name=‘smartthings-myq-edge’ --network=host 'brbeaird/smartthings-myq-edge:latest’h” it tells me docker:not found.

I tried changing the name and still got the same error. Am I doing this in the right place of the docker? I am very new to this.

Are you running on a Pi or something else? If the container is already running, you should stop it (docker stop smartthings-myq-edge) and then try running the command again. I also see some extra characters at the end of the command you ran.

Confirm you are running this

docker run -d --name=‘smartthings-myq-edge’ --network=host ‘brbeaird/smartthings-myq-edge:latest’

Windows 11. Do I do this in the execute section of the container? I am still getting the same response when I use the windows cmd app

Oh ok. I’m not sure of the syntax on Win11 but I know I had to stop mine in my Pi before I could make any config type changes to it.

Whenever my MyQ Edge server stops working I run the following sequence of commands to reset/refresh it and it usually fixes things. It’s a big hammer but I don’t need to think about it.

sudo docker rm --force smartthings-myq-edge
sudo docker system prune --all --force
sudo docker run --detach --restart=always --name smartthings-myq-edge --network=host brbeaird/smartthings-myq-edge

1 Like

The MyQ API is on the move yet again. I’ve been getting 429 (throttling) errors all morning. No solution yet.

1 Like

I am back up now. I stopped my bridge server for about 10 minutes and then started it back. I also changed the refresh interval up to 60 seconds. This is a setting in the SmartThings app on the MyQ-Controller device.

1 Like

I was up and down for about 15 minutes this morning, but have been error-free since. My polling interval remains at 10 seconds; it feels like 60 would be too long for certain automations. I have sometimes thought, however, that it would be nice if we modify the polling interval based on various conditions (time, presence, or whatever).

Mine was having problems this morning as well.

Windows 10

I did not stop it, just let it continue running.

At 10:24am it resolved itself and has been rock-solid since.

Been having lots of server off line errors or incorrect credentials. Deleted everything and started fresh. Now I get this:

My server is a Dell i3 micro pc running Ubuntu 22.04. This issue started in the last few days.

I’ve confirmed my MyQ credentials are good.

After trying multiple times yesterday and today it appears to be working this afternoon? Maybe 8th time is the charm. No changes made to MyQ account or credentials. I just restarted the server, added the controller in ST, input credentials (unchanged since yesterday), and it now works. Hopefully for a while.

Mines been solid since the last update using docker on my pi. No issues. Excellent work.

Spoke too soon.
“myQ API error: API call returned error: 429.”
And smartthings says
“Error: bridge server unable to refresh myq devices. Refresh failed.”

Ditto here.

That’s a throttling error - not much we can do about those. You can try shutting down your bridge server for an hour or so and also lengthen your refresh interval to something closer to 10-15 seconds.

1 Like

May have missed it in the long thread but I am getting a 403 forbidden when it is trying to access the partner-identity authorize API. Suggestions?

EDIT: Nevermind upgraded to the latest version and it is working

1 Like

Just curious, am i the only one that sometimes has an issue where the garage symbol is stuck on “closing” instead of closed… atleast 3 times ive noticed this. Only the last week ive been having this bug. The myq app shows correctly that the door is closed. Its very wierd.

have you tried rebooting your ST hub?