[ST Edge] SmartThings MyQ Edge (Obsolete)

did you also enter the IP address and port of the MyQ server?

will be interesting to see what happens when you get the forthcoming windows executable

1 Like

I tried it both ways. It is now setup with the static ip of my NAS and the 8090 port. Once I put the IP and port in the controller device says offline. The log message on the docker container has not changed. It does not show any attempt to log in to the Myq servers.

did you try using bridge mode?

I do have it in bridge mode and confirmed in a logger that my port is the same as being listened to in the docker container. I saw a post from another user that Smarthings is pushing a new firmware version. I confirmed I have it. I wonder if this is part of my issue.

Thank you for provided things to check.

1 Like

Good morning @brbeaird, are you planning to publish new server executables, including Mac?

Another item to note. Smarthings is in the process of pushing as new firmware release. I am on it so I wonder if changes implemented in this are why my controller device is unable to communicate with my docker container. Below is the link to the smartthings post.

https://community.smartthings.com/t/aeotec-smart-home-hub-2018-2015-model-hub-firmware-release-notes-0-49-09/268526**strong text**

1 Like
1 Like

Curious, is there a way to run this as a series of scripts only? Or is Docker or the executables the only way?

This was probably self inflicted, I forgot to stop the old docker image, I think I’m all current now and we will see how it goes today.

2 Likes

Hi All. I think I’m having same issue as others like @Jeffp92 indicated here. On Docker version and pulled down new image and rebooted hub. Connected and worked for a little bit, but I keep getting intermittent “Offline” error on the ST app. I manually re-enter my credentials to reconnect again. But it drops every few hours or so.

Any ideas anyone? I’m not too tech savvy, so any guidance would be appreciated.

Did you create a new docker container on your Pi with the new version?

If you did, did you remember to stop the old container?

I just looked and I am on version 49.09 it seems to be stable for me. At least it was last I checked.

Just shotgunning trying to offer suggestions to maybe get you going?

Edit: just looked at MyQ controller history again. Last entry was when I created my new container.

Guess I’m just lucky for now, I’m sure the luck will run out.

How can you check version of docker container?

I’m sorry. I only pulled down the new image and rebooted my ST Hub. I am not sure I know how to delete the old container and install the new container.

Is everyone stopping their old contained first, then pulling down th image to update it? Also Make sure you are not creating a second container.

1 Like

I did not stop the container before pulling the image as noone had mentioned that. Honestly I was lucky I got this working the first time. I’ll try to figure out how to stop it, re-pull the image and then restart it.:crossed_fingers:

The easiest method I have found is Portainer. No commands to remember. It has the stop and start commands as well as a recreate command and pull new image. Very easy. It is free and a web UI that runs on the station with your containers.

2 Likes

Can someone please help and just post the command lines to delete the old container and reinstall the new image? I assume it’s relatively straightforward to copy and paste for someone simple like myself to follow?

I recommend like @jkp suggested. Setup portainer. I just used portainer to stop my old docker container.

I did not select the pull new image. I did the pull command via command line like when I 1st created it. Those commands are on the 1st post of this thread, or on the GitHub page. I forget, I had saved my command line I used initially and some notes in a text file. So I just copied and pasted those to create my new container. I know what I ran had options which are not needed anymore because the ID and Pwd are now set in the app.

It started the container up and found everything automatically on it’s own.

I’ll share my commands I used in docker to pull and create my container as soon as I can get to my PC to open my notes.

1 Like

Thanks. I was able to pull down the new image correctly using the Docker Pull command line from the original install instructions at top of page. Just wasn’t sure how to delete old container and replace with new image given there are no commands listed to do that.