[ST Edge] SmartThings MyQ Edge (Obsolete)

Open myq connector in the st app, tap on 3 dots and select settings

1 Like

I am trying to setup a routine to notify me when the controller or door go offline by using the device health property visible in the Routines. The routine does not seem to fire.

Any tips so I can get notification if something is potentially not working properly?

Sorry for the repost… but I think I posted it previously in the Obsolete topic. Hopefully I can get some help here:

Well this had been running flawlessly until this morning…

I opened the app to discover both garage doors were offline. So I checked my always on PC bridge server and it was reporting all sorts of difficulties. I shut down the bridge server and restarted, then the ST app was reporting “searching for bridge server”, or “MyQ server” offline, and when connected it would say “Invalid credentials”. Got it to function correctly once, but it was only functional for a few minutes, then I would return to all the errors. Tried manually inserting the IP and Port info, and the MyQ-Controller immediately reported “Invalid credentials”.

This is what the bridge server is showing on my last attempt:

And this is what the MyQ-Controller is showing:

Should I just start over? Any help would be appreciated…

All is now fine… shut down bridge server for a couple of hours, then restarted it and everything has been working fine for about a half an hour. Suspect it might have had something to do with this:

SmartThings Status - Aeotec Smart Home Hub, SmartThings Hub 2015 (v2), and SmartThings Hub 2018 (v3) Firmware Update


@brbeaird Thank you for this amazing work!

Just chiming in to let you/others know that I installed MyQ-Controller about a week ago on Windows10/64bit using your Windows Installer and it’s been working great !

Running a Samsung SmartThings v3 HUB.

After the SmartThings Firmware Update yesterday to 0.45.00011, MyQ-Controller stopped communicating between the HUB and Windows 10 Computer.

I shutdown/restarted the Windows 10 Computer: Did not communicate.

I then pulled Power from the SmartThings HUB, waited 1 minute or so, then powered back on. After the HUB fully booted (to green light status), MyQ-Controller instantly reconnected and is fully operational !

Oh… a mindful note to those running SmartThings v2 HUBS: Pulling the Power Cord is not enough. Pop the back off and remove the batteries as well.

Thanks again !!!

1 Like

or use the reboot option in IDE (while it is still available) and avoid pulling out the power cord or batteries :slight_smile:

Hi Scott, I followed the instructions but when it tried to connect to my NAS it just at there. I set it up using the 1900 UPD port and 8090 TCP and default server settings. But then tried the NAS IP address and local port on my NAS that was 49154. Once I did that is connected and found the device.

My set up seems to be working, but after reviewing the logs I’m concerned something may not be correct.

I see a myQ API Unable to retrieve account information
request to URL failed
and then a number of “Refresh failed” entries.

Any idea why and what I need to do?


Has anyone figured out a way to get notification if the door and/or controller go offline? @brbeaird are the device health parameters actionable the way the drivers work? Do they get the online/offline settings? Some of my terminology may be off due to my limited understanding of the drivers, but hompefuly this is clear.

This is a screenshot of the Automation that sends me a notification. I’m pretty sure it worked when I tested it but I haven’t had the MyQ off in some time.

I can check tonight when I get home and let you know.

1 Like

I have mine setup the same way without the duration. I can add that and test.

Hmmm, I have the same without the delay. It has never triggered and my machine running the MyQ server has been offline here and there.

EDIT: Well, actually I was monitoring the actual door device which also has the Health deal and it should work but it doesn’t for me. I’ve changed it to the controller device and we’ll see what happens.

I set up a routine identical to the above for the controller and for the door with a 5 min duration.

Controller says “searching for bridge server”, Door says “Offline”.

Neither routine has fired after 10+ min of turning off my bridge server exe file.

ok @brbeaird you are amazing. I got this up and running on my Synology NAS with little issue, and this is so incredible. Thank you for what you have done. Will be donating!

1 Like

@Nezmo ,
It appears mine is also non functional. I’m pretty sure it used to work?

I have another alert for edgebridge that’s on the same Pi. It has a longer delay. I’ll see if that one triggers as a test.

@brbeaird any ideas on this?

1 Like

So the other alert for the edgebridge monitor worked. So possibly something in Smartthings is messed up and causing it to not work with the MyQ driver

1 Like

That’s normal - the myQ API tends to bounce up and down. You’ll only notice a status change in SmartThings if it stays down for several minutes.

Interesting. I’ll have to do some testing and make sure it’s properly setting the health status.


Wow, yep - that was the issue. I never added the logic to fully update the health status capability when things go offline. That is now fixed, and I tested my own routines that correctly fired when it went offline and then back online. Nice catch @peeps /@TN_Oldman

New Edge driver should get pushed out within the next few hours. Timestamp will be 2023-01-21T00:09:47.988015388.


Thank you very much for such a quick fix!

I’ll test it tomorrow so driver has time to update!

@brbeaird This is so cool!

Is there anything I can do on my end to force an update and get the new Edge Driver?