[ST Edge] SmartThings MyQ Edge (Obsolete)

@jkp thanks!

That did it!

All three of our Overhead Garage Doors showed up in Smart Lock Guest Access.

Worth noting: Icons display as a Door Lock (which make sense of course), instead of a Garage Door, with no option to edit the Icon.


If you did it that way, you’re more than likely on the latest version. But you raise a good point - I’ll add something to output the version on startup and maybe also display it in the status endpoint.

1 Like

Hi Brian!

I had been using your Edge driver successfully for a while and recently started having issues with some door openings/closings not getting passed to the ST Hub. The myq.txt log file would show that it got the proper state from the MyQ server, but then I’d see errors/timeouts when it tried to connect to the local ST Hub.

I found this page and saw that there was an updated myQBridgeServer-win-x64.exe, so I stopped the service, downloaded and replaced the existing myQBridgeServer-win-x64.exe, and restarted the service. The log file now reads:

2/9/2023, 8:05:47 AM | HTTP server listening on port 61721
2/9/2023, 8:05:47 AM | SSDP server up and listening for broadcasts: urn:SmartThingsCommunity:device:MyQController

but smartthings edge:drivers:logcat --hub-address=192.168.1.xxx now shows issues trying to find the bridge.

2023-02-09T14:18:14.796367852+00:00 INFO MyQ Door ===== SCANNING NETWORK…
2023-02-09T14:18:16.805739228+00:00 ERROR MyQ Door ===== No MyQ Bridge found in

Any pointers of what to look for next?


After rebooting the ST hub, I now get these types of errors:

2023-02-09T14:28:52.605230133+00:00 TRACE MyQ Door Error making GET Call to Got [string “socket”]:1555: timeout response
2023-02-09T14:28:52.605979800+00:00 ERROR MyQ Door Door Garage Door 1 : failed to refresh.
2023-02-09T14:28:52.606654879+00:00 DEBUG MyQ Door Garage Door 1 device thread event handled
2023-02-09T14:28:52.614435695+00:00 TRACE MyQ Door Error making GET Call to Got [string “socket”]:1555: timeout response
2023-02-09T14:28:52.616165788+00:00 ERROR MyQ Door Door Garage Door 2 : failed to refresh.
2023-02-09T14:28:52.617936360+00:00 DEBUG MyQ Door Garage Door 2 device thread event handled

I noticed that the port isn’t matching up with the one currently being used by the bridge server.

Yep, your hub is not able to find the bridge server. It’s trying to auto-detect it over SSDP, but the bridge server seems to not be able to get those requests - possibly due to Windows firewall?

If you can’t figure that out, you probably need to fall back to specifying the IP/Port in the MyQ-Controller device in SmartThings, and you would also need to add a Windows environment variable to make the port static so it doesn’t randomly change each time the executable starts up.


I’ve been trying to find the MyQ-Controller device in ST, but can’t seem to find it; only the two garage doors that were created from before. What am I missing?

I rebooted the hub and since I can’t specify the port via the ST app, I changed the windows environment variable MYQ_SERVER_PORT to match the port I see it attempting to hit.

This is the new error message:

2023-02-09T20:42:51.041438047+00:00 INFO MyQ Door ===== SCANNING NETWORK…
2023-02-09T20:42:51.513950589+00:00 ERROR MyQ Door Garage Door 1 thread encountered error: [string “commands.lua”]:28: attempt to perform arithmetic on a nil value
2023-02-09T20:42:51.586720936+00:00 TRACE MyQ Door Error making POST Call to Got 404 response
2023-02-09T20:42:51.587293608+00:00 INFO MyQ Door ===== Ping failed for Garage Door 2 attempting auto-update.
2023-02-09T20:42:51.597873607+00:00 INFO MyQ Door ===== SCANNING NETWORK…
2023-02-09T20:42:52.925367070+00:00 ERROR MyQ Door Garage Door 2 thread encountered error: [string “commands.lua”]:28: attempt to perform arithmetic on a nil value

try SmartThings API Browser+. You will need to create a Personal Access Token. Go to the Devices section and see if it is listed. Then tap on details. It will show you what Room it is in.

You can also try in the ST app… go to the Devices section, tap on the Home icon in the upper left and select All Devices and look through each room.

I assume CLI provides details on devices as well.

Thanks for this!
Very nice interface to see everything via browser. I can’t locate it in the device list though, same as within the app. Wondering if it somehow mysteriously disappeared after I used it to create the two garage door devices. Not sure how to try to start from scratch, as I tried adding a new device/scan and nothing comes up.

Click on scan under Add Device

Nothing appears after several minutes. I also have the CLI open and watching the logs for the MyQ Door, and I am currently just seeing this every second:

2023-02-10T00:37:53.235631753+00:00 INFO MyQ Door ===== SCANNING NETWORK…
2023-02-10T00:37:55.744470457+00:00 ERROR MyQ Door ===== No MyQ Bridge found in network

At this point, I will step aside and let the developer help you. He is the expert :slight_smile:

You could try to delete the driver the re add it.

Ok, I think I’m making progress. For some reason I only had MyQ Door installed and not MyQ Connector.

I ended up deleting the two garage door devices and starting from scratch. All is working now. Thanks everyone!

1 Like

SO I am having some issues running the Edge on my NAS in Docker. I thought it was working at one point, but when I go look at the logs I am seeing:

MYQ_EMAIL & MYQ_PASSWORD are set as env vars for the container, and I can log into my account copying and pasting those values, so I know they are right

EDIT: NVM - I set the email & password as settings in the controller in the smartthings app, and it’s working again.

1 Like

Hi Brian

Running into a similar issue with the myq gateway and device being discovered but not getting added within Smart Things.

on the SmartThings MyQ-COntroller, i see Status: Connected: 1 devices and the correct myqserveraddress and port number.

Here is what i see under History tab on MyQ-Controller within SmartThings

for Windows users, check the firewall … :slight_smile:

ST hub and MyQ server are on the same subnet?

I’m afraid I’m giving up. Things worked great with Groovy, but it died today and I can’t get anything to work with the new Edge drivers. I am not a computer expert, but I am willing to plunge into the unknown in case I can get lucky. Just in case it is helpful, here is what I did:

  1. Successfully installed the new Edge drivers
  2. Tried many times to get Docker to work without success. I was able to pull down the image. Main problem was that I could never get the container to work on a Windows desktop. I kept getting an error message about invalid port '8090. When I tried container commands that others suggested, they also failed, usually because of some kind of format problem.
  3. EXE file booted up, but it was unable to find either of my two garage doors. I can see the IP addresses on my network just fine and they work fine with the pitiful MyQ app.
  4. I was intermittently able to find my two garage doors in the ST device scan when working with Docker, but they would never get beyond awaiting credentialing despite appropriate credentials.
  5. I’m running a smoking hot, totally updated Windows desktop.
  6. I could not figure out how to download the ST CLI.

Brian, I appreciate all that you have done to help us. I’m very sad that I am not able to get things to work. IFTTT sucks. If you can get this to work, $100 headed your way.

did a MyQ-Controller device appear in the ST app and did you open Settings and enter your MyQ email/password and server IP and port for the server on your windows machine?

do you have another computer (not from the windows machine the server is on) to try : http://server IP#:port#/status

1 Like

Look at my post here:

Also I think around post 168 I left another link to details in another thread on setting up and using CLI.

Also if you search this thread using CLI there’s abundant post on command lines to get the logs and people’s experiences.

I can’t help with your windows docker or windows executable setup. I did have it running in windows docker but since have moved to another device, and I Pie 3B a while ago.

Everyone here will try to help you and walk you through it, you’ll just have to share ALOT and be persistent.