[ST Edge] Philips Hue LAN [BETA] (3rd Party Driver, Not ST Native) (2024 workaround in post #736)

Thank you for your help and for quickly fixing the issue!

1 Like

Hi…I am on that driver version but have been experiencing issues since late yesterday evening…during which at some point my hub received the new firmware. Now lights are mostly unresponsive (but do respond occasionally to manual control and automations). Strangely, some rooms will turn on to an automation but fail to turn off to another automation a minute later. Nothing has changed regards the automations.

Any suggestions?

Thanks

I was able to get everything added properly. Two issues though which I am hoping you can assist with. First, I accidentally deleted a group and am not having any luck getting SmartThings to rediscover that group from Hue. Second, when using the Hue groups on ST, it does not give you the ability to change colors; only on/off & dim.

@bthompson/@ap77 Can you check something on your end. It sounds like ST pushed out the wrong driver again. In the previous case, the driver info in the app was not accurate. Can you please run these commands and DM me the result so I can verify:

Get a list of your devices

smartthings devices

Find a device that is not acting correctly and note its ID

smartthings devices DEVICE_ID

Hi, since I last posted, I had deleted my original Hue set up from ST so I didn’t have duplicate devices and now multiple devices will not update their status also. Everything seems to work ok for the most part but they go offline frequently. I think they may be what you’re looking for - e6accb72-c3ad-4866-8245-65f43b53a6a4 - Thank you so much!

I would need you to run the second command with that ID and DM it to me. I don’t have permission to view your devices directly.

I’m sorry, I’m afraid I’m not entirely sure how to do that but if you told me how, I’d be able to. Thanks again.

I’m back on the beta. The alpha worked flawlessly. When do you predict the switches will be released? :pray:

Glad it worked for you, but there were some stability issues for users that have a bunch of 3rd party stuff connected to their Hue hub. Although the Hue side of that is the root issue, the driver isn’t usable in those scenarios. Working to make the use of the advanced features (e.g. switches) configurable.

2 Likes

Only have the switches connected to hue. All other units are in the ST network.
Any date for when switches come online? Half the house lost functionality after going to beta.

I don’t have a firm timeline, but it is being worked on. I would caution you against relying on the alpha for anything more than testing. The beta will be more stable, but the intent is still exploration and getting time in real world use.

1 Like

Having the same problem. Was it solved for you?

14 posts were split to a new topic: My problems with Hue drivers

Please contact support. This thread is intended for feedback directly related to this specific driver. Any comments are shared with all 6000+ viewers.

I’ve been reading through (mostly) all of the posts on this thread and seen many issues that you seem to have solved, but I can’t quite figure my issue out. I’m running v3 smartthings hub…

I have installed your edge driver and made sure there weren’t any other hue drivers installed. When I add the hue bridge, it adds normally, but it doesn’t seem to be running the edge driver. It automatically adds in all of the hue bulbs running on the bridge, and doesn’t show any of the settings or even show the “driver” menu.

I’ve followed all instructions and repeated the process a few times with the same results. Sorry I’m sure I’m doing something stupid but I can’t figure it out!

SmartThings has their own DTH and Driver that they rolled out. Some users (mostly outside the US) seem to be getting their version instead of this driver. In those cases:

  1. Do not delete their hub device
  2. Go through discovery again and press the link button on the Hue hub
  3. This should bring in this version as theirs isn’t going to steal the link tap
  4. Now you can delete their version of the hub

I am working on a version to handle this as they have no plans to allow you to choose which driver to use in discovery, and you can’t switch the device after the fact due to the way they setup their IDs.

3 Likes

Worked like a charm. Thanks!

I’m now having a separate issue – I don’t know that it is specifically a Hue integration issue, since it seems to be happening also to my nanoleaf light panels… When I turn them onto their default (2700K, no color), they somehow automatically (time varies, sometimes 1 minute, sometimes 1 hour) turn to a light blue color. This is now happening will all of my hue color lights.

If anyone has any ideas or suggestions on how to rid the blue ghost from my system, I’d really appreciate it!

It’s unrelated to this driver, but you are probably best off looking at your history in the ST app to see what is triggering this. You could also shutdown the ST hub for a couple of hours and see if it still does it. If it does, I suspect something or someone is messing with your Hue and Nano systems.

It’s definitely something in ST, there’s nothing in history that shows a trigger, all that shows is that the hue and saturation are different. Removing all color bulbs for now from ST :sob:

I’d actually think it would be the opposite. If there is no trigger in your history, then it was triggered outside ST. The hue and saturation will update to sync with the light, but you should see a trigger for this in ST if ST caused it.