[ST Edge] Personal Tuya Devices - Generic EF00 Device

@Omer_harel
Try settings like this and leave it for 1-2 hours and then check. I have the same and with this settings it is working.

Hey.
Tried it. Shows not pre sent in anyway.
Waited 2 hours even more.
Put 112 in presence DP. Shows presence all the time.

It there another way? Maybe oyhe process / steps to do to make it work?
Someone?

I have the same device and this has happened to me so I just go near by device and wave my hand a few times till it detects present and then go out of the room and then come back where it detects presence as normal. Try this and let us know how it goes.

I cant get the device to detect motion either. It took a while to update its status from blank to not present but no amount of hand waving is changing it to present

Send some logs to @w35l3y, your settings of the DP looks OK. You put the correct DP’s for presence and illumination.

@w35l3y, any idea?

1 Like

You probably are using the wrong datapoints.

@w35l3y


Thats what im putting.

There isn’t any profile predefined for your device or similar ones.
The settings (sensitivity, near detection, far detection, detection delay and fading time) won’t work.

You will need a tuya hub or use the generic profile.

If you are OK with it, try using DP 112 or 105 for presence sensor.

Otherwise, I suggest you to read Contribute with your integration and create your own profile.

OK i will try all the ways and update here so People with the same sensor will learn.

1 Like

OK,
I tried all the pre defined setups. Every one I put 112 and wait.
Also tried 105 and Waited.

Its not working properly.
What does happen one a very very long time or on the first paring, it shows there is no presence, when I wave over it its changing to presence and not coming back when there is no presence.

Edit: the iluminance seems to work OK. When there is a dark room the lux is low. When I turn on the light its almost on the peak.

Any one can help with building a pro file for it or adding something that it could work?


1 Like

Are you sure you are using the right driver ?

Yes, I am with the main driver.
Have to say I tried all the drivers (beta, default, main😩)
Just not working.

@w35l3y
i attached link to a log . mabe you can help me (and others with this sensor)
i put 112 and switched to 105 on DP presence sensor.
the lux remains 104.

if you can help i will be happy. also if you need something, more info, things i can try and make output . im here :pray:

Has anyone managed to use this driver for presence sensor _tze200_2aaelwxk ?

[ZigBee presence sensir](Just found this amazing item on AliExpress. Check it out! US $12.44 50%OFF | Tuya WiFi / Zigbee Human Presence Detector,Luminance/Distance Detection, Smart Human Body PIR Sensor Support Home Assistant https://a.aliexpress.com/_oCOnLMm)

This is what I see in the info log when selecting a generic device:

What needs to be done to add it?
Tnx!

It only contains logs for ± 1 minute.
I would recommend at least 5 minutes of you don’t know what to look for.

With that log, the only thing I can read is what I have already said… this profile is not for your device.
There isn’t any error message, but it expects for datapoints that doesn’t exist in your device.

has anyone noticed a problem with battery display, i have two temperature sensors that have new rechargeable batteries in that are showing 19 percent ,
thanks
martin

The problem is that most battery operated smart home devices are made to use with Alkaline Batteries not rechargeable batteries.

Alkaline Batteries have a nominal voltage of about 1.5 volts. Rechargeable batteries typically have a voltage of only 1.2 volts. So SmartThings thinks your batteries are nearly dead due to this lower voltage.

An exception to this are the newer Ikea devices that are made to use with 1.2 volt rechargeable batteries.

6 Likes

thanks that explains that
thanks
martin

Got this today, did exactly what you said and paired perfectly. Also, created a virtual smoke detector through VEdge creator to set it up to work with SHM, wrote a couple of routines and it works perfectly.

In terms of testing, tried lighting a match stick and placing it near this gas detector but it doesn’t do anything, don’t have a cigratte lighter either so any other ways to do a quick test?

1 Like