[ST Edge] ONVIF-compliant IP Camera Motion Detection & Video Streaming - Testers Wanted!

Android or iOS?

iOS with a Hikvision camera

Guessing this was noted previously in the thread, but wanted to make mention of it…

I had one camera go offline (out of 5). Typically, if I reboot the camera remotely through the native Reolink App, it will come back online.

No such luck after 3 reboots and over the course of several hours.

Then I went to the My SmartThings Advanced web page, the Camera in question, and clicked “SwitchOn” and it immediately came online as I was watching the Device Card on my phone!

Before you did that, had you tried tapping either the refresh button or the Events switch in the device Controls screen in the mobile app?

1 Like

I “think” I did… as well as a “pull-down” on the device card to refresh… seems like everything was grayed out and I couldn’t tap on anything.

But the next time I see it happen, I will be sure to try those things first before heading to the SmartThings Advanced web page.


OK, thanks for reporting it. So the device was definitely in an offline state if everything was grayed out. It’s a bit of a catch-22 if you can’t tap the refresh button to get things working again. I’ll have a look at the code to see what could be done.

1 Like

Following up…

I had 2 (out of 5) Reolink Outdoor E1 Outdoor cameras go offline in SmartThings at 10:42am (while at the same time all were online/operable in their native ReoLink App as well as Blue Iris Stream).

The Device Cards indicated “Offline” at the top, and ALL of the controls WERE Grayed out. Could NOT click Refresh Button or the Events Button.

Went to My SmartThings Advanced, into each camera, clicked Push and SwitchOn several times, but this time neither camera came back online in SmartThings.

Tried rebooting the 2 cameras (in the ReoLink App) but they did not come back online in SmartThings.

Let me know if there is any info I can provide to help troubleshoot.

Typically after a while, they come online in SmartThings at some random time.

@TAustin i’ve played today with Doorbird devices, first started with driver v1.3 which seems to stop middle of soap, then tried driver v2 - which seems to work, at least - haha - i have camera picture. Motion is not working, maybe some extra settings on DoorBird necessary. Anyway, if you wish i can provide cli logs.

Hi - Those haven’t been tested before, so yes, please send along logs if you have them. Start logging then hit the refresh button in the camera device. Direct message me the logs rather than post here. If they are super long, which they may be, you can email them to me at rpi.smartthings@gmail.com

I can’t find the download on github… where can I download the android onvif drivers?

Drivers are installed via their channel invite link and are not specific to your mobile device. They run on your SmartThings hub, and you use your SmartThings mobile app to interact with them.

How can I be invited?

From the first post

I don’t see your channel

You need Hub to install drivers

Samsung SmartThings Hub 2015 (Hub v2)
Samsung SmartThings Hub 2018 (Hub v3)
Aeotec Smart Home Hub (the only one that can be bought)

For me, the video streaming has begun working again! Somewhere along the way a SmartThings app, hub firmware, or iOS update seems to have done the trick.

Hopefully others who had not been able to get it working before may have success now.

1 Like

@TAustin yes it’s bizarre, suddenly one of my three Reolink E1 Pro devices shows a video stream. But the other two, with exactly same firmware/hardware versions, I still can’t even add to a Camera Group. In fact, the three literally have the exact same settings in both your SmartThings driver on my android app, and the Reolink android app (and also the Reolink windows app, which as you know exposes additional settings). The only difference is the name of the cameras. Except… The working one I bought and installed yesterday, but the other two were installed and configured two months ago. Suspicious, eh?

What exactly happens when you try to? Are the devices not listed to select from or are you getting an error in the app?

If you have the CLI, can you capture some logs so I can see if there is anything unusual going on?

Hi @TAustin. Yes I should’ve been more specific than the standard “it doesn’t work”! Actually I have never had the problem I saw from previously in this thread where the menu item “Create camera group” didn’t appear for that subset of unlucky users - this has always been there for me, AFAIK. So the option to create is always there, but when I try to create a new group only the 2 pre-existing Cam360s that I own appear in the list, and none of my recent Reolink device purchases (all onboarded to ST using your driver) appear in the “Select cameras” list. Apart from the one I bought most recently, in the last week, which did, and showed streaming video 640w in the resultant Camera Group.

Except… now it doesn’t. The camera doesn’t appear in the list now, like the other Reolinks - it too has been filtered out. And no more streaming - when I go into the Camera Group the image for this one is now frozen in time and no longer updates - and clicking into it to navigate from the Camera Group to Camera page now shows a black empty frame. Strange. Now I’m suspecting that it’s been caused by a setting I’ve changed (as yesterday evening I was configuring some values in the Reolink app to match my other Reolinks). I need to work backwards, maybe do a restore to factory settings, and see if I can get it back.

Finally. Your suggestion to install the CLI might be more dramatic than you think. I’m actually a software engineer here in London and the “other half” has forbidden me from learning Lua or writing any ST/IoT related code whatsoever :wink: because there’s an unspoken understanding that if I open that floodgate it can never be closed again! :joy: as soon as I start writing Edge drivers that’s it, I’ll be glued to this PC and no-one will see me again for months. I think you know what I mean, right? :smile:

I feel a bit sneaky though, because I’ve just downloaded and installed the CLI. It’s a slippery slope :melting_face: I’ll either ping something that looks relevant from a condensed log or DM you something tomorrow morning. Now, I’m being called, so I gotta go!


Cli installed… slippery slope started :grin: look forward to your drivers :rofl: