[ST Edge] ONVIF-compliant IP Camera Motion Detection & Video Streaming - Testers Wanted!

I’ve reolink camera RLC-410W.

I find my cam
, I set user and pass… but I don’t see any video!! Have I do something else??

Did you create a camera group?

Are there any Reolink PTZ cameras known to work? How about the E1 Outdoor, any word on that model?

There is a link in the first post outling all aspects of the driver inc what works and what might not, your best bet is to install and see what happens

Here is some info from the link in the first post

I bought one off the known working list so I can familiarize myself with the process of adding to SmartThings. Was hoping not to go the trial and error route for any new purchases. Thank you for responding.

Trial and error was meant more for the driver in Smartthings, not purchasing, once the driver is added you only have to do a scan to see if your cameras appear, it is a pretty painless experience and definitely worth a trial and error go, just to see if your cameras appear

In the list that @fido posted, E1 model noted that doesn’t work is the indoor model. Not sure anyone has tested the outdoor model. The newer-released ones are your best bet, as the firmware on many of the older ones wasn’t ONVIF compliant, or had bugs.

Yes, I did


but it doesn’t work! it is connected

A couple questions:

  1. If you look in the camera info table, probably down at the bottom, what does it show for resolution?
  2. Are motion events being reported?

Hello @TAustin

I have a Tapo C100, but i only have one camera.
In the settings the Status is Responding

The drivers found two more cameras that are connected, but they belong to my neighbors (I shared the network with them) but I don’t have access to the cameras.

Shouldn’t the image of mine appear that is giving Responding? Or do I have to have at least another one configured?

At this moment when I try to see the image I get “thinking”

thanks

Hi there. Look in the info table and at the bottom you should see a ‘Resolution’ value. What does that say?

You need to define a camera group - with at least 2 cameras. But if you you got a SmartThings device created from your neighbor’s camera, and can use that in the camera group, that shouldn’t prevent your own configured camera from working. I assume you configured the correct userid and password?

I’d be glad to diagnose further if needed, but I’d need you to download and run the CLI tool so we can get a log.

hello, for some reason I wasn’t accepting it… I changed the login data and the image is already there!

Now all that’s missing is the motion detection function… that was really important for me… Because I have the camera in the garage and I’ve already suffered burglary attempts.

Do you think it’s in the near future?

Thanks

I’m glad you got the video working!

I worked with someone else (@Sakari) to try and get the motion detection working on their Tapo camera, but we were unsuccessful. I was even looking at buying one so I could test here. They aren’t very expensive, but the shipping to the U.S. was more than the camera itself unfortunately!

If you have lots of time and patience, I’m happy to continue trying to figure out the problem. You’d need to be able to download and run the CLI so we could get logs.

If you are trying out something new then I’m happy to contribute too.

1 Like

1 the resolution is low while in the camera is 4k


2 yes it is

I have 1920x1080 no problems. I think that 4K is not supported

A lower resolution is to be expected when the ‘Video Stream Selection’ device setting is set to sub stream. (This is the ‘preview’ resolution)

I’m not sure what the problem could be. Make sure you give it a long time for the video to come up; sometimes it can take as much as 20-30 seconds.

EDIT: You could try to change the Video Stream selection option to ‘Main Stream’. Be sure to tap the Refresh button on the Controls screen after you save your new setting.

I tried to reduce the resolution but no video started (I’ll wait a lot of time and I insert main stream . Nothing! it is all black

Sad to report I was unable to discover the Reolink RLC-510WA that I purchased. Would having two hubs cause an issue? When adding a device it asks me to select a hub prior to searching.

I don’t think so, but you never know!

We have a couple choices to proceed:

  1. Install & download the CLI so we can get some logs to see what’s going on.
  2. If we find we can’t get your camera discovered for whatever reason (usually it is network config issues), then I have a separate driver that allows you to manually create your camera device by providing its IP address. Then once you do that, you can move the device to the main ONVIF driver and use it normally.

EDIT: Additional thought: make sure you’ve gone through your camera settings to see if you have any ONVIF-related options. For example you may need to explicitly enable ONVIF or explicitly make your camera discoverable.