[ST Edge] ONVIF-compliant IP Camera Motion Detection & Video Streaming - Testers Wanted!

Yes, I’m sorry for the limitation. SmartThings is not even officially supporting video from Edge drivers, so we have to live with what we have. The way it works behind the scenes is that when video streaming is requested, SmartThings asks the driver for the streaming URL, which the driver had obtained from the camera during initialization. At this point, the driver is out of the equation and it is the SmartThings platform (likely the mobile app itself) that then uses that URL to get and display the video feed. So of course if the phone isn’t connected to your local network, it can’t access the URL which is a local network address.

I have not looked at dyndns, but I’ll try to. If we could somehow turn that local streaming URL into an internet-accessible URL, then maybe it could work.

1 Like

There’s no need to be sorry - you did a great job with the tools available to you and the limitations thereof - I understand this technical limitation, just disappointed with the overall situation, but still very grateful to at least be able to access them from home.

Yes - if we could maybe change the IP-based URL you get from the device during discovery, to one with a dyndns (or other dynamic DNS) URL and port number, then maybe we can at least configure our routers to do port forwarding to specific cameras. but I understand it is a lot of work as well, and possibly a lot of testing to be carried out, so, no stress, just look at it when and if you have the time to, - and if you feel like it. Really appreciate your hard work on this, even as it is!

Hey @TAustin, I realised over the past few days that a number of cameras stop working occasionally. I have to go into the detail view of each camera and find their onvifstatus status “Not responding”, and I have to refresh before I can see the stream once again (sometimes it takes a few refreshes before it reverts to a connected 'Responding" state) - and then it works fine, likely for a few days, though likely will revert at some state once again.

Is this normal, and is there any way I can avoid this happening? Can we perhaps have an auto-refresh happen occasionally to keep them connected? Not sure what’s possible here, just asking.

Hi Martin - Thanks for reporting this. I too have experienced this periodically. The last time it happened to me was when my hub got rebooted. I’ve only once been able to catch a log when the driver is just starting after a reboot (it’s a little tricky to do) and saw that there were repeated socket errors occurring. I need to determine what is causing this in the first place.

But regardless of solving that, it is the case that if the cameras don’t initialize at driver startup, then I should implement some kind of periodic retry until they do. I will definitely look at this for my next update, as I agree that it is important.

1 Like

Great - thanks a lot @TAustin, I look forward to it. I am not sure it happens after hub reboots, and to be fair, I have a number of hub reboots happening per week these days, as I am doing loads of exclusions and inclusions thanks to this Edge project. Will try to keep a record of reboots to see whether it is happening right after those - but in any case, thank you.

Hi, can you tell me how you managed to display the video in the smartthings app? I only got motion detection (I’ve even tested it as a routine trigger and it worked), but the image doesn’t appear.

Mine is an RLC 410W too.

I send below the information that appears in the smartthings app




@TAustin

@Filippo_Mori

Are there any special characters in your userid or password for the cameras, or anything unusual about them? We have found that in some cases this can cause problems with the authentication during the streaming request to the camera.

The user is the default admin and the password has only letters (uppercase and lowercase) and numbers…

Honestly, I don’t know what it could be.

I’m thinking of resetting my camera and trying everything again to see if anything changes.

The interesting thing would be someone who has already managed to put the Reolink RLC 410W to work to give a configuration tip…

I’m sorry you’re not having success. Someone has definitely reported that they had the 410W working OK. The only other thing I can think of is to make sure that you don’t have some config option that needs to be turned on for ONVIF support.

If you can, you could download the CLI and run some log outputs so I can see if anything is going wrong. But it looks to me like all the initialization completed OK.

So I just downloaded the driver and it successfully found all my foscam cameras. The problem I have is that inside the smartthings app, I have no labels on any of the camera details (i.e. below the box that says Motion sensor it has a box with a switch labelled untitled. I can see it is off but I can’t turn it on. The cameras are responding or so it says in the next ‘untitled’ box. My question is why are these untitled for me when I can see others have labels? Driver version is 2022-07-05T18:39:13… Also, I am unable to turn on motion detection (the on / off switch won’t turn on. Any suggestions?

Hi Troy - welcome to the community.

Unfortunately there was a SmartThings change made that broke all community-developed driver device labels. We don’t know if it will ever be fixed or if we all have to go back to do a bunch of rework to ever make them right again. The switch that you see below the motion sensor is for turning on and off motion events. The button at the very bottom is for refreshing the device.

The second bit of bad news is that Foscam cameras do not support motion event notifications through their ONVIF interface.

I have 410w working just fine. Look at mine video resolution. Maybe you have too high video profile set?

Thanks. It’s a good thought, but it looks like @Raimundo has the same resolution set according to his earlier screen shot.

Do you have the latest firmware available for that camera?

Thank you for the very quick reply. That is too bad about the labels and hopefully smartthings fixes that.
That is bad news about Foscam cameras not supporting motion detection since that makes this interface useless to me unless I want to just view the cameras. Thank you for writing this driver though.

I would like to let you know that it worked, it was the camera resolution that was preventing it from working correctly.

Thank you @TAustin

*After some tests, I realized that the image function itself is not very interesting, because it only works within the same network and anyway, it is easier to visualize using the camera app (higher resolution), but the detection functionality of movements is very good!

Hi @TAustin, after a hub reboot (I have plenty of reboots happening these days as I carry the hub with me around the house to exclude/include devices to convert them to Edge drivers) about 4 of my cameras reverted to Not Responding, and will not reconnect even after pressing Refresh.

In fact, I further worsened the situation by trying to kickstart one of the cameras by chnging its driver to Mariano’s Zwave Device Config driver (yes - I know it’s not a Zwave device of course), and then resetting it back to its original driver, thinking it would be re-initialised in this manner. Of course, this did not work - instead the device is currently unusable, showing only the following page.

What can I do to:

  1. Re-activate the cameras Not Responding; and
  2. Bring back to life the camera I managed to stop working as per image above.

Many thanks

To clarify your situation, do you have some cameras working and others not?

Yes - indeed, that is the case… only 2 of 6 are working now.

Just for future reference, what adjustment did you make to your camera settings? It looked like the resolution (640 x 360) was OK in the screenshot you posted.

And yes, I tend to agree that the manufacturer’s app will always be superior for viewing the video. It’s really the motion detection integration that’s more useful for most people.