[ST Edge] LG WebOS TV

I’m new here. Not sure why but I cannot see where I am to find the download link? Seems weird that it is not obvious. I am tech savvy enough… Yet failing to identify download link… Help please…

Very first post, click on the link. Enroll in the channel then once enrolled it will say “available drivers” or something like that and you can pick the driver. But warning this driver hasn’t worked for many, including me, so may not be worth the effort here.

it stopped working today so i removed it but cant re add it again ,
is it still being maintained or has it been abandoned @nayelyz


For anyone still interested in controlling their LG TV from SmartThings, and/or found that the earlier driver announced in this thread is no longer working: I have a new Edge driver that may work for you:

Please see my Github README file for more information on installation and useage.

Thanks to @montyfert for testing!


Thank you

Awesome, been waiting on an update to this Edge driver for a few months now. As always, appreciate everything you do for the community.

One call out, when I scanned for a new device, it found my TV, but the app showed a STATUS with a default IP address that was not my TVs address. I never received the registration popup on my TV. I went into my router and set the TVs IP to what showed in the STATUS field in the app and then I received the popup on my TV. Now the STATUS field in the app shows REGISTERED.

That’s interesting - do you run a mesh network, or is there anything else unusual about your network setup? VPN?

During SSDP discovery, the device answers a multicast network query and provides its IP address. Not sure why it wouldn’t be the right one. If you ever have the time or inclination in might be interesting to get some driver logs to verify what’s going on.

Same issue here with my living room TV showing up with a “phantom” IP address, and no pop-up appearing on the TV.

I logged into my router and can see no device connected at that address. I have the TV hard wired on a reserved IP at 192.168.10.XXX which is on the same VLAN as my Smartthings hub.

The first line of the log seems to discover a device with IP address 192.168.1.XXX (no idea what this is, this is the same IP that shows in the ST app Status box saying “Connect Retry”)
The second line finds the actual TV at 192.168.10.XXX but says it is “not an LG TV”

2023-11-21T20:51:41.627757803+00:00 TRACE LG TV V1.0  [disco] found device:	6666	[LG] webOS TV UN74006LB
2023-11-21T20:51:41.628838803+00:00 DEBUG LG TV V1.0  [disco] Responding device at is not an LG TV: USN=uuid:09c0b5a0-98bf-b5f4-7b91-75c74c8f0e20::urn:schemas-upnp-org:device:MediaRenderer:1
2023-11-21T20:51:41.630507803+00:00 DEBUG LG TV V1.0  [disco] Unexpected LG header from Living Room TV
2023-11-21T20:51:41.632044136+00:00 DEBUG LG TV V1.0  	Received Socket msg:	HTTP/1.1 200 OK
Cache-Control: max-age=1800
Server: Linux/i686 UPnP/1,0 DLNADOC/1.50 LGE WebOS TV/Version 0.9
USN: uuid:09c0b5a0-98bf-b5f4-7b91-75c74c8f0e20::urn:schemas-upnp-org:device:MediaRenderer:1
ST: urn:schemas-upnp-org:device:MediaRenderer:1
Date: Tue, 21 Nov 2023 20:51:39 GMT
DLNADeviceName.lge.com: Living%20Room%20TV

Hey @TAustin thanks for working on this driver. I tried it and and it found my LG TV but i’m unable to control it. The status says “Connect retry” and the IP address is incorrect. I updated the Mac address in settings but still no luck. You mentioned that a popup should show onscreen but not see any on my end. Anyway to manually update the IP address to match the router’s IP address?

As @skinnypope mentioned my IP address is also saying

@cog89, @skinnypope, @ny_robert
Thank you for the report. It turns out there are two different things I had to fix:

(1) there was some testing code inadvertently left in the driver that caused the IP issue (my bad!)

(2) Thanks to @skinnypope’s log I could see that the LG header being returned may have different contents from what I was expecting.

I’ve hopefully corrected both these issues and pushed out a driver update: Version 2023-11-22T19:22:59.514540542. So verify this driver has been updated on your hub, retry device discovery, and let me know if you have success.

1 Like

Thanks for the update @TAustin. There’s progress but still unable to control the TV. The IP address is correct but still says “connect retry”.

I deleted the driver and reinstall to get the latest version. Deleted the device and restart the hub then try adding but no luck

Did you get the registration popup on the TV?

It may be necessary to generate driver logs so I can see what it happening. Do you have the SmartThings CLI? If not, the link for a Windows install is here.

I can guide you on its use if needed.

Working well for me now thanks Tod.

Updated the driver, deleted existing device and re-ran discovery. TV appeared and I got a pop up on the TV to grant access.

I’ll play around with it over the coming days, but initial testing shows all the basic volume / channel / input commands working, and the media switching has all added loads like Amazon, Apple etc under “Play a favourite” that were missing in the original driver.

[One thing I will test is having more than one LGTV in the house. I switched off the two other LGTVs in our house at the wall before running discovery for this one. Will report back in due course]

1 Like

Some quick things after some very light fiddling around.

  1. The power state seems a bit flakey. One example is that switching the TV off with the physical remote, does not mirror in the ST app where the TV remains as “On”. Also if the TV is on, but switches to the screen saver after some inactivity, the ST app shows the TV as “Off”.

  2. The volume seems to only control the TV internal speakers? I have a soundbar that the physical TV remote controls, but the app doesn’t seem to.

  3. The Media Inputs list is below, however the TV inputs are “Live TV” and HDMI 1-4, so I am missing “Live TV” and HDMI4.

Let me know if you need any logs

I guess this is not surprising, since if you turn the TV off, it can no longer provide updates of its state. So the SmartThings driver is kind of left in limbo. I’ll have to think about if there is any way to address this.

This must be because that’s what the TV is reporting. I’ll have to look to see if there is another indication to distinguish between screen saver and actual power, but I don’t think there is.

Not too sure if I can do anything about this. I don’t see any commands that allow you to specify internal vs. external speakers.

I can add these, but need to see see your log (see below).

I’ve pushed out a driver update: Version 2023-11-24T00:37:14.891856547. Once you’ve confirmed it’s been updated on your hub. Start logging and do a swipe-down gesture on the Controls screen of the device to force a refresh. Capture that log and send to me in a direct message.


FYI to all, I’m going to be working out some of these kinks with @skinnypope in a separate thread. Will report back here on an updated driver when ready.

1 Like

Thank you for developing the driver. It’s very useful for automations. I have installed it and using it with LG G3 webOS 3.20.17

I was able to pair the driver. All functions seem to work on the main device screen, however only on/off function seems to work in routines or automations.

A few things I needed to do that may help others.

  • set the TV IP to a static ip, driver does not seem to have a way to update it
  • connect the TV via LAN, leave TV WiFi enabled but not connected
  • Turn Quick Start + off

I will look into that. Thanks for reporting.

Thank you for the driver. I can send commands but
It seems like the driver is not subscribed to the TV events.

For example, I can turn on the TV via the app, but when I turn it off using the remote, the status in the app stays “ON”
also, I got an error

2023-11-29T21:36:13.279190346+00:00 INFO LG TV V1.0 <Device: 493364d5-5a4f-4c4d-8bdd-bc19355d7ae6 (TV)> emitting event: {“attribute_id”:“switch”,“capability_id”:“switch”,“component_id”:“main”,“state”:{“value”:“on”}}
2023-11-29T21:36:13.291159346+00:00 ERROR LG TV V1.0 Invalid MAC Address <<
2023-11-29T21:36:13.297744346+00:00 DEBUG LG TV V1.0 TV device thread event handled

I’m working on some updates to the driver which will address this. Hope to have it pushed out in another day or so.

The error you referenced is because you haven’t configured your TV’s MAC in the device Settings screen. This is required to be able to turn the TV on, since it uses a Wake-on-LAN packet. Although you say you were able to turn the TV on, so I’m kind of confused about that one!