[ST Edge] Issues with released Drivers

Back home now and all my motion sensors are online again without my doing anything. I’d like to think it was the motion events that put them back online. Recovering from being offline is great but I’ve yet to figure out what put them offline to start with.

Just pointing out that the ocf device type for illuminance sensors never had an icon so that’s not a new issue.

Just tried the Sonoff SNZB-04 contact sensor, which identifies as the eWeLink DS01, with the Zigbee Contact driver. Initial reaction is open/closed looks fine but there may be issues:

  1. It looks like the profile being used includes the temperatureMeasurement capability. I’d be delighted if it did support that but I don’t think it does.
  2. The battery level with the DTH was 60%, which sounds reasonable, but the Edge driver is reporting it as 3%. OK, the second one I tried had 74% in the DTH but is showing 69-70% in Edge which seems fair enough so I changed the battery in the first and tried again and got 100%. So that is probably OK. No wonder they are practically giving these things away at the moment.

Update:

  1. One of my devices that had been open since about 14:30 was showing offline when I just looked (about 18:30). Closing it brought it back online.

The Sengled and at least one of the Nyce contact sensors in that driver don’t support temperature either. I’m surprised there isn’t a sub-driver without temperature capability.

I believe this is the fingerprint that the “Sengled” device matches, right?

contact-battery-profile only includes the contact and battery capabilities, does the temperatureMeasurement tile appear in the device UI?

Do you know which is the other Nyce device that doesn’t include this capability, @Automated_House?

It’s different from the profile used by eWeLink DS01, which indeed includes the temperatureMeasurement capability. I’ll report that, @orangebucket to see if there was an error assigning the profile.

The Nyce one is correct. I missed the different deviceProfileName set for it. Thanks!

1 Like

To test the Beta Contact Sensor edge driver, since it did not detect my open/close sensor as compatible, I have added the LIDL open/close sensor fingerprint with contact-battery-profile.

  - id: "LIDL Open/Close Sensor"
    deviceLabel: LIDL Open/Close Sensor
    manufacturer: _TZ1800_ejwkn2h2
    model: TY0203
    deviceProfileName: contact-battery-profile

It is working well.

  • The configuration seems well done, since it reports the status every 300 sec, according to the default configuration.
    The battery also reported a change since installation and have the percentage remaining calculation.
  • The same thing happens to the edge driver smartthings multiporpuse sensor. It does not appear in the status monitor of the favorites page when it is open.
    More specifically, if the sensor is open when you install it, it appears in the status monitor. When you close the app and reopen it, it no longer appears

Do you happen to have any Lidl motion sensors? Motion Sensor driver needs Lidl fingerprint :relieved::grinning_face_with_smiling_eyes:

I’ll try it as soon as I can and tell you something

Modified edge driver “zigbee Motion Sensor” with LIDL Motion Sensor fingerprint with motion-battery profile works fine.

I will update if any problem appears

  - id: "LIDL Motion Sensor"
    deviceLabel: LIDL Motion Sensor
    manufacturer: _TZ1800_fcdjzz3s
    model: TY0202
    deviceProfileName: motion-battery

This is great and needs to be added to the official driver eventually. :relaxed::pray:

Yes, right.
Adding this fingerprint data to the fingerprint.yml file

and then doing the package and publish with the CLI.
Installation in the hub can be done with the CLI or from the app by opening the Drivers option in the hub menu.

Uninstall the sensor and reinstall it by searching nearby

1 Like

In the drivers page of the Hub, when you exceed what can be seen on a page, it does not scroll down and you do not see all data

1 Like

Thank you for sharing, this is already reported. We’ll let you know about the progress. :smiley:

2 Likes

@nayelyz I have an enhancement request for the driver channel webpage. It would be nice if their was a drop down below each driver that showed the deviceLabel entries of the fingerprints.yml file for the driver so its easier to tell what devices it supports. It’s impossible to tell from this view which driver I need to install for a certain device

2 Likes

Thank you for sharing your idea. I’ll create the enhancement request. :smiley:

2 Likes

Looks like this just got fixed

1 Like

I have an iris motion sensor. I added it using the Zigbee motion sensor edge driver. It does not show any motion. Automation does not work.

Edit: I removed the device and rebooted the hub. I reinstalled the device. Now I see motion, battery %, graphics and temperature. When I use it in an automation, nothing happens.

Just got around to looking at that. It looks like the profile for the Sonoff (eWeLink DS01) has been replaced by one that only has the Contact Sensor, instead of by one with the Contact Sensor and the Battery. That will be worse …

Fingerprint:

- id: "eWeLink/DS01"
    deviceLabel: eWeLink Open/Closed Sensor
    manufacturer: eWeLink
    model: DS01
    deviceProfileName: contact-general

Profile:

name: contact-general
components:
- id: main
  capabilities:
  - id: contactSensor
    version: 1
  categories:
  - name: ContactSensor

@nayelyz

1 Like